Download it now!
Bug 54097 - : jump lists to recent files
Summary: : jump lists to recent files
Status: RESOLVED DUPLICATE of bug 45600
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-26 21:05 UTC by Lew
Modified: 2013-04-10 16:13 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lew 2012-08-26 21:05:28 UTC
Problem description: W7 task bar icons for Writer and Calc do not show their own recent or pinned files.

Steps to reproduce:
1. pin LO Writer and Calc to the taskbar.
2. open some .odt and .ods files from W7 explorer/directories
3. right click on the taskbar icons

Current behavior:

Right-clicking the task bar icons only shows the program name and "unpin from taskbar".

I've relied on OO Writer and Calc to show their own recent files from their own jumplists by right clicking their task bar icons. I also like having the files pinned permanently in that location.  OO/AOO do this, so I suspect that it has to do with settings or installation of LO.

Expected behavior:

I'd like to see files that I've pinned appear first, and then a number of recently files.  I'd like the Writer .odt and other files that Writer opens by default (.txt, .doc) appear.  I'd like the Calc .ods and other files that Calc opens by default (.xls, .cvs) appear.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Comment 1 Roman Eisele 2012-09-12 12:58:10 UTC
A Windows issue, therefore adapted “Platform” field.”
Comment 2 gioni 2013-02-14 21:33:59 UTC
same behaviour on 4003.
Comment 3 Joel Madero 2013-02-21 18:51:33 UTC
Version is the oldest version that we see the issue, not the latest we've tested. We just use comments to say we've tested on a newer release and it's still a problem. 

Changing version back.
Comment 4 V Stuart Foote 2013-03-01 09:18:25 UTC
Enhancement - per QA guidlines, marking as Resolved - Fixed. 

This behavior on Windows 7 is correct for LibreOffice's cross platform core.

Enhancing with Windows specific code to instrument use of Microsoft Taskbar Jump Lists, including problematic calls needed to record into the Windows registry, is clearly an Enhancement that a DEV would have to take on.  It possibly could be integrated into the Windows Explorer Shell integration modules to facilitate inclusion/omission on install. 

refs:
http://msdn.microsoft.com/en-us/library/ff770767.aspx

http://blogs.windows.com/windows/archive/b/developers/archive/2009/06/25/developing-for-the-windows-7-taskbar-jump-into-jump-lists-part-2.aspx
Comment 5 V Stuart Foote 2013-03-01 11:20:25 UTC

*** This bug has been marked as a duplicate of bug 45600 ***
Comment 6 gioni 2013-04-10 16:13:43 UTC
LO 4.0.2.2 still unresolved