Download it now!
Bug 54160 - EDITING: Sorting Table with Column-Header
Summary: EDITING: Sorting Table with Column-Header
Status: RESOLVED DUPLICATE of bug 53482
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
: 55220 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-08-28 14:53 UTC by martin.pasi
Modified: 2013-11-16 12:57 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Bugzilla1 (16.44 KB, image/png)
2012-09-03 07:56 UTC, martin.pasi
Details
Bugzilla2 (6.18 KB, image/png)
2012-09-03 07:57 UTC, martin.pasi
Details
simple test file (7.86 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-10-11 20:51 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description martin.pasi 2012-08-28 14:53:24 UTC
Problem description: 
When marking a comlpete table and sorting the table with a Column-Header (Option "Bereich enthält Spaltenbeschriftungen") the header is sorted into the table. Doesn't work when marking just a few columns.

Example:
   A        B
01 Header1  Header2
02 123      456
03 789      012

After sorting for "Header2":
   A        B
01 789      012
02 123      456
03 Header1  Header2

Steps to reproduce:
1. Mark complete table
2. Sort
3. Select Option "Bereich enthält Spaltenbeschriftungen"
4. Select column to sort

Current behavior:

Expected behavior:
Header should stay in first row.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Comment 1 Jean-Baptiste Faure 2012-09-01 10:32:06 UTC
I do not reproduce the problem with LO 3.6.1 under Ubuntu 11.10

Please upgrade to current release and try again. If that does not work, please attach your test file.

Best regards. JBF
Comment 2 martin.pasi 2012-09-03 07:56:58 UTC
Created attachment 66529 [details]
Bugzilla1
Comment 3 martin.pasi 2012-09-03 07:57:26 UTC
Created attachment 66530 [details]
Bugzilla2
Comment 4 martin.pasi 2012-09-03 07:58:03 UTC
Hi,

I already upgraded to 3.6.1 (please note that I work with Windows 7). With the new version I still got the problem. It comes with every table I tried (some I created on my own, some I got from externals).

You have to mark the complete table (and not only some parts) in the upper left corner of the table, where the column and row counters meet. When the sort-window opens, column-headers are not recognized and I have to set the option manually and choose a column. When sorting the option seems to be ignored.

 <Bugzilla1>

After sorting:

  <Bugzilla2>

Test-table only contains:

TEST1    TEST2
123         789
456         234
324         951

Regards,
Martin
Comment 5 Nick 2012-09-13 14:48:56 UTC
I can confirm this fault exists in 3.6.1.2 (Windows XP SP3).

I sorted a large csv file (26,300+) lines with column headers. I ticked the option to say there were column headers in the file, which were displayed in the sort list. After the sort the column headers had been sorted into the data. In this instance they were placed into the next to last row.
Comment 6 Nick 2012-09-13 15:43:42 UTC
Further tests have shown that the problem exists when the whole sheet is selected (by clicking the left-hand corner) but not when selecting just the columns with data in. I selected columns A-AG in my worksheet and sorted the data as before, the column headers were still in row 1 after the sort.
Comment 7 Jean-Baptiste Faure 2012-09-15 06:04:09 UTC
Reproducible. The important words are: "When marking a complete table".

Best regards. JBF
Comment 8 Jean-Baptiste Faure 2012-09-15 08:39:57 UTC
*** Bug 54360 has been marked as a duplicate of this bug. ***
Comment 9 domi 2012-09-18 12:30:25 UTC
confirm 3.6.1.2 version
under windows and ubuntu (from last ppa)
Comment 10 Egil Hansen 2012-10-04 16:15:57 UTC
*** Bug 55220 has been marked as a duplicate of this bug. ***
Comment 11 Egil Hansen 2012-10-04 16:17:17 UTC
Bug still there in 3.6.2
Comment 12 Jean-Baptiste Faure 2012-10-04 17:41:49 UTC
Please, do not change the version number. It gives the oldest version in which the bug is known reproducible, not the newest.

Best regards. JBF
Comment 13 Julien Nabet 2012-10-11 20:51:29 UTC
Created attachment 68455 [details]
simple test file

On pc Debian x86-64 with 3.6 sources updated today I reproduce the problem.
With 3.5 sources updated today, I don't reproduce the problem.

Here are the steps:
- Control A (to select all the cells)
- Choose Menu Data/Sort
- Click "options" tab and check "Range contains column labels" if it's already checked
- Click "Sort criteria" tab and select "heading1" for example + let "ascending" order by default

Results: labels are also sorted

I don't reproduce this on 3.6 if I select exactly A1:B3

(about master sources, I can't test for now, I suppose I must run a "make clean && make")
Comment 14 Julien Nabet 2012-10-11 20:55:25 UTC
Markus: I know there are other bugs concerning headings but would you have some time to take a look?

(following my previous comment, tagged as regression)
Comment 15 Rainer Bielefeld Retired 2012-10-15 05:44:16 UTC
DUP of "Bug 53482 - UI: Option 'Range contains column headings' ignored"

@All:
Please check of fix heals all aspects you observed here, this bug seems related to some other effects.

*** This bug has been marked as a duplicate of bug 53482 ***