Bug Hunting Session
Bug 54259 - FILESAVE: When saving in MSWord .doc format, some table cells unmerged so data not shown properly
Summary: FILESAVE: When saving in MSWord .doc format, some table cells unmerged so dat...
Status: RESOLVED DUPLICATE of bug 54862
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 54262 (view as bug list)
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2012-08-30 10:02 UTC by Timur
Modified: 2014-08-15 12:30 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
LO bug 54259 - 1 Table saved in ODT (13.31 KB, application/vnd.oasis.opendocument.text)
2012-08-30 10:05 UTC, Timur
Details
LO bug 54259 - 2a Table can be saved in DOC LO 355 (16.00 KB, application/msword)
2012-08-30 10:06 UTC, Timur
Details
LO bug 54259 - 2b Table then saved in DOC LO 361 (15.50 KB, application/msword)
2012-08-30 10:06 UTC, Timur
Details
LO bug 54259 - 3a Table saved in DOC LO 361 opens fine in Word 2010 (64.89 KB, image/jpeg)
2012-08-30 10:08 UTC, Timur
Details
LO bug 54259 - 3b Table saved in DOC LO 361 opens wrong in Writer 361 (68.32 KB, image/jpeg)
2012-08-30 10:08 UTC, Timur
Details
LO bug 54259 - 2c Table saved in DOC LO 370 master 2012-08-30 (16.00 KB, application/msword)
2012-08-30 10:37 UTC, Timur
Details
LO bug 54259 - 3c Table saved in DOC LO 370 opens not quite correctly in Writer 370 (80.80 KB, image/jpeg)
2012-08-30 10:37 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2012-08-30 10:02:01 UTC
To produce file with this problem:
1. Open attached document with table in LO Writer 3.6.1
2. Save document as DOC
3. Open DOC document in LO Writer 3.6.1, table lines and data not shown properly
Comment 1 Timur 2012-08-30 10:05:07 UTC
Created attachment 66327 [details]
LO bug 54259 - 1 Table saved in ODT
Comment 2 Timur 2012-08-30 10:06:02 UTC
Created attachment 66329 [details]
LO bug 54259 - 2a Table can be saved in DOC LO 355
Comment 3 Timur 2012-08-30 10:06:37 UTC
Created attachment 66330 [details]
LO bug 54259 - 2b Table then saved in DOC LO 361
Comment 4 Timur 2012-08-30 10:08:06 UTC
Created attachment 66331 [details]
LO bug 54259 - 3a Table saved in DOC LO 361 opens fine in Word 2010
Comment 5 Timur 2012-08-30 10:08:51 UTC
Created attachment 66332 [details]
LO bug 54259 - 3b Table saved in DOC LO 361 opens wrong in Writer 361
Comment 6 Timur 2012-08-30 10:12:18 UTC
To reproduce the problem:
1. Open attached document with table in LO Writer 3.5.5 and 3.6.1
2. Save document as DOC in LO Writer 3.5.5 and 3.6.1 
3. Open DOC documents in LO Writer 3.5.5 and 3.6.1 and Word 2010
DOC from LO Writer 3.5.5 opens fine, DOC from LO Writer 3.6.1 opens wrong in LO Writer 3.6.1 with table lines and data not shown properly, but opens fine in Word 2010. 
Looks like a regression to me.
Comment 7 Timur 2012-08-30 10:37:00 UTC
Created attachment 66334 [details]
LO bug 54259 - 2c Table saved in DOC LO 370 master 2012-08-30
Comment 8 Timur 2012-08-30 10:37:30 UTC
Created attachment 66335 [details]
LO bug 54259 - 3c Table saved in DOC LO 370 opens not quite correctly in Writer 370
Comment 9 sasha.libreoffice 2012-08-30 10:39:38 UTC
Thanks for bugreport
Reproduced. In my tests with first attachment cell merging is lost during saving into doc format in 3.3.4, 3.5.5, 3.6.1 versions on Fedora 64 bit.
Changing version to 3.3.4 as most early reproduced
Comment 10 sasha.libreoffice 2012-08-30 10:41:35 UTC
Slightly resembles Bug 35991
Comment 11 Timur 2012-08-30 10:47:52 UTC
DOC from LO Writer 3.5.5 created on Ubuntu 12.04 32bit opens correctly on the same version, but in LO Writer 3.6.1 on Windows 7 64 bit shows all data, while table lines are not correct
DOC from LO Writer 3.6.1 opens wrong in LO Writer 3.6.1 with table lines and
data not shown properly, but opens fine in Word 2010
DOC from LO Writer 3.7.0 master  2012-08-30 opens better than 3.6.1 but still
not quite correctly (opens in Windows like 3.5.5, with additional lines in table)
Comment 12 Timur 2012-08-30 10:49:37 UTC
"table lines are not correct" and "additional lines in table" really means that "cell merging is lost", thank you.
Comment 13 Timur 2012-08-31 11:02:11 UTC
After some more experiments it seems to me that there was a problem with export of a table with merged cells to DOC even before, until LO 355, but somehow import was better. From 360, import is a problem, so cells are unmerged. 

Something like this.
DOC from LO Writer 3.5.5 with merged cells opens correctly on the same version, but in LO Writer 3.6.1 cells are unmerged
DOC from LO Writer 3.6.1 opens wrong in LO Writer 3.5.5 and LO Writer 3.6.1 (cells unmerged and data not shown), but opens fine in Word 2010
DOC from LO Writer 3.7.0 master 2012-08-30 also opens wrong (cells unmerged although data shown)
Comment 14 billhook 2012-09-03 03:52:42 UTC
*** Bug 54262 has been marked as a duplicate of this bug. ***
Comment 15 Timur 2012-09-03 11:29:45 UTC
After even more experiments, this is a current summary:
DOC with table with merged cells exported from LO Writer 3.4.5 or 3.5.5 opens correctly on the same version (except in LO Writer 3.5.6 on Fedora 64bit), but in LO Writer 3.6.1 and 3.7.0 cells are unmerged.
DOC with table with merged cells exported from LO Writer 3.6.1 opens wrong in LO Writer 3.6.1 (cells unmerged and data not shown), but opens fine in LO Writer 3.4.5, LO Writer 3.5.5 and Word 2010.
DOC with table with merged cells exported from LO Writer 3.7.0 master 2012-08-30 also opens wrong in LO Writer 3.6.1 or LO Writer 3.7.0 (cells unmerged although data shown), but opens fine in LO Writer 3.4.5 and Word 2010.

LO Writer 3.4.5 tested on LMDE 32bit, LO Writer 3.5.4 tested on OpenSuse 32bit, LO Writer 3.5.6 tested on Windows 64bit and MS Word 2010 tested on Windows 64bit open all documents fine, except DOC created with LO Writer 3.5.6 on Fedora 64bit. 
My conclusion is therefore that this bug is different from Bug 35991.
It seems that bug started in 3.6.0 (opens all wrong). It shouldn't be 3.3.4. I put 3.6 but I kindly ask Sasha to test on other platforms than Fedora.
Comment 16 sasha.libreoffice 2012-09-04 07:32:13 UTC
in 3.6.0rc on Windows I noticed some problem with _opening_ doc file that contains merged cells. But not have more new version of LO on Windows. So, opening may be already fixed.
Comment 17 Dmitry 2012-10-03 11:42:52 UTC
I experience the same problem. After hours of playing around it I found that the issue is reproduced in 64-bit systems only.
Table cells saves as merged in 32-bit versions but loose merging when saved in 64-bit environments.
Comment 18 billhook 2012-10-06 21:53:54 UTC
This bug is definitely happening in 32 bit Windows on 3.6.1. See the sample document in bug 54262 for a reproducible test case.
Comment 19 Roman Eisele 2012-10-08 07:33:57 UTC
Can someone please check if this could be the same issue as Bug 54862 - “FILEOPEN, TABLES: Merged table cells from .doc file appear split in Writer (regression)”?

If yes, there are good new -- bug 54862 is fixed in master and 3.6 daily; therefore, if this is the same issue, it should no longer be reproducible in current master (daily) and 3.6 daily builds. Can you please test this? Thanks!
Comment 20 Timur 2012-10-08 09:06:51 UTC
(In reply to comment #19)
> Can someone please check if this could be the same issue as Bug 54862 -
> “FILEOPEN, TABLES: Merged table cells from .doc file appear split in Writer
> (regression)”?
> 
> If yes, there are good new -- bug 54862 is fixed in master and 3.6 daily;
> therefore, if this is the same issue, it should no longer be reproducible in
> current master (daily) and 3.6 daily builds. Can you please test this?
> Thanks!

I tested with 3.6. daily on Windows 7 64 bit and looks OK to me. 
It would mean that Bug 54862 was a duplicate of this one, but that one was solved.
Comment 21 Roman Eisele 2012-10-09 08:00:02 UTC
@ Timur:
Thank you very much for your additional testing and answer!

I can confirm that: if I save the .odt sample file in .doc format, and open it again, the LOdev (3.7) master build dated 2011-09-30 still shows the table wrong (like on the screenshots), but the master build dated 2011-10-04 shows the table correctly, just like in the .odt file. Tests done on Mac OS X 10.6.8 (Intel).

Therefore I propose to close this bug as RESOLVED/DUPLICATE of bug 54862, because this issue was fixed very very probably by the fix for bug 54862, too.

This fix will appear in LibreOffice 3.6.3 (coming soon!) and 3.7, of course.


@ Everybody:
Feel free to open this bug report again if you can reproduce *exactly* the original issue with a LibreOffice 3.6.3 or master daily build *after* 2012-10-04, or with a LibreOffice release version >= 3.6.3. If you can reproduce a similar, but not identical issue, please file a new bug report for it instead.

Thank you very much!

*** This bug has been marked as a duplicate of bug 54862 ***