Download it now!
Bug 54452 - AutoInput: view more completions with Control+Tab or Control+Shift+Tab broken
Summary: AutoInput: view more completions with Control+Tab or Control+Shift+Tab broken
Status: RESOLVED DUPLICATE of bug 48868
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: (target:3.6.2)
Keywords:
Depends on:
Blocks: AutoCorrect-Complete
  Show dependency treegraph
 
Reported: 2012-09-03 17:37 UTC by Peter Head
Modified: 2016-10-19 23:31 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Head 2012-09-03 17:37:04 UTC
Ctrl-Tab no longer cycles the highlighted item through the matching alternative items.
Comment 1 Rainer Bielefeld Retired 2012-09-04 18:07:41 UTC
NOT reproducible with  "LibreOffice 3.6.1.2  German UI/ German Locale [Build-ID:  e29a214] on German WIN7 Home Premium (64bit), but I do not know whether I understood the prolbem.

I highlighted 4 Cells A13, C9, E18, C21, and <Tab> will jump around one by one of the highlighted cells.

@Peter Head
No Idea what the problem might be.
May be hints on <http://wiki.documentfoundation.org/BugReport> will help you to find out what information will be useful to reproduce your problem? If you believe that that  is really sophisticated please as for Help on a user mailing list
Please:
- Write a meaningful Summary describing exactly what the problem is
- Attach a sample document (not only screenshot) or refer to an existing 
  sample document in an other Bug with a link; to attach a file to this 
  bug report, just click on "Add an attachment" right on this page.
- Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
- Contribute a document related step by step instruction containing every 
  key press and every mouse click how to reproduce your problem 
  (similar to example in Bug 43431)
– if possible contribute an instruction how to create a sample document 
  from the scratch
- add information 
  -- what EXACTLY is unexpected
  -- and WHY do you believe it's unexpected (cite Help or Documentation!)
  -- concerning your OS (Version, Distribution, Language)
  -- concerning your LibO localization (UI language, Locale setting)
  –- Libo settings that might be related to your problems 
  -- how you launch LibO and how you opened the sample document
  –- Whether your problem persists when you renamed your user profile before you
     launch LibO (please see
     <https://wiki.documentfoundation.org/UserProfile#User_profile_location>)
  -- everything else crossing your mind after you read linked texts
Comment 2 GerardF 2012-09-04 19:32:45 UTC
(In reply to comment #1)

> No Idea what the problem might be.

I think reporter refers to autocompletion.
Ctrl+Tab toggles between autocomplete proposals.

to Peter Head, can you confirm ?

In this case, this issue can be close as DUP of https://bugs.freedesktop.org/show_bug.cgi?id=48868.
Will be fix in 3.6.2
Comment 3 Peter Head 2012-09-04 20:20:26 UTC
My bug report refers to AutoInput in the spreadsheet module. See:
http://help.libreoffice.org/Calc/AutoInput

Example from how I use spreadsheet to generate a work report:
Set cells B20, B21 etc as shown here:
B20 dtp - agenda for trustees meeting
B21 dtp – conference programme
B22 dtp - journal
B23 dtp - minutes of meeting
B24 writing agenda
B25 writing minutes
B26 writing report
These are just a few of the standard phrases I use (I set these cells B20:B99 as protected and not to print).

Check that option Tools | Cell Contents | AutoInput is checked. Now in cell A1 type today's date, eg "4 Sep" and in cell B1 type "d" as the work item. It will auto-complete to be "dtp - agenda for trustees meeting" and the cell will be highlighted. But suppose we want the 3rd matching item "dtp - journal? In this case, we should be able to cycle through the matching items (B20:B23) by typing Ctrl+Tab -- i.e. pressing Ctrl+Tab should change cell B1 to be "dtp - conference programme". Press Ctrl+Tab again should give "dtp - journal".

However, this Ctrl+Tab feature (which I have used since OpenOffice was first released) is not implemented in this version of LibreOffice.
Comment 4 Rainer Bielefeld Retired 2012-09-05 04:51:51 UTC
[Reproducible] with  "LibreOffice 3.6.1.2  German UI/ German Locale [Build-ID:  e29a214] on German WIN7 Home Premium (64bit).
Auto Complete in Writer still works fine, but viewing alternatives for AutoInput in Calc is no longer possible. In Help it's still mentioned.

Already broken with
- 3.6.0.4
- Server installation of Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 7175cee]" (tinderbox: Win-x86@6-fast, pull time 2012-05-16 22:07:37)
- Server installation of  Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 475d0c5-829fc92-39746e8-206648e-fefd87]" (2012-02-14)


Works fine again with parallel installation of Master "LOdev  3.7.0.0.alpha0+   -  ENGLISH UI / German Locale  [Build ID: 6cad15d]"  {tinderbox: @6, pull time 2012-09-03 23:08:07} on German WIN7 Home Premium (64bit)  (installation without Base)

I will do an additional test with a branch version, may be has been fixed in between?

@David:
Help has been wrong, as you can see on 
<http://help.libreoffice.org/Calc/AutoInput>
Never was  Tab / Shift+Tab, 
but always has been
Control+Tab / Control+Shift+Tab
But let's wait for final results here
Comment 5 Rainer Bielefeld Retired 2012-09-05 05:26:41 UTC
No longer reproducible with Server Installation of  "LibreOffice  3.6.2.0+  English UI/ German Locale [Build-ID:  6781ee7] on German WIN7 Home Premium (64bit)  {tinderbox: Win-x86@9, pull time2012-08-31 19:54:09}

@David, András:
This help problem has been handled in Bug "46143 - Wrong AutoInput Hot Keys described in SPREADSHEET LOCALHELP" and has been marked as FIXED - what has gone wrong?
Comment 6 Rainer Bielefeld Retired 2012-09-05 05:29:24 UTC
*** Bug 53546 has been marked as a duplicate of this bug. ***
Comment 7 Andras Timar 2012-09-05 07:29:19 UTC
(In reply to comment #5)
> This help problem has been handled in Bug "46143 - Wrong AutoInput Hot Keys
> described in SPREADSHEET LOCALHELP" and has been marked as FIXED - what has
> gone wrong?

Help describes the correct (i.e. the desired) behaviour. The function was broken, see bug 48868.

*** This bug has been marked as a duplicate of bug 48868 ***