Bug Hunting Session
Bug 54485 - EDITING: cut / paste of a line of data doesn't remove the selected lines
Summary: EDITING: cut / paste of a line of data doesn't remove the selected lines
Status: RESOLVED DUPLICATE of bug 99483
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.1.1 rc
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Clipboard
  Show dependency treegraph
 
Reported: 2012-09-04 08:41 UTC by bureautiquelibre
Modified: 2017-07-01 10:45 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bureautiquelibre 2012-09-04 08:41:12 UTC
Observed behavior:

Select a line, then cut it and paste it somewhere else.
The line selected for cut goes blank but isn't removed.


Expected behavior:

The line selected for cut should be removed since it's a cut that is performed.
Comment 1 Jean-Baptiste Faure 2012-09-17 17:24:53 UTC
The cut & paste works on the contents of the cells. It is the way Calc works for ages. For me it is not a bug as it works as designed.

Best regards. JBF
Comment 2 bureautiquelibre 2012-09-18 10:00:51 UTC
I understand but if that design can be improved I don't see any good reason not to change it.

Main reasons why it's not good are :
1/ It's a waste of time every time a cut/paste is performed. Cut is supposed to cut, not copy and wipe cells.
2/ For the end user it is a regression compared to what they are used to.
3/ Cut/paste function is one of the most frequently used functions in a spreadsheet.

I'm currently leading a small scale test with 95 regular users -not IT- out of 5000 users and almost everybody reported this problem as upsetting.

This design is obviously a problem to many if not all the calc users.


Is there a way to proceed so that this design is reconsidered as it would be a significant usability improvement?
Comment 3 bureautiquelibre 2012-09-21 08:40:20 UTC
I'm discovering how the community is structured, it's the first time I'm contributing to an opensource project, all of this is quite new for me.

I'll get in touch with the design team about this feature, the bugtracker isn't the good place for this kind of discussion,

Sorry for the inconvenience, this is not a bug,

Best Regards,
Eric Ficheux
Comment 4 Mathieu Parent 2012-09-24 10:10:38 UTC
I agree. Maybe a new design should be proposed? See <http://wiki.documentfoundation.org/Design>.
Comment 5 pierre-yves samyn 2012-12-14 16:17:56 UTC
Hello

The feature (move a line) already exists:
1. Select the line (click on the header)
2. Move the cursor on the line (not on the header) and move the selection to the destination by pressing the Alt key

Regards
Pierre-Yves
Comment 6 Stefan Knorr (astron) 2012-12-14 16:28:11 UTC
Agree that this is not terribly logical & agree with Eric's (bureautiquelibre's) proposed solution.

One of the caveats here is presumably making sure that formulae stay intact, even as a line is removed* – so I guess this improvement might be some work...


* Simple example: you have a formula SUM(A1:A4) in cell A5 and then delete row 3. The formula will now be in A4... to make sure the formula is still valid, you'd have to correct it to SUM(A1:A3).
Comment 7 Stefan Knorr (astron) 2012-12-14 16:31:59 UTC
Disregard the last part of my comment. I should have tried what happen when removing a row currently – and formulas are corrected as expected. So, I don't really see any reason not do this.

(Setting major => normal, because while annoying, it's not related to data loss etc.)
Comment 8 Thomas Lendo 2017-06-28 21:16:46 UTC
Adding keyword needsUXeval to see if a change is still a valid/wanted issue.
Comment 9 Heiko Tietze 2017-06-29 09:02:11 UTC
Do you mean do have something like

  A B C
1 x x x 
2 y y y
3 z z z
4

and on cut and paste of row 2 to 4 all z-values are moved into row 2? That actually happens when you press Alt once the dragging has started. It's the same behavior as known from Microsoft products. Would be good to have a keyboard shortcut like or option in the paste special dialog.
Comment 10 bureautiquelibre 2017-06-29 09:21:29 UTC
Hi Heiko,

A specific option in the paste special would do the job (that's the way recent MSO versions do it)

The origin of this request was from MSO2003 users where cut/paste removes the whole line when paste command is performed.

Newer version behave differently indeed.

I'll attend todays design meeting, maybe we can talk about this,

Regards,
Eric
Comment 11 Gerry 2017-06-29 14:25:51 UTC
It seems to me that this bug is very much related to bug 39936, as "paste + shift cells in one click" also suffers from this behavior in Calc on Cut&Paste. 

Therefore, I added bug 39936 under "see also".
Comment 12 Yousuf Philips (jay) (retired) 2017-06-30 15:42:26 UTC
Closing as a duplicate as a longer discussion has happened in bug 99483.

*** This bug has been marked as a duplicate of bug 99483 ***