Bug Hunting Session
Bug 54699 - : Important information missing from macros;recording Help
Summary: : Important information missing from macros;recording Help
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other All
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: BSA target:3.7.0
Keywords:
: 38509 41909 56928 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-09-09 18:09 UTC by Alan
Modified: 2012-12-16 17:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Attached is a document with screenshots showing the current state of the macro;recording documentation, what the Tools-Macro menu looks like before 'experimental features' is activated, and after it is enabled. (306.30 KB, application/vnd.oasis.opendocument.text)
2012-09-09 18:09 UTC, Alan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alan 2012-09-09 18:09:52 UTC
Created attachment 66888 [details]
Attached is a document with screenshots showing the current state of the macro;recording documentation, what the Tools-Macro menu looks like before 'experimental features' is activated, and after it is enabled.

Problem description: 

Steps to reproduce:
1. Open Help
2. Go to macros;recording

Current behavior:
There is no mention of how to show the 'Record Macro' option under the menu Tools --> Macros.  Searching the net shows that when 'Enable Experimental Features' is not chosen in the LibreOffice General Options then the option to record macros does not appear.

Expected behavior:
Mention that if the record macro does not appear that it is necessary to manually enable it.  Suggested language for after the Limitations paragraph:

Note:  
If the Record Macro is not visible or greyed out under Tools – Macros you will need to enable it in LibreOffice Options
 - Choose Tools – Options to open the LibreOffice Optinos dialog window
 - Navigate to LibreOffice – General and check the 'Enable experimental (unstable) features' option


Platform (if different from the browser): 
Running Kubuntu 12.04
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:15.0) Gecko/20100101 Firefox/15.0
Comment 1 Not Assigned 2012-10-23 12:25:27 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=a43f72ace3d84b3ba0df35ec589a21a1d5de2299

fdo#54699 document that macro recording is an unstable feature



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 2 Julien Nabet 2012-12-08 12:47:36 UTC
*** Bug 56928 has been marked as a duplicate of this bug. ***
Comment 3 Julien Nabet 2012-12-08 14:52:04 UTC
*** Bug 41909 has been marked as a duplicate of this bug. ***
Comment 4 manj_k 2012-12-16 17:17:21 UTC
*** Bug 38509 has been marked as a duplicate of this bug. ***