Download it now!
Bug 54981 - FILEOPEN: Libre office can't open a MS Access database 2003.
Summary: FILEOPEN: Libre office can't open a MS Access database 2003.
Status: CLOSED DUPLICATE of bug 53070
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-16 08:19 UTC by Soon
Modified: 2013-12-12 16:07 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Neptuno database format MS Access 2003 (996.00 KB, application/x-msaccess)
2012-09-17 11:47 UTC, Soon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Soon 2012-09-16 08:19:21 UTC
Problem description: 
I have created a personal database with MS Access 2003 (.mdb). I have try to migrate to LibreOffice creating a libreoffice database conextion between MS Access 2003 and LibreOffice, but when I try to create a database conexión between the access and libreoffice the libreoffice hangs up and don't finish never. I have do the same with openoffice and runs correctly. 

Steps to reproduce:
1. Open LibreOffice Base and select connect to a database Existing
2. Select Microsoft Access in the dropdown
3. Click on Next
4. Select the Access database file (.mdb) and click on next
5. Select No register the database, click on open database for edit and click on finish
6. Then, the libreoffice hangs up and not finish never.

I have do the same with Open Office and it runs correctly.

Current behavior:
When opening the database, LibreOffice hangs up.

Expected behavior:
Libreoffice open the ms access database and I can migrate from access to libreoffice base.

Platform (if different from the browser): 
Windows 7 x64              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0
Comment 1 Jochen 2012-09-16 10:25:06 UTC
Hi Soon,

is it possible to attach the mdb-file?
Comment 2 Soon 2012-09-17 11:47:50 UTC
Created attachment 67279 [details]
Neptuno database format MS Access 2003
Comment 3 Soon 2012-09-17 11:49:20 UTC
The database has confidential data, but a I find a public database to get the test. With this database you can reprocedure the error.
Thanks
Comment 4 nescient 2012-10-07 14:41:52 UTC
I also have this problem when I click finish, enter the Save As dialog and then LibreOffice just hangs. My Access database is .mdb with 1 table/four rows of data. I get the same result with other .mdb files.


Win XP SP3
LibreOffice 3.6.2.2
Comment 5 Robert Großkopf 2012-10-15 17:02:41 UTC
Could it be the same problem as
https://bugs.freedesktop.org/show_bug.cgi?id=53070 ?
Comment 6 Joel Madero 2012-10-19 17:03:56 UTC
This isn't a bug. MS Office Access is incredibly interdependent with MS Office. If anything this is a bug with Microsoft, they created a product which is pretty much impossible (maybe not impossible but incredibly time consuming, probably impossible on Linux, maybe even Mac), to make cross-compatible with LibO (or any other office suite). 

Marking this as NOTOURBUG as I seriously think it is a bug with Microsoft Office, they could have made a product that didn't depend on Windows platform so much but, they didn't. 

This is an unfortunate reality. Please check this out for some suggestions on how to get the data into database:

http://ask.libreoffice.org/question/703/is-there-a-microsoft-access-mdb-conversion-filter/

Regards,
Joel
Comment 7 Robert Großkopf 2012-10-19 18:06:05 UTC
@Joel,

I don't understand your arguments. When LO (under Windows) seems to have a driver to connect to MS Access, and this driver doesn't work - why is this a bug of MS Access?

There are some other reports for databases, created with Access and later connected with Base:
https://bugs.freedesktop.org/show_bug.cgi?id=53070
https://bugs.freedesktop.org/show_bug.cgi?id=43187
https://bugs.freedesktop.org/show_bug.cgi?id=43227
https://bugs.freedesktop.org/show_bug.cgi?id=53080
... I have no Windows-system here. So I can't connect to an existing Access-database. But in LO-Windows-versions it seems to be possible. Please read the steps to reproduce, as reported by Soon.

I change the Status to unconfirmed, because there must be someone, who could test it with Windows and LO 3.6.1 or 3.6.2.
Comment 8 Joel Madero 2012-10-19 18:09:25 UTC
That is the problem, Access DEPENDS on Windows, so any workaround would be Windows only because Microsoft has created a software package that is dependent on the OS.
Comment 9 Joel Madero 2012-10-19 18:48:12 UTC
So just to be clear. You're just wanting the ability to open the file in Windows?
Comment 10 Robert Großkopf 2012-10-19 19:33:13 UTC
I don't think it is an enhancement. My system shows me the databases, where Base could connect to, for example the KDE-Adressbook. With a Windows-system you could connect to Outlook, Outlook-express, ADO, Access. A *.mdb-file could be opened with OOo and LO only under Windows. So the platform for this bug could only be windows. And it is a regression, when it couldn't be opened any more. 

I couldn't test it - no Windows-system here. But it can be a problem with LO 3.6.*, as described in the other bug-reports or solved here:
https://bugs.freedesktop.org/show_bug.cgi?id=52615

There are many other reports, which are declared as duplicate of the report above. I don't know, if this is a duplicate of that bug, too. I can't test, because my system and my LO hasn't a connection to *.mdb-files.
Comment 11 Joel Madero 2012-10-19 19:36:09 UTC
If you're not using a Windows machine I don't think it is possible to connect to a mdb file, again, because Microsoft has gone above and beyond in making mdb DEPENDENT on Windows. I am forwarding this for a second opinion as I admit I'm not an expert on this subject but from all of my research and talking to other people, Access is completely dependent on having Windows and there is no workaround for this.
Comment 12 Robert Großkopf 2012-10-20 07:11:39 UTC
@comment 11
You are right, its a problem of Windows and LO only, and so I changed the platform to "Windows".
But it's a bug of LO. The connection worked (in Windows) in earlier versions.
Comment 13 Alex Thurgood 2012-10-21 03:57:20 UTC
Oh jeez, yet another MS Access bug, surely a DUP of one we already have in the system, in fact, the hang in LO is exactly the same behaviour as at least one other bug report on the same topic (will have to dig around to find out which one).

Not only is it a bug, it also a regression. This used to work in previous versions of LO.



Alex
Comment 14 Alex Thurgood 2012-10-21 04:02:59 UTC
See comment 21 of bug 53070.
Confirming as DUP. The whole MS Access read mechanism seems currently broken.


Alex

*** This bug has been marked as a duplicate of bug 53070 ***
Comment 15 Terrence Enger 2012-10-21 17:55:44 UTC
(In reply to comment #6)
> This isn't a bug. MS Office Access is incredibly interdependent with MS
> Office.

Indeed, we cannot expect LibreOffice to do the impossible.  But I think it should refuse such a request quicky and politely.  Well, at least in the absence of some undecideable question.  Can you agree that we should go this far?

Terry.