Bug Hunting Session
Bug 53070 - freeze/hang when connecting to ADO source (e.g. MS Access 2003 mdb / 2007 accdb)
Summary: freeze/hang when connecting to ADO source (e.g. MS Access 2003 mdb / 2007 accdb)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: All Windows (All)
: highest critical
Assignee: DavidO
URL:
Whiteboard: BSA target:3.7.0 target:3.6.4
Keywords: regression
: 54454 54915 54981 55869 (view as bug list)
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2012-08-02 08:19 UTC by John Smith
Modified: 2013-11-13 19:12 UTC (History)
16 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample MS Access 2007 database (999.15 KB, application/zip)
2012-08-02 08:19 UTC, John Smith
Details
2nd Sample MS Access 2007 Database (912.19 KB, application/zip)
2012-08-02 08:23 UTC, John Smith
Details
3rd MS Access sample mdb (267.03 KB, application/zip)
2012-08-03 04:46 UTC, John Smith
Details
4th MS Access sample mdb (349.23 KB, application/zip)
2012-08-03 04:47 UTC, John Smith
Details
Process monitor detail with 4th MS Access sample mdb (183.72 KB, image/png)
2012-10-09 14:47 UTC, paour
Details
5th MS Access (2000) sample mdb (120.00 KB, application/x-msaccess)
2012-10-26 07:37 UTC, Winfried Donkers
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Smith 2012-08-02 08:19:27 UTC
Created attachment 65061 [details]
Sample MS Access 2007 database

Problem description: 

Steps to reproduce:
1. Start LibreOffice
2. Click on 'Database'
3. Choose 'connect to an exisiting database'
4. Select 'MS Access 2007'
5. Click 'Browse', se;ect the file, and click 'open'
6. Click 'Finish', and 'save'.
7. Click on 'Finish.

Current behavior:
When opening the attached database, LibreOffice becomes unresponsive.

Expected behavior:
The database is opened for editing.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.0; rv:14.0) Gecko/20100101 Firefox/14.0.1
Comment 1 John Smith 2012-08-02 08:21:31 UTC
*** Bug 53069 has been marked as a duplicate of this bug. ***
Comment 2 John Smith 2012-08-02 08:23:12 UTC
Created attachment 65062 [details]
2nd Sample MS Access 2007 Database
Comment 3 John Smith 2012-08-03 04:46:37 UTC
Created attachment 65070 [details]
3rd MS Access sample mdb
Comment 4 John Smith 2012-08-03 04:47:02 UTC
Created attachment 65071 [details]
4th MS Access sample mdb
Comment 5 Jochen 2012-08-29 19:07:17 UTC
@Regina

Please: an you have a look at this bugreport. What is your opinion?
Comment 6 Regina Henschel 2012-08-29 19:53:27 UTC
I cannot open the database samples with Microsoft Access 2007. So there is something wrong with the files.

Nevertheless, I had already reported in bug 43187 that LibO 3.6.1 hangs when I try to open an *.accdb database file via driver "MS Access 2007".

AFAIK, the driver "MS Access 2007" is not intended to be used with *.mdb database files. So the 3rd and 4th sample are irrelevant.
Comment 7 Jochen 2012-08-29 20:03:33 UTC
(In reply to comment #6)
> I cannot open the database samples with Microsoft Access 2007. So there is
> something wrong with the files.

@John:
I'm right in thinking that you have created your database samples with Microsoft Access 2007 and now you want to open this in LibreOffice/Base?

I understand Regina that she can´t open the database samples with Microsoft Access 2007. Can it be that something is wrong with database samples?
Comment 8 John Smith 2012-08-30 05:40:20 UTC
(In reply to comment #7)
> @John:
> I'm right in thinking that you have created your database samples with
> Microsoft Access 2007 and now you want to open this in LibreOffice/Base?
> 
I downloaded the files from the public Microsoft.com website, and want to open them with LibreOffice.

(In reply to comment #7)
> 
> I understand Regina that she can´t open the database samples with Microsoft
> Access 2007. Can it be that something is wrong with database samples?
> 
 I just tried to open them with Microsoft Office 2010, and that works as expected. Perhaps they are MsOffice 2010 files, and MsOffice 2010 isnt supported with LibreOffice ?

(In reply to comment #6)
> 
> AFAIK, the driver "MS Access 2007" is not intended to be used with *.mdb
> database files. So the 3rd and 4th sample are irrelevant.
For the *.mdb files, I didnt choose 'Access 2007', but 'Microsoft Access' in LibreOffice. Im sorry that the initial bug description didnt mention that.
Comment 9 Jochen 2012-08-30 06:25:47 UTC
Hi John,

please create a new summary of your procedure, e.g. like
1) I have downloaded four MS Access files (attachments 1-4) from the public Microsoft.com website.
2) Now I want to open them with LibreOffice xxx (post what version).
3) <next steps similar in your original bugreport but in more details> 
x) describe misbehavior.

Poste your guess:
Perhaps MsOffice 2010 files aren´t supported with LibreOffice.
Comment 10 John Smith 2012-08-30 13:18:56 UTC
(In reply to comment #9)
> Hi John,
> 
> please create a new summary of your procedure, e.g. like
> 1) I have downloaded four MS Access files (attachments 1-4) from the public
> Microsoft.com website.
> 2) Now I want to open them with LibreOffice xxx (post what version).
> 3) <next steps similar in your original bugreport but in more details> 
> x) describe misbehavior.
> 
> Poste your guess:
> Perhaps MsOffice 2010 files aren´t supported with LibreOffice.
Would this be sufficient ? :



Steps to reproduce:
1. Download sample files from the Microsoft.com public website, or download the attachments from this bug report.
2. If the attachments were used, unzip the attachmnents.
3. Download 'master~2012-08-30_00.35.51_LibO-Dev_3.7.0.0.alpha0_Win_x86_install_en-US.msi' from http://dev-builds.libreoffice.org/daily/W2008R2@20-With-Symbol-Bytemark-Hosting/master/2012-08-30_00.35.51/
4. Install 'master~2012-08-30_00.35.51_LibO-Dev_3.7.0.0.alpha0_Win_x86_install_en-US.msi' 
5. Start MibreOffice master~2012-08-30_00.35.51_LibO-Dev_3.7.0.0.alpha0
4. Click on 'Database'
4. Choose 'connect to an exisiting database'
5. For the other 1st and 2nd *.accdb files, select 'MS Access 2007.' For the 3rd and 4th  *.mdb files. select 'MS Access'. 
6. Click 'Browse', select the file, and click 'open'
7. Click 'Finish', and 'Save'.
8. Click on 'Finish.

Current behavior:
When opening the filee, LibreOffice becomes unresponsive.

Expected behavior:
The database is opened for editing.
Comment 11 John Smith 2012-09-02 06:31:01 UTC
Why is the status still 'NEEDINFO' ? What further info is needed, or do I need to deliver ? Thanks.
Comment 12 Jochen 2012-09-02 09:34:00 UTC
Hi John,

your bugreport must be confirmed. To reproduce takes much time. On average I edit 1 bug in 1 or 2 days because there are most vague informations. I will test your bugreport if I have time.
But perhaps another person has time?
Comment 13 Alex Thurgood 2012-09-02 14:57:26 UTC
Surely, this report is a duplicate of Regina's problems that she mentioned already :

https://bugs.freedesktop.org/show_bug.cgi?id=43187#c6


Alex
Comment 14 Alex Thurgood 2012-09-02 14:59:37 UTC
Or alternatively, I would take Regina's comment as confirmation that the problem is reproducible.

My problem in bug 43187 was that I couldn't write/update the datasets, but at least I could load the tables, which would mean that that this current bug is an even further regression over 43187.

Am confirming this bug with regard to Regina's comments.


Alex
Comment 15 Alex Thurgood 2012-09-03 19:29:50 UTC
*** Bug 54454 has been marked as a duplicate of this bug. ***
Comment 16 Alex Thurgood 2012-09-03 19:32:33 UTC
I also managed to reproduce this yesterday, with an Access 2007 MONDIAL.accdb file and 3.6.1.

Alex
Comment 17 billhook 2012-09-03 23:36:14 UTC
I am having almost the exact same problem, but with a ".mdb" file, using the "Microsoft Access" driver. This is on 3.6.1.2 Win Vista 32bit.

I can open the database using the ODBC driver.

The database file is confidential information so I cannot upload it.

Should I create a new bug report for this? Or is it probably the same issue?
Comment 18 John Smith 2012-09-04 05:25:47 UTC
Modified the bug title because the issue also occurs with the attached MS Access sample .mdb files (3rd sample and 4th sample).
Comment 19 Alex Thurgood 2012-09-14 10:09:25 UTC
*** Bug 54915 has been marked as a duplicate of this bug. ***
Comment 20 paour 2012-10-09 14:16:03 UTC
Hello,
This problem occurs with Lbo 3.6.2
regards
Nicolas
Comment 21 paour 2012-10-09 14:24:09 UTC
Add comment for previous message :
  With MS-Access 2003 -> file freezes/hangs 

Nicolas
Comment 22 paour 2012-10-09 14:47:49 UTC
Created attachment 68348 [details]
Process monitor detail with 4th MS Access sample mdb
Comment 23 ape 2012-10-11 09:41:05 UTC
OS: Windows XP (32-bit and 64-bit)
LibreOffice:
Version 3.6.4.0+ (Build ID: a4b919d)
Version 3.6.2.2 (Build ID: da8c1e6)
W2008R2@20-With-Symbol-Bytemark-Hosting/../master~2012-10-01_05.02.30_LibO-Dev_3.7.0.0.alpha0_Win_x86
LibreOffice Base freezes when you try to connect to the Microsoft database.
As it seems to me the reason for the error is the same as here (Bug 55437). These releases have only one common feature: they compiled the MS_VCR-2008 SP1.
There is no error in:
LibreOffice 3.5.7.2; Build ID: 3215f89-f603614-ab984f2-7348103-1225a5b
/Win-x86@6/../master~2012-09-24_21.00.28_LibO-Dev_3.7.0.0.alpha0_Win_x86
Comment 24 ape 2012-10-11 10:18:27 UTC
@:_nthiebaud@gmail.com
You use the MS_VCR-2008 (version 001500002102, non SP1). Please compile the W2008R2@16-minimal_build /LibO-Dev_3.7.0.0.alpha0_Win_x86 with JDK 1.6.0_u21-u33. It is possible that your release will solve this problem.
Comment 25 Rainer Bielefeld Retired 2012-10-11 12:08:38 UTC
My test with Server Installation of  "LibreOffice  3.6.4.0+  English UI/ German Locale [Build-ID: a4b919d],{tinderbox: Win-x86@9 pull time 2012-10-10 19:11:32}  on German WIN7 Home Premium (64bit)  

0. Download / unzip Test kit 2012-08-02 08:19 UTC, John Smith 
1. Launch LibO
2. Click "New Database" button in LibO Start Center
   > Database Wizard appears
3. Select "Connect to existing Database - MS Access 2007  <Next>
4. Browse for Test Kit contents "TS102483123.accdb", <Open>  ->  <Next>
   > Wizard Step 3 dialog appears
5. Yes, Register + "Open for Editing" <Finish>
   > Save Dialog appears
6. Save "New Database.ODF" in same folder
   Expected: Database will be opened
   Actual: Error Message "The connection to the data source "New Database" could 
           not be established. The connection could not be created. May be 
            the necessary data provider is not installed"

Same when I exactly follow reporter's steps and finish in my step 4
Same with LibO 3.4.5 and 3.3.3 and AOOo 3.4.1

I wonder why I always get error messages instead of freeze?
Comment 26 paour 2012-10-11 14:06:37 UTC
Hello, Answr to comment 24:
1- I download here http://www.microsoft.com/fr-fr/download/details.aspx?id=26368
Microsoft Visual C++ 2008 Service Pack 1 Redistributable Package (the same of
LibreOffice 3.5.6, I don't found this version -> 3.5.7.2 mentioned in your post)
2- remove olds versions of Microsoft Visual C++ 2008
3- Setup this verion Visual C++ 2008 9.0.30729.6161
4- test to open MS-access 2003 database
5- freeze /hang :-(

Please confirm the Vc++ version is 99.0.30729.6161 or give me a link to donwload it.
Regards
Nicolas
Comment 27 ape 2012-10-15 13:27:23 UTC
(In reply to comment #26)
> Hello, Answr to comment 24:
> 1- I download here
> http://www.microsoft.com/fr-fr/download/details.aspx?id=26368
> Microsoft Visual C++ 2008 Service Pack 1 Redistributable Package (the same of
> LibreOffice 3.5.6, I don't found this version -> 3.5.7.2 mentioned in your
> post)
> 2- remove olds versions of Microsoft Visual C++ 2008
> 3- Setup this verion Visual C++ 2008 9.0.30729.6161
> 4- test to open MS-access 2003 database
> 5- freeze /hang :-(
> 
> Please confirm the Vc++ version is 99.0.30729.6161 or give me a link to
> donwload it.
> Regards
> Nicolas

1. http://ftp5.gwdg.de/pub/tdf/libreoffice/testing/3.5.7/win/x86/LibO_3.5.7rc2_Win_x86_install_multi.msi
2. I used MC_VCR_9.0.21022.8_x86: http://www.microsoft.com/en-us/download/details.aspx?id=29 - this version is specified in manifests of binary and executable files.
Comment 28 paour 2012-10-15 14:27:44 UTC
Hello APE,
I did the test with Visual C++ MC_VCR_9.0.21022.8_x86 and already had the same probleme (freeze).
Please note this problem occur with LibreOffice-3.6.2 (not with 
libo 3.5.7 mention in your post).

Regards
Nicolas
Comment 29 ape 2012-10-15 16:26:49 UTC
(In reply to comment #28)
> Hello APE,
> I did the test with Visual C++ MC_VCR_9.0.21022.8_x86 and already had the
> same probleme (freeze).
> Please note this problem occur with LibreOffice-3.6.2 (not with 
> libo 3.5.7 mention in your post).
> 
> Regards
> Nicolas
Nicolas!
 MS_VCR's version installed in the system, is not important in this bug. I think that an Built environment used to compile the LibO-3.6(7).x_Win_x86 is reason of an error. MS_VCR-9.0.21022 and JDK-1.6.0_u16-u35 should be used in the assembly all LibOffices (now - 3.5.7 only).
Fridrich uses MSVCR-9.0.30729 (this is SP1).
ape
Comment 30 Alex Thurgood 2012-10-21 04:02:59 UTC
*** Bug 54981 has been marked as a duplicate of this bug. ***
Comment 31 Lionel Elie Mamane 2012-10-22 06:37:37 UTC
(In reply to comment #25)
> My test (...) on German WIN7 Home Premium (64bit)  

> 6. Save "New Database.ODF" in same folder
>    Expected: Database will be opened
>    Actual: Error Message "The connection to the data source "New Database"
>            could not be established. The connection could not be created.
>            May be the necessary data provider is not installed"
> 
> Same when I exactly follow reporter's steps and finish in my step 4
> Same with LibO 3.4.5 and 3.3.3 and AOOo 3.4.1

> I wonder why I always get error messages instead of freeze?

On a 64bit OS, Microsoft Jet is not installed by default. You need to install http://www.microsoft.com/en-us/download/details.aspx?id=13255
Comment 32 Petr Mladek 2012-10-23 10:41:51 UTC
The duplicate bug #54454 describes that LO-3.5 worked better => we need to look at it => added into MABs.

Well, this bug affects only limited group of users. It has already been in the earlier 3.6 releases => it can't block the next bugfix release => lowering the severity a bit.
Comment 33 Roman Eisele 2012-10-23 12:26:36 UTC
Added “regression” keyword according to comment 23 and comment 32.
Comment 34 Winfried Donkers 2012-10-25 08:21:42 UTC
I confirm the problem with version 3.6.2.2 and Access 2000 .mdb files.
O/S is Windows XP and Windows 7.
Comment 35 ape 2012-10-26 04:49:28 UTC
(In reply to comment #2)
> Created attachment 65062 [details]
> 2nd Sample MS Access 2007 Database
--
(In reply to comment #0)
> Created attachment 65061 [details]
> Sample MS Access 2007 database
--
Sorry, but I can not open your files in Microsoft Access 2007 sp3 32-bit RUS: "Unrecognized database format <filename>. (Error 3343)".
Comment 36 Winfried Donkers 2012-10-26 07:37:53 UTC
Created attachment 69101 [details]
5th MS Access (2000) sample mdb

Attached a very simple mdb made with MS Access 2000.
Creating a Base document by connecting to existing Access database does produce the .odb with the link to the mdb, but on opening, Base freezes.
(LibO 3.6.3RC2, Windows XP)
Comment 37 Winfried Donkers 2012-10-26 10:56:50 UTC
@Lionel
I'm sorry to disturb you, but the previous time LibO couldn't open mdb files, you where the master that overpowered the bug. Would it be possible that you have a look at this bug?
It may not be a blocker, but it certainly is a seriour nuisance for private users companies that transferred from MS Office to LibreOffice.

I quite willing to test daily builds on Windows, if you want me to
Comment 38 ape 2012-10-27 14:04:27 UTC
Sorry amateur opine.
There is a bug in the LibO_3.5.x. Import DOCX-file containing formulas Microsoft Office 2003, will start The Equation Editor (EQNEDT32.EXE) in the background.
This error appeared after fixing that bug. It seems that the ability to access libraries of Microsoft’s external programs has been disabled in the LibO_3.6.x. Therefore, the two regressions were born at the same time: this and the bug 55437. See also bug 46716.
Comment 39 Lionel Elie Mamane 2012-10-28 16:31:39 UTC
Can't connect to other ADO sources either, so it seems our whole ADO driver is bust (the Access and Access 2007 "drivers" are just alternative names for the ADO driver with a preconfigured 'magic' data source URL).

This would need some love from a developer with a Windows build and/or a QA person with a windows debug build. I'd love to see the equivalent of gdb's "thread apply all bt full" at the moment of the freeze.

I'd be very happy to cooperate with a LibO-on-Windows developer.


I've looked a bit at the log of changes in connectivity/source/drivers/ado. What strikes me as weird is:

Commit 8256eb0205fcddb79a67be13d6507b2653ff5e08
Author: Matúš Kukan <matus.kukan@gmail.com>  2012-04-07 14:09:40
Committer: David Tardon <dtardon@redhat.com>  2012-05-29 07:24:43

   connectivity: remove unused adabas files

REMOVES files:

connectivity/source/drivers/ado/AKeyColumn.cxx
connectivity/source/drivers/ado/AKeyColumns.cxx


Commit fc6d226a0ed0e493a33d5f82edcedec0ddd37ec7
Author: David Tardon <dtardon@redhat.com>  2012-03-10 19:00:43
Committer: David Tardon <dtardon@redhat.com>  2012-03-12 08:53:56

 WaE: missing braces around initializer for 'unsigned char [8]'

------------------ connectivity/source/drivers/ado/adoimp.cxx ------------------
index 14f5f52..3c05419 100644
@@ -41,7 +41,7 @@ using namespace com::sun::star::sdbc;
 using namespace com::sun::star::sdbcx;
 
 
-#define MYADOID(l) {l, 0,0x10,0x80,0,0,0xAA,0,0x6D,0x2E,0xA4};
+#define MYADOID(l) {l, 0,0x10,{0x80,0,0,0xAA,0,0x6D,0x2E,0xA4}};
 
 const CLSID ADOS::CLSID_ADOCONNECTION_21    =   MYADOID(0x00000514);
 const IID   ADOS::IID_ADOCONNECTION_21      =   MYADOID(0x00000550);



Are we double-plus extra sure that this does not change the value of e.g. ADOS::CLSID_ADOCONNECTION_21?


One thing to try is to revert these commits (or parts thereof) and see if it makes a difference. Or also some bibisect love to try to find the exact commit which introduced this bug.
Comment 40 David Tardon 2012-10-29 08:09:14 UTC
(In reply to comment #39)
> Can't connect to other ADO sources either, so it seems our whole ADO driver
> is bust (the Access and Access 2007 "drivers" are just alternative names for
> the ADO driver with a preconfigured 'magic' data source URL).
> 
> This would need some love from a developer with a Windows build and/or a QA
> person with a windows debug build. I'd love to see the equivalent of gdb's
> "thread apply all bt full" at the moment of the freeze.
> 
> I'd be very happy to cooperate with a LibO-on-Windows developer.
> 
> 
> I've looked a bit at the log of changes in connectivity/source/drivers/ado.
> What strikes me as weird is:
> 
> Commit 8256eb0205fcddb79a67be13d6507b2653ff5e08
> Author: Matúš Kukan <matus.kukan@gmail.com>  2012-04-07 14:09:40
> Committer: David Tardon <dtardon@redhat.com>  2012-05-29 07:24:43
> 
>    connectivity: remove unused adabas files
> 
> REMOVES files:
> 
> connectivity/source/drivers/ado/AKeyColumn.cxx
> connectivity/source/drivers/ado/AKeyColumns.cxx

It is not weird at all, actually. git log says these files had never been compiled.

> 
> 
> Commit fc6d226a0ed0e493a33d5f82edcedec0ddd37ec7
> Author: David Tardon <dtardon@redhat.com>  2012-03-10 19:00:43
> Committer: David Tardon <dtardon@redhat.com>  2012-03-12 08:53:56
> 
>  WaE: missing braces around initializer for 'unsigned char [8]'
> 
> ------------------ connectivity/source/drivers/ado/adoimp.cxx
> ------------------
> index 14f5f52..3c05419 100644
> @@ -41,7 +41,7 @@ using namespace com::sun::star::sdbc;
>  using namespace com::sun::star::sdbcx;
>  
>  
> -#define MYADOID(l) {l, 0,0x10,0x80,0,0,0xAA,0,0x6D,0x2E,0xA4};
> +#define MYADOID(l) {l, 0,0x10,{0x80,0,0,0xAA,0,0x6D,0x2E,0xA4}};
>  
>  const CLSID ADOS::CLSID_ADOCONNECTION_21    =   MYADOID(0x00000514);
>  const IID   ADOS::IID_ADOCONNECTION_21      =   MYADOID(0x00000550);
> 
> 
> 
> Are we double-plus extra sure that this does not change the value of e.g.
> ADOS::CLSID_ADOCONNECTION_21?

Yes. Both CLSID and IID are typedef'd from GUID, which is declared as

typedef struct _GUID {
  DWORD Data1;
  WORD  Data2;
  WORD  Data3;
  BYTE  Data4[8];
} GUID;

(http://msdn.microsoft.com/en-us/library/aa373931(VS.85).aspx). The commit just adds braces around the initializer for the Data4 array.
Comment 41 ape 2012-11-01 08:12:11 UTC
(In reply to comment #40)
> (In reply to comment #39)
> > I've looked a bit at the log of changes in connectivity/source/drivers/ado.
> > What strikes me as weird is:
> > 
> > Commit 8256eb0205fcddb79a67be13d6507b2653ff5e08
> > Author: Matúš Kukan <matus.kukan@gmail.com>  2012-04-07 14:09:40
> > Committer: David Tardon <dtardon@redhat.com>  2012-05-29 07:24:43
> > 
> >    connectivity: remove unused adabas files
> > 
> > REMOVES files:
> > 
> > connectivity/source/drivers/ado/AKeyColumn.cxx
> > connectivity/source/drivers/ado/AKeyColumns.cxx
> 
> It is not weird at all, actually. git log says these files had never been
> compiled.
> 
> > 
> > 
> > Commit fc6d226a0ed0e493a33d5f82edcedec0ddd37ec7
> > Author: David Tardon <dtardon@redhat.com>  2012-03-10 19:00:43
> > Committer: David Tardon <dtardon@redhat.com>  2012-03-12 08:53:56
> > 
> >  WaE: missing braces around initializer for 'unsigned char [8]'
> > 
> > ------------------ connectivity/source/drivers/ado/adoimp.cxx
...
> (http://msdn.microsoft.com/en-us/library/aa373931(VS.85).aspx). The commit
> just adds braces around the initializer for the Data4 array.
------
@David Tardon:
David, let's recover the files that have been deleted on May 29:
 1. Access problems began at about this time.
 2. I think that the patch has not been used in LibO-35.
 3. The patch (made by March 12) eliminates problems with connecting to the Access-98\2000.
Comment 42 David Tardon 2012-11-01 08:33:42 UTC
(In reply to comment #41)
> David, let's recover the files that have been deleted on May 29:
>  1. Access problems began at about this time.

I repeat: these files have nothing to do with it. I merged a branch that converted module connectivity (where the ado driver is placed) to gbuild at that date. In all probability the problem was caused by that conversion (missing exported symbols, most likely).

>  2. I think that the patch has not been used in LibO-35.

No. But neither were the files.

>  3. The patch (made by March 12) eliminates problems with connecting to the
> Access-98\2000.

Huh?
Comment 43 Lionel Elie Mamane 2012-11-01 12:58:53 UTC
*** Bug 55869 has been marked as a duplicate of this bug. ***
Comment 44 Not Assigned 2012-11-03 00:51:23 UTC
David Ostrovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ac2cfed553b8c9303f86758e9fe8b70911db00cd

fdo#53070 fix access violation



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 45 Not Assigned 2012-11-03 09:45:20 UTC
David Ostrovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1f02853eccd33585a4964c370b15fcd356dfef9d

fdo#53070 add complete unit test



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 46 Not Assigned 2012-11-05 11:05:10 UTC
David Ostrovsky committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=edd29ae3d8a17e69f5d7bfaff562635322ff21c5&g=libreoffice-3-6

fdo#53070 fix access violation


It will be available in LibreOffice 3.6.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 47 oli 2012-11-06 17:07:13 UTC
The patch works with ADO connection to MS-SQL-Server 2003 (see also Bug 55869)
Thank you David!