Bug 55007 - [EMF] FILEOPEN: Close circle instead of arch (exported by Catia v5)
Summary: [EMF] FILEOPEN: Close circle instead of arch (exported by Catia v5)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: Other All
: medium normal
Assignee: Bartosz
URL:
Whiteboard: BSA target:7.2.0 target:7.1.5
Keywords:
Depends on:
Blocks: EMF-WMF
  Show dependency treegraph
 
Reported: 2012-09-17 11:11 UTC by Giacomo
Modified: 2021-05-25 07:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Circle in the corner close not correct (try to open immagine1.emf with paint) (33.24 KB, application/x-7z-compressed)
2012-09-17 11:11 UTC, Giacomo
Details
Image exported to png with Paint (24.29 KB, image/png)
2020-11-13 13:20 UTC, Bartosz
Details
EMF sample with ARC that has negative values in Start/End angle coords (168 bytes, image/x-emf)
2021-05-22 16:17 UTC, Valek Filippov
Details
EMF sample of Chord with negative values in Start/End angle (168 bytes, image/x-emf)
2021-05-23 11:24 UTC, Valek Filippov
Details
EMF sample of Pie with negative values in Start/End angle (168 bytes, image/x-emf)
2021-05-23 11:25 UTC, Valek Filippov
Details
How chord and pie should look like (8.09 KB, image/png)
2021-05-23 11:26 UTC, Valek Filippov
Details
Not draw a complete circle (33.82 KB, application/x-7z-compressed)
2021-05-24 08:08 UTC, Giacomo
Details
Comparison of Catia vs LO 7.2 (45.45 KB, image/png)
2021-05-25 07:34 UTC, Bartosz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Giacomo 2012-09-17 11:11:05 UTC
Created attachment 67274 [details]
Circle in the corner close not correct (try to open immagine1.emf with paint)

Problem description: 

Steps to reproduce:
1. open writer
2. insert image from file
3. insert a file ***.ems (windows metafile)

Current behavior:

Expected behavior:

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Comment 1 A (Andy) 2013-02-24 13:21:29 UTC
reproducible with LO 4.0.0.3 (Win7 Home, 64bit)

Observed results after inserting the EMF sample file:
In the upper image in the upper and lower area are several items not fully imported correctly.
In the lower image the circle in the middle is not fully imported correctly.
Comment 2 QA Administrators 2015-04-19 03:21:46 UTC Comment hidden (obsolete)
Comment 3 Buovjaga 2015-06-16 17:43:47 UTC
Confirmed (compared to Irfanview).

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 80ec99db4325a439a8a3f1d420d0a80f8bf9c439
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-16_00:00:20
Locale: fi-FI (fi_FI)
Comment 4 QA Administrators 2016-09-20 10:00:12 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2020-05-21 03:42:09 UTC Comment hidden (obsolete)
Comment 6 Giacomo 2020-05-27 09:53:14 UTC
Good morning, 
the bug is also present in the version :
Versione: 6.3.6.2 (x64)
Build ID: 2196df99b074d8a661f4036fca8fa0cbfa33a497
Thread CPU: 8; SO: Windows 6.1; Resa interfaccia: GL; VCL: win; 
Versione locale: it-IT (it_IT); Lingua interfaccia: it-IT
Calc: CL
Comment 7 Bartosz 2020-11-13 13:20:04 UTC
Created attachment 167274 [details]
Image exported to png with Paint
Comment 8 Bartosz 2021-04-02 15:19:44 UTC
The EMR_SETMITERLIMIT record specifies the limit for the length of miter joins for the playback device context.

Due to missing implementation in:
emfio/source/reader/emfreader.cxx
Comment 9 Commit Notification 2021-05-18 18:42:56 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/39369c6e67dffe04acc4abb678c1a94526237fd8

tdf#55007 tdf#142263 tdf#142268 EMF Properly display ARC and CHORD

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2021-05-21 05:31:29 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/fb5247bf587518eaa01cf5d54dceddf73827d740

tdf#55007 tdf#142263 tdf#142268 EMF ARC, PIE, CHORD allow to draw circle

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2021-05-21 08:21:10 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/71edc1d1af9691f7b5067579f22d3d8677c1608c

tdf#55007 tdf#142263 tdf#142268 EMF Properly display ARC and CHORD

It will be available in 7.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Valek Filippov 2021-05-22 16:17:53 UTC
Created attachment 172252 [details]
EMF sample with ARC that has negative values in Start/End angle coords

LO 7.2 master renders it as a full arc instead of approx. 1/8th of the circle segment
Comment 13 Commit Notification 2021-05-22 18:09:14 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4f4c5b43f0c69385aa2738cbac7f7c898af1972f

tdf#55007 EMF Allow negatives values for Start Point and End Point

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Bartosz 2021-05-22 20:37:20 UTC
Hi @Giacomo,
Could you please verify if the issue was resolved also for other EMF images generated by Catia?

You could download latest version of Libreoffice master from: https://dev-builds.libreoffice.org/daily/
Comment 15 Valek Filippov 2021-05-23 11:24:54 UTC
Created attachment 172263 [details]
EMF sample of Chord with negative values in Start/End angle

For test coverage
Comment 16 Valek Filippov 2021-05-23 11:25:36 UTC
Created attachment 172264 [details]
EMF sample of Pie with negative values in Start/End angle
Comment 17 Valek Filippov 2021-05-23 11:26:11 UTC
Created attachment 172265 [details]
How chord and pie should look like
Comment 18 Giacomo 2021-05-24 08:08:38 UTC
Created attachment 172283 [details]
Not draw a complete circle
Comment 19 Bartosz 2021-05-25 07:34:00 UTC
Created attachment 172313 [details]
Comparison of Catia vs LO 7.2

Thanks @Giacomo
The image looks ok, in the latest Catia verification image (LO 7.2 master).


Could you please install latest daily version from:
https://dev-builds.libreoffice.org/daily/master/Win-x86_64@tb77-TDF/current/

and verify if it is working for you?

If you have some spare time, you could verify some other Catia documents with LO 7.2 master.
Comment 20 Giacomo 2021-05-25 07:57:30 UTC
Hi,
in LO 7.2.0.0 Alpha1 any file emf exported by Catia V5 are imported correctly.
Thank you.