Bug Hunting Session
Bug 55059 - EDITING: Calculate formula: Delete or Backspace to empty a refecenced cell, do not result in updating
Summary: EDITING: Calculate formula: Delete or Backspace to empty a refecenced cell, d...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: Other All
: highest major
Assignee: Markus Mohrhard
URL:
Whiteboard: BSA target:3.7.0 target:3.6.2
Keywords: regression
: 55314 (view as bug list)
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2012-09-18 17:03 UTC by p_kongstad
Modified: 2012-11-02 10:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description p_kongstad 2012-09-18 17:03:47 UTC
Problem description: 

Steps to reproduce:
1. Type 2 in A1
2. In A2 type '=A1*2'
3. The result returned in A2 is 4
4. Now delete the value in A1 and the value in A2 is not changed.
5. Pressing F9 will not update. Only CTRL+SHIFT+F9 is updating.

Auto calculate is active.

Current behavior: The value is not updated

Expected behavior: The value should be updated

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:18.0) Gecko/18.0 Firefox/18.0
Comment 1 vitriol 2012-09-19 10:51:02 UTC
Reproducible for me under Win7.
Comment 2 vitriol 2012-09-19 10:56:02 UTC
Regression
Comment 3 vitriol 2012-09-19 10:58:26 UTC
Regression
Comment 4 vitriol 2012-09-19 10:59:10 UTC
Regression
Comment 5 vitriol 2012-09-19 11:01:53 UTC
Sorry for duplicated comments...
Comment 6 Markus Mohrhard 2012-09-19 15:58:24 UTC
One for me. Is another case of the broadcaster lifetime problem. I have to spend some time to figure out again when they should be deleted and when the broadcaster has to be transfered to the temporary note cell.
Comment 7 Not Assigned 2012-09-19 16:55:25 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3fa50ac35b6a56ae9628b0310cbf0eb7b4634736

use correct cell for broadcasting, fdo#55059



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Not Assigned 2012-09-19 17:23:17 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=44946ef77dd14d139fc799a25c4e2b26c772ce9f&g=libreoffice-3-6

use correct cell for broadcasting, fdo#55059


It will be available in LibreOffice 3.6.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Not Assigned 2012-09-21 13:12:28 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-3-6-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7615e7ea047291f9c65ee32f4aaf615e2efbff21&g=libreoffice-3-6-2

use correct cell for broadcasting, fdo#55059


It will be available already in LibreOffice 3.6.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Markus Mohrhard 2012-09-25 11:53:04 UTC
*** Bug 55314 has been marked as a duplicate of this bug. ***
Comment 11 p_kongstad 2012-09-28 15:06:58 UTC
The value in A2 is updated,when changing the value in A1.

If you delete the content in A1, A2 is not updated.
Comment 12 p_kongstad 2012-09-28 15:12:21 UTC
Sorry, The version was not updated. Works as supposed.
Comment 13 luksiw 2012-10-20 17:38:30 UTC
Tested for build: 
libreoffice-3-6~2012-10-19_19.11.54_LibO-Dev_3.6.4.0_Win_x86_install_en-US.msi

Steps:
1. Type 2 in A1
2. In A2 type '=A1*2'
3. The result returned in A2 is 4
4. Deleting value in A1 results in value in A2 being set to 0, as should be.
Comment 14 Cor Nouws 2012-10-22 07:52:33 UTC
Working in Version 3.6.2.2 (build-id: da8c1e6)

A more nested example of the same problem.

     A     B      C

1    2     4      =A1/B1  

2    5    =B1*C1


Value in B2 = 2

Now delete C1 ... B2 does not change, still shows value 2

Only when I actually enter C1, select the formula, delete it and press Enter ...
then B2 is updated correctly.

(Of course, same problem in masterbuild)
Comment 15 Markus Mohrhard 2012-10-22 09:11:36 UTC
@Cor: You should know better than to reopen a bug report that has been verified. Your problem is totally different and needs a different fix. Please opne a  new bug report for the new problem.
Comment 16 Cor Nouws 2012-10-22 11:09:07 UTC
(In reply to comment #15)
> @Cor: You should know better than to reopen a bug report that has been
> verified. Your problem is totally different and needs a different fix.
> Please opne a  new bug report for the new problem.

Please do not hit me ;-)
Sorry, in my ignorance I assumed it was a sort of the same underling problem.
New issue 56278