Download it now!
Bug 55233 - Unexpected "Enable JRE" message with disabled Java Runtime Environment
Summary: Unexpected "Enable JRE" message with disabled Java Runtime Environment
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.6.2.1 rc
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: Java-Runtime-JRE-Warnings
  Show dependency treegraph
 
Reported: 2012-09-23 08:12 UTC by Rainer Bielefeld Retired
Modified: 2013-05-28 21:06 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (22.48 KB, image/png)
2012-09-23 08:12 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-09-23 08:12:05 UTC
Created attachment 67573 [details]
Screenshot

Steps how to reproduce with  Server Installation of "LibreOffice 3.6.2.1 rc  English UI/ German Locale [Build-ID:  ba822cc] on German WIN7 Home Premium (64bit) :

1. Launch LibO from Desktop icon
2. Via 'Tools -> Options -> LibO -> Java' disable Java, if necessary
3. Disable and close Quickstarter if necessary
4. Close LibO 
5. Launch LibO from Desktop icon
6. Click "New Spreadsheet" button
   As Expected: New spreadsheet document appears
   Unexpected: Enable JRE Message "LibreOffice requires a Java runtime 
               environment (JRE) to perform this task. However, use of JRE has 
               been disabled. Do you want to enable the use of a JRE now?"

I doubt that there really some function needing JRE to open a blank new spreadsheet does exist. 

If you open without enabling JRE, close again and do again step 6, Message does not appear.

I doubt that this problem is limited to CALC, I also see the message unexpectedly in other situations, for example in file open dialog, but this one is the only case 100% reproducible for me.

I am pretty sure that I already saw a similar bug here 8or even may be I reported it), but currently I can't find the Bug report.

I found this problem during my research for "Bug 54644 - Launch of LibO neds long time if JRE is disabled".

@io@hydrosight.com
Can you confirm my observations?
Comment 1 Rainer Bielefeld Retired 2012-09-23 08:31:06 UTC
oops, wrong Version.

Regression, no Problem with 3.5.6.

NOT reproducible with parallel installation of Master "LOdev  3.7.0.0.alpha0+   -  ENGLISH UI / German Locale  [Build ID: 24761a6]"  {tinderbox: @6, pull time 2012-09-18 23:21:04} on German WIN7 Home Premium (64bit)

Blocks "Bug 38046 - [Task] False "Libreoffice requires a Java runtime environment (JRE)" warnings"
Comment 2 m.meinesz 2012-09-23 09:47:45 UTC
my version is 3.6.1.2 build e29a214
on win 7 prof. version 6.1.7601

i don't get this error message of missing JRE.

i tried on my mac (same version LO, on Lion) and don't get this error message eather.

on LO versions of 3.5 pop up and dialogue windows are sometimes really slow. It is hard to reproduce, but it happened frequently. I hope it is less so with version 3.6

In my ignorance I thought this might have to do with a missing JRE that I just had disabled. It was probably not related to Java at all.

Wouldn't it be possible to get rid of Java alltogether? It seems so unnecessary and bloated.
Comment 3 Rainer Bielefeld Retired 2012-09-23 11:21:07 UTC
(In reply to comment #2)
<http://www.libreoffice.org/get-help/faq/general-faq/does-libreoffice-require-java/>
Comment 4 Roman Eisele 2012-09-23 18:16:07 UTC
I can not confirm this observation with LibreOffice 3.6.2.1, German langpack installed, on Mac OS X 10.6.8 (Intel).

(However, there are many other places where I see unnecessary “JRE required” alerts, just as Rainer wrote in comment #0.)
Comment 5 Rainer Bielefeld Retired 2012-09-24 04:43:31 UTC
So let's use a more general summary. I also see that for WRITER, DRAW impress in the same situation, and sometimes in different situations, for Example from Start Center
- Menu Help
- Tools -> extension Manager
- Sometimes even when Start Center appears

But I can't remember that I have seen it after a while of working. For me that message appears early after I launched LibO or never.
Comment 6 Roman Eisele 2012-09-24 07:41:35 UTC
(In reply to comment #5)
> But I can't remember that I have seen it after a while of working. For me
> that message appears early after I launched LibO or never.

Agree. For example, bug 34809 (“EDITING: Turning off JRE creates annoying alert if you start LibO, open/create a document and type anything”, which is the easiest to reproduce issue of this kind for me) happens only once after I start LibreOffice; if I open/create another document and begin to type, the message does not appear; but if I quit LibreOffice and start it again, the message appears again.
Comment 7 bfoman (inactive) 2013-03-22 11:04:48 UTC
(In reply to comment #1)
> NOT reproducible with parallel installation of Master "LOdev 
> 3.7.0.0.alpha0+   -  ENGLISH UI / German Locale  [Build ID: 24761a6]" 
> {tinderbox: @6, pull time 2012-09-18 23:21:04} on German WIN7 Home Premium
> (64bit)

If this particular report is not reproducible anymore in latest version, maybe should be closed as 3.6 will be in EOL state soon?
Comment 8 Julien Nabet 2013-05-28 21:06:39 UTC
bfoman: you're right.

If someone reproduces this, please don't hesitate to reopen this tracker.