Download it now!
Bug 58501 - First action in LibO Start Center after launch: message "JRE required" if no JRE selected
Summary: First action in LibO Start Center after launch: message "JRE required" if no ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-19 06:31 UTC by Rainer Bielefeld Retired
Modified: 2013-01-17 05:41 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-12-19 06:31:11 UTC
Steps how to reproduce [Reproducible] with parallel installation of  "LOdev  4.0.0.0.beta1   -  GERMAN UI / German Locale  [Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7)]"  {tinderbox: @6, pull time 2012-12-06} on German WIN7 Home Premium (64bit) with separate /4 User Profile for Master Branch:

1. Launch LibO
2. Disable JRE
3. Close Libo
4. Launch LibO
5. Click "Open New Writer Document" in LibO Start Center

Current behavior: Message "JRE required" (but document will be open although I click "No" in Message)
Expected behavior: no message

I saw as similar effect with unzipped  installation of  "LOdev  4.0.0.0.alpha1+   -  ENGLISH UI / German Locale  [Build ID: af60316514f3ae3d4c475819bf86f2af837171e)]"  {tinderbox: Win-x86@6, pull time 2012-11-23 22:10:31} on German WIN7 Home Premium (64bit) with own separate User Profile: When I try to insert a Frame into a Writer document, I get a "JRE required" message, but frame will be inserted even if I click "No" in dialog.

Related to "Bug 57553 - EDITING: On computer without JRE, Picture dialog shows: JRE required and freezes after OK"?
Operating System: Windows 7
Version: 4.0.0.0.alpha0+ Master
Comment 1 Rainer Bielefeld Retired 2012-12-19 06:32:50 UTC
Still worked fine with unzipped  installation of  "LOdev  4.0.0.0.alpha1+   -  ENGLISH UI / German Locale  [Build ID: af60316514f3ae3d4c475819bf86f2af837171e)]"  {tinderbox: Win-x86@6, pull time 2012-11-23 22:10:31} on German WIN7 Home Premium (64bit) with own separate User Profile.

Not a big problem, but very ugly!
Comment 2 Rainer Bielefeld Retired 2012-12-19 08:43:35 UTC
Seems to be a more general problem, more or less any first action in LibO Start Center causes that message.
Comment 3 Rainer Bielefeld Retired 2012-12-19 08:48:44 UTC
Only a glitch or related to particular settings or whatever? NOT reproducible with server  installation of  "LOdev  4.0.0.0.beta1+   -  ENGLISH UI / German Locale  [Build ID: 6d4a55bf38a1c470c49f904dbbddf94eb2f6154)]"  {tinderbox: Win-x86@6, pull time 2012-12-17 08:36:40} on German WIN7 Home Premium (64bit) with own separate User Profile
Comment 4 Joel Madero 2013-01-15 19:20:59 UTC
Rainer - I'm going to mark this as NEW since it's you that reported it :) If you want independent confirmation ask and I'll give it a shot but I'm sure that it's a valid bug.
Comment 5 Rainer Bielefeld Retired 2013-01-15 21:20:19 UTC
Well, thx. for reminder, this one is somewhere at the bottom of my to do list ...
I saw that in various versions with several different profiles, and I remember that I also read about similar problems in mailing lists. 

But I have not seen this problem for a while, so I will do some systematic tests with 3 more 4.0 Branch versions the next days and close this one WFM if I do not see any indications that the problem still exists.
Comment 6 Rainer Bielefeld Retired 2013-01-17 05:41:59 UTC
I tried to reproduce the issue issue with 4.0.0.1 and latest daylies like server  installation of  "LOdev  4.0.0.1+   -  ENGLISH UI / German Locale  [Build ID:  072fc07107e9849ed7050d18575b42049db9657)]"  {tinderbox: Win-x86@6, pull time 2013-01-16 09:31:57} on German WIN7 Home Premium (64bit) with own separate User Profile, problem has vanished.

Strange, even with Version from original report I can't reproduce the problem today. So WFM for now

Unfortunately these problems come and go, for example see, bugs mentioned below. So I am afraid this is only lucky chance, but not fixed.

"Bug 55233 - Unexpected "Enable JRE" message with disabled Java Runtime Environment"
"Bug 34809 - EDITING: Turning off JRE creates annoying alert if you start LibO, open/create a document and type anything (edit)"