Download it now!
Bug 55554 - FILTER DOC Unnumbered entries in (bullet|numbered) list not indented incorrectly when saved as ".doc"
Summary: FILTER DOC Unnumbered entries in (bullet|numbered) list not indented incorrec...
Status: VERIFIED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-02 19:55 UTC by haim kilov
Modified: 2015-12-22 08:37 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Incorrectly formatted unnumbered entries (10.00 KB, application/msword)
2012-10-02 19:55 UTC, haim kilov
Details
The original (correctly formatted) file (9.31 KB, application/vnd.oasis.opendocument.text)
2012-10-02 19:57 UTC, haim kilov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description haim kilov 2012-10-02 19:55:50 UTC
Created attachment 68006 [details]
Incorrectly formatted unnumbered entries

When an unnumbered entry is inserted in a bullet list using "Insert unnumbered entry" and the file is saved as a ".doc" file the formatting of that entry is wrong: it is aligned to the left. If the file is saved as an ".odt" file there are no formatting problems. 

The attachment is an example of such a file saved as ".doc".
Comment 1 haim kilov 2012-10-02 19:57:45 UTC
Created attachment 68007 [details]
The original (correctly formatted) file

Here is the original, correctly formatted, file with two unnumbered entries
Comment 2 Roman Eisele 2012-10-03 10:09:43 UTC
Comment on attachment 68006 [details]
Incorrectly formatted unnumbered entries

(Fixed MIME type.)
Comment 3 Alex Thurgood 2012-10-04 09:30:07 UTC
This is a DUP of the bullet list problem isn't it ?


Alex
Comment 4 Alex Thurgood 2012-10-04 09:31:59 UTC
After opening the file, I can confirm that it is a DUP of that bullet list issue. Now to find the original report...


Alex
Comment 5 Alex Thurgood 2012-10-04 09:41:25 UTC

*** This bug has been marked as a duplicate of bug 50284 ***
Comment 6 Caolán McNamara 2012-12-18 17:21:36 UTC
while the bullet itself problem might be a duplicate, and fixed, the indent of the unnumbered entry is incorrect, which I believe is the specific problem here.
Comment 7 haim kilov 2013-03-05 05:30:53 UTC
The bug still exists in 4.0.0.3.
Comment 8 it 2014-10-13 14:51:38 UTC
The bug still exists in 4.3.1.2.

Same thing happens with "docx" format.
Comment 9 Joel Madero 2014-11-05 03:24:05 UTC
Looks like thi was confirmed so moving to NEW as REOPENED means something different. Thanks all.
Comment 10 QA Administrators 2015-12-20 16:19:47 UTC Comment hidden (obsolete)
Comment 11 Alex Thurgood 2015-12-21 09:10:43 UTC
Fixed for DOC and DOCX export in 


Version: 5.2.0.0.alpha0+
Build ID: ce3d3f5543e3e132a3473af27aa2c827336add0f
CPU Threads: 2; OS Version: -; UI Render: default; 
Locale : fr-FR (fr.UTF-8)
Comment 12 Alex Thurgood 2015-12-22 07:34:59 UTC
So whatever change caused this now to work, i.e. to indent correctly, Bug 96638 seems to be a request to revert to previous behaviour.
Comment 13 Lionel Elie Mamane 2015-12-22 08:37:25 UTC
(In reply to Alex Thurgood from comment #11)

> Fixed for DOC and DOCX export (...)

Yup, confirm that on master as of 18 December

(In reply to Alex Thurgood from comment #12)
> So whatever change caused this now to work, i.e. to indent correctly, Bug
> 96638 seems to be a request to revert to previous behaviour.

No, it is not. This bug is about an unnumbered entry in a list. Bug 96638 is about making a sequence of paragraphs that were a list into a plain sequence of paragraphs (not a list).