Download it now!
Bug 55618 - LOCALHELP: obsolete for CALC Conditional Formatting
Summary: LOCALHELP: obsolete for CALC Conditional Formatting
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: Other All
: medium major
Assignee: Andras Timar
URL: http://help.libreoffice.org/Calc/Cond...
Whiteboard: BSA target:4.2.0
Keywords:
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2012-10-04 11:49 UTC by Rainer Bielefeld Retired
Modified: 2014-02-14 08:44 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Help content proposal (5.04 KB, text/plain)
2013-07-31 16:34 UTC, sophie
Details
Text for the Manage dialog box (623 bytes, text/plain)
2013-08-01 12:13 UTC, sophie
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-10-04 11:49:38 UTC
In Helep for CF I still read sentences like "Condition 1/2/3 - 
Mark the boxes corresponding to each condition and enter the corresponding condition. To close the dialog, click OK.", what was valid for old dialog, but not for the new one in 3.6
Additionally any Help for 'Conditional Formatting -> Manage' is missing.

              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120909 Firefox/15.0.1 SeaMonkey/2.12.1
Comment 1 Rainer Bielefeld Retired 2012-10-04 11:56:55 UTC
Same still in WIKIHELP (as expected)
Comment 2 Rainer Bielefeld Retired 2012-11-23 16:20:55 UTC
See "Bug 57395 - FORMATTING: modifying reference for CONDITIONAL FORMATTING of a single cell also modifies references in adjacent cells"

The best feature is completely useless if nobody can use it because of a missing manual (and even a crippled feature can be a great tool with a good manual).

So it's urgent to get useful Help.
Comment 3 Michael Meeks 2013-05-20 11:09:39 UTC
Hi Cor/Sophie - any thoughts on this one ? the help needs updating for Markus' new conditional formats work - and this is a MAB so ... ;-) help / ideas much appreciated for fixing it.
Comment 4 Cor Nouws 2013-05-20 20:22:19 UTC
(In reply to comment #3)
> Hi Cor/Sophie - any thoughts on this one ? the help needs updating for
> Markus' new conditional formats work - and this is a MAB so ... ;-) help /
> ideas much appreciated for fixing it.

I think that I'll post to the (Dutch) users list to ask if there is someone with wide experience in the area to provide a new text.
OK, Sophie?
Comment 5 tommy27 2013-07-30 21:02:41 UTC
@Markus Mohrhard
could you please take a look at this?
Comment 6 Michael Meeks 2013-07-31 08:41:33 UTC
Both Sophie & Cor volunteered to find someone to do this :-) Markus is on vacation so ...
Comment 7 sophie 2013-07-31 08:59:22 UTC
So I'll propose something short about the different formatting options and the Manage feature based on our FR FAQ, see:
https://wiki.documentfoundation.org/FR/FAQ/Calc/141
https://wiki.documentfoundation.org/FR/FAQ/Calc/142
https://wiki.documentfoundation.org/FR/FAQ/Calc/143

As I'm currently translating the FR FAQ to EN, may be those links could be added too into the help content? I'll provide the text on Fryday last. Sophie
Comment 8 Joel Madero 2013-07-31 15:42:03 UTC
....raises hand....
Comment 9 Markus Mohrhard 2013-07-31 15:53:06 UTC
It is known that the help is missing but that is true for most of the new features. .I spend the time instead on moving the extended tooltips out of the help.
 this is done and would allow us to move to wikihelp as our primary help so that everyone could write help texts. sadly it was blocked for 4.1 but I hope we can get it in for 4.2.
Comment 10 sophie 2013-07-31 16:34:51 UTC
Created attachment 83380 [details]
Help content proposal

So here is the content I propose. The FAQ entries linked are not yet translated from French (I'll do it later today and tomorrow). If you need another formatting, please tell me, I do it as txt to be able to be copied easily. Sophie
Comment 11 sophie 2013-08-01 10:19:00 UTC
(In reply to comment #10)
> Created attachment 83380 [details]
> Help content proposal
> 
> So here is the content I propose. The FAQ entries linked are not yet
> translated from French (I'll do it later today and tomorrow). If you need
> another formatting, please tell me, I do it as txt to be able to be copied
> easily. Sophie

So for information the 3 linked FAQs are now translated
https://wiki.documentfoundation.org/Faq/Calc/141
https://wiki.documentfoundation.org/Faq/Calc/142
https://wiki.documentfoundation.org/Faq/Calc/143
I have asked for proof reading and screen shots on the documentation project. I'm going to work on the Manage text now and will provide the samples spreadsheet for the FAQ. Sophie
Comment 12 sophie 2013-08-01 12:13:44 UTC
Created attachment 83428 [details]
Text for the Manage dialog box

I've asked for proof read of my texts on the documentation list. Sophie
Comment 13 Pedro 2013-08-01 13:10:55 UTC
Just got here from the User mailing list. Thanks to this I have learned quite a few useful LO features.

There seems to be a bug in the Conditional formatting with no axes function
https://wiki.documentfoundation.org/images/9/96/FR.FAQ_Calc_143_BarreDeDonnees2.png

The value -20 should be a full length red bar and the length of a -18 red bar should be longer than a -2 (unless I am misunderstanding the logic in this chart...)

If this is a bug maybe it should be fixed before creating the documentation?
Comment 14 sophie 2013-08-01 16:10:17 UTC
(In reply to comment #13)
> Just got here from the User mailing list. Thanks to this I have learned
> quite a few useful LO features.
> 
> There seems to be a bug in the Conditional formatting with no axes function
> https://wiki.documentfoundation.org/images/9/96/FR.
> FAQ_Calc_143_BarreDeDonnees2.png
> 
> The value -20 should be a full length red bar and the length of a -18 red
> bar should be longer than a -2 (unless I am misunderstanding the logic in
> this chart...)
> 
> If this is a bug maybe it should be fixed before creating the documentation?

Hi Pedro, this is not a bug, if you remove the axes the higher negative values have the shortest length in the table while the lowest negative values have the longer one, they are negative values. Sophie
Comment 15 tommy27 2013-08-03 09:35:18 UTC
according to previous comments this issue has been assigned and will probably be fixed soon.

in the meantime I move if from the 3.6mab to the 4.0mab for cleanup purposes.
Comment 16 Michael Meeks 2013-08-03 11:31:57 UTC
Thanks Sophie for that ! looking forward to it being merged so we can close another MAB :-)
Comment 17 Joel Madero 2013-08-26 15:19:13 UTC
Hi All - 

sorry just really incredibly busy right now. Releasing this one....Markus if you want to take it I'm sure it'd be really straight forward for you, else...perhaps some pointers and EasyHack designation?

Apologies - life has just gotten hectic but this one *should* be fixed....been on MAB far too long :-/
Comment 18 Andras Timar 2013-08-27 12:03:54 UTC
I pushed the new text to git, but is seems that proofreading did not happen. I fixed a few typos and grammar mistakes, but there may be more. Please let it be checked by a native speaker.
Comment 19 Commit Notification 2013-08-27 12:05:22 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=39a7e6c2242bbe9050f4b7a408d95f06dcfd7a02

fdo#55618 update help for CALC Conditional Formatting



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 20 Joel Madero 2013-08-27 13:29:12 UTC
Thanks for taking this off my plate Andras :)
Comment 21 Ulrich Windl 2014-02-14 08:44:27 UTC
Still obsolete in 4.1.4.2 (German)...