Bug 57395 - FORMATTING: modifying reference for CONDITIONAL FORMATTING of a single cell also modifies references in adjacent cells
Summary: FORMATTING: modifying reference for CONDITIONAL FORMATTING of a single cell a...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.4.1 rc
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-22 05:44 UTC by Rainer Bielefeld Retired
Modified: 2012-11-23 15:16 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample Document (17.07 KB, application/x-vnd.oasis.opendocument.spreadsheet)
2012-11-22 05:44 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-11-22 05:44:39 UTC
Created attachment 70408 [details]
Sample Document

I found this problem during my investigations for "Bug 48970 - EDITING: Deleting a column in particular.xls corrupts following columns" with "LibreOffice 3.6.4.1 rc" German UI/ German Locale [Build-ID: a9a0717] on German WIN7 Home Premium (64bit) and a sample document what is a simplified Version of Attachment 60391 [details] 

Steps how to reproduce:
1. Open attached sample0.ods2. 
2. Click cell D17, check Conditional formatting in 'Format -> Conditional 
   Formatting -> Conditional Formatting'. Reference should be 'Sample.$D17=""'
3. Click cell D18
4. Menu 'Format -> Conditional Formatting -> Conditional Formatting'
   > Dialog opens
5. Modify formula from 'Sample.$D18=""' to 'Sample.$E18=""' <ok>
   Expected: only this cell gets new formatting (so it happens with 3.5)
   Actual: all similar conditions in B11:D22 change reference from column D
           to column E (check as per step 2)
Comment 1 Rainer Bielefeld Retired 2012-11-22 06:09:08 UTC
This behavior  might be a feature, in Conditional 'Formatting -> Manage' I see that the condition is defined for a range and not for separate cells.

But:
a) LibO 3.5 handled those conditions separately for each cell, so that the new 
   behavior is worrying
b) the result is even more worrying because there is no warning or question
   "change only this cell or ocmplete range?
d) and the result is even more worrying because how for Version 3.6.4 we still
   have no Help contents matching with the new UI (see 
   "Bug 55618 - LOCALHELP: obsolete for CALC Conditional Formatting")

Because of the missing Help I have no idea how to break that range.
Comment 2 Markus Mohrhard 2012-11-23 15:16:25 UTC
(In reply to comment #1)
> This behavior  might be a feature, in Conditional 'Formatting -> Manage' I
> see that the condition is defined for a range and not for separate cells.

It is a feature. Between 3.5 and 3.6 we switched from cell based conditional formats to range based conditional formats. There are several advantages with this approach like conditional formats that not only work with the current cell value but also take into the account the values in the range (color scales, data bars and in 4.0 several new conditional formats)


> 
> But:
> a) LibO 3.5 handled those conditions separately for each cell, so that the
> new 
>    behavior is worrying
> b) the result is even more worrying because there is no warning or question
>    "change only this cell or ocmplete range?

This will be improved in 4.0 with overlapping conditional formats.

> d) and the result is even more worrying because how for Version 3.6.4 we
> still
>    have no Help contents matching with the new UI (see 
>    "Bug 55618 - LOCALHELP: obsolete for CALC Conditional Formatting")
> 
> Because of the missing Help I have no idea how to break that range.