Download it now!
Bug 55659 - EDITING: LibreOffice crashing when editing a grouped object, which is also grouped into an object
Summary: EDITING: LibreOffice crashing when editing a grouped object, which is also gr...
Status: RESOLVED DUPLICATE of bug 54155
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 56727 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-10-05 10:34 UTC by huber_lukas
Modified: 2013-12-16 17:01 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
The file that keeps on crashing my LibreOffice Writer (10.54 KB, application/vnd.oasis.opendocument.text)
2012-10-05 10:34 UTC, huber_lukas
Details
bt on master (2.12 KB, text/plain)
2012-10-06 05:36 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description huber_lukas 2012-10-05 10:34:41 UTC
Created attachment 68112 [details]
The file that keeps on crashing my LibreOffice Writer

Problem description: 

I inserted a .jpg figure and i added some dashed lines in LibreOffice. Some of the dashed lines were grouped as a kind of box with some annotations ( = "subgruop"). All parts (.jpg figure + dashed lines + "subgrup") were grouped as one. When editing the "subgroup" and then exiting it, libreoffice writer crashed completely and shuts it self down, without any explanation or announcement.

Steps to reproduce:
1. Select the grouped figure in the attached .odt file
2. right klick on figure: Group -> Edit group
3. right klick on the group located behind the outer left "2°" label: group -> edit group
4. do whatever you want, the second/third next klick outside the group (with or without deleting anything out of the subgroup) shuts my libreoffice

Current behavior:

shuts down immediately, recovery is working well

Expected behavior:

different :)

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Linux i686; rv:13.0) Gecko/20100101 Firefox/13.0
Comment 1 Julien Nabet 2012-10-06 05:36:00 UTC
Created attachment 68146 [details]
bt on master

On pc Debian x86-64 with master sources updated yesterday, I reproduced the problem.
Attached the bt.
Comment 2 Julien Nabet 2012-10-06 05:36:49 UTC
Michael: one for you?
Comment 3 starmatz71 2012-11-22 21:25:26 UTC
*** Bug 56727 has been marked as a duplicate of this bug. ***
Comment 4 Owen Genat (retired) 2013-11-14 23:54:23 UTC
This would appear to be a duplicate of bug #54155. The summary and descriptions for reproducing the bug appear identical. There appears to be more developers associated with this one so I thought I would comment rather than close it.

Crash is still reproducible under Crunchbang 11 x86_64 running v4.1.3.2 for both the test file in this bug and the related bug.
Comment 5 Papamatti 2013-12-16 17:00:58 UTC

*** This bug has been marked as a duplicate of bug 54155 ***