Download it now!
Bug 56727 - EDITING: CRASH after deleting a line inside a drawing inside a group of a group in writer
Summary: EDITING: CRASH after deleting a line inside a drawing inside a group of a gro...
Status: RESOLVED DUPLICATE of bug 55659
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-03 21:30 UTC by starmatz71
Modified: 2013-12-16 17:03 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
This is a file created with Libre Office Draw with a group-definition (9.54 KB, application/vnd.oasis.opendocument.graphics)
2012-11-03 21:32 UTC, starmatz71
Details

Note You need to log in before you can comment on or make changes to this bug.
Description starmatz71 2012-11-03 21:30:05 UTC
Problem description:

I had create a simple drawing of two circles and a line. After grouping this three objects together, I does add a single text field.
If I copy this drawing into a writer document and try to delete a object inside this drawing Libre Office crashes and I have to use the taskmanager to kill soffice.bin!

The crash does not occur if no groups are defined in the drawing (but writer is grouping the drawing itself - you have to enter the group for editing)

Steps to reproduce:
(The goal is to delete the line under the two circles!)
1. Open the file in the attachment
2. Mark all the drawing objects and copy it.
3. Open a new blank writer document.
4. Paste the drawing into the empty writer document.
5. Enter the group (right click the mouse an chose group and then enter group)
6. Enter the underlying group (which contains the circles and the line)
7. Select the Line and press the Del-Key to delete the line.
8. Click anywhere in the document.
9. Click at the drawing and try to move it around.
9. Libre Office crashes immediately or after some seconds.
10. Open the Taskmanager (on Windows) and kill the process soffice.bin

Current behavior:
Crash

Expected behavior:
No Crash

Platform (if different from the browser): 
Windows XP SP3 with Libre Office 3.6.3.2
              
This crash happens also in Ubuntu 12.04 LTS with Libre Office 3.5.4.2 and in Windows XP SP3 with Libre Office 3.5.7.2
Comment 1 starmatz71 2012-11-03 21:32:39 UTC
Created attachment 69499 [details]
This is a file created with Libre Office Draw with a group-definition
Comment 2 Francisco 2012-11-08 17:30:58 UTC
This is something very similar to what I get sometimes using Writer. Not only deleting a line inside 2 nested groups, but also simply editing them, and copy&pasting some of inner components. I can not confirm it is the same bug, but I guess is related, though I draw directly in Writer.
Comment 3 Francisco 2012-11-08 17:31:47 UTC
Edit: Using LO 3.5.6 under Kubuntu 12.04
Comment 4 Francisco 2012-11-08 17:35:48 UTC
Well, I simply followed thw steps and it's reproducible, under LO 3.5.6 on Kubuntu 12.04 (Linux kernel 3.2.0-32)
Comment 5 starmatz71 2012-11-22 21:25:26 UTC

*** This bug has been marked as a duplicate of bug 55659 ***