Bug Hunting Session
Bug 55735 - Writer hogs cpu after mis-pasting image
Summary: Writer hogs cpu after mis-pasting image
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-07 16:28 UTC by marshals
Modified: 2015-05-02 19:28 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
3 page odt doc with images pasted from a google image search result page - the final 2 images do not display properly and cause Writer to hog cpu and become unresponsive (75.86 KB, application/vnd.oasis.opendocument.text)
2012-10-07 16:28 UTC, marshals
Details
gdb trace from kill -15 during hang (33.10 KB, text/plain)
2012-10-07 19:23 UTC, leighman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description marshals 2012-10-07 16:28:13 UTC
Created attachment 68218 [details]
3 page odt doc with images pasted from a google image search result page - the final 2 images do not display properly and cause Writer to hog cpu and become unresponsive

A number of times, with both LO 3.6.1 and 3.6.2, my daughter has pasted an image from the clipboard (copied from a google image search result page) into an odt doc and the image has been displayed in the document as a empty box with what looks like the url of the image in a small courier-like font.  The image is never displayed.  It does not seem to be caused by a particular image type - I have seen the problem with both gif and png in a document that contains other gif and png images successfully pasted.

Also, when it happened today with 3.6.2, Writer became unresponsive when I tried to scroll on the page with the mis-pasted image.  Task Manager shows soffice.bin*32 spinning at 100% on a cpu.  I can still interact with Writer - it is not completely stuck - and I can close it though not via the File menu.

This is reproducible for me with the attached example.  If I re-open the odt doc and try to scroll to the end of the document, the above problem re-occurs.

I never saw this problem with 3.4.* or 3.5.*.

This is on Win7HP 64bit.
Comment 1 leighman 2012-10-07 19:23:04 UTC
Created attachment 68223 [details]
gdb trace from kill -15 during hang

Confirmed in master 5c02bb0 (7 Oct, 11.50) on Ubuntu 12.04.

GDB trace attached.

By looking at the file the problem images seem to be base64 jpeg.

Also hangs in 3.5.4 here.
Comment 2 marshals 2012-11-09 09:26:53 UTC
i can confirm the problem remains in lo-3.6.3.2/win7hp-64b with the attached doc and scrolling to p3.
Comment 3 marshals 2013-01-02 11:55:46 UTC
i can confirm the problem remains in lo-4.0.0beta2/win7ult-32b with the attached doc and scrolling to p3.
Comment 4 marshals 2013-04-22 10:34:59 UTC
i can confirm the problem remains in lo-4.0.2/win7hp-64b with the
attached doc and scrolling to p3.
Comment 5 mal 2013-06-04 10:17:20 UTC
This is still in 4.1 b1 ( Linux on openSuse 12.3 )

The workaround is always to use paste special and select the bitmap from
the list in the clipboard. Selecting the hyperlink or just doing a straight
paste will hang LO writer or grind it to a standstill ( if the hyperlink 
is the first item in the list on the clipboard ) 

Both Firefox and Chrome copy both the hyperlink and the bitmap which
causes writer problems if the hyperlink is the first in the list. If
you use Opera it always works OK because in that browser it only ever
puts the bitmap on the clipboard.
Comment 6 Paijo 2013-06-07 16:51:34 UTC
Similar to Bug 65410
Comment 7 marshals 2013-06-25 11:22:20 UTC
i can confirm the problem remains in lo-4.1.0.1/win7hp-32b with the
attached doc and scrolling to p3.
Comment 8 marshals 2014-01-06 10:20:45 UTC
this is still a problem in 4.2 rc1 (win7ult-32b)
Comment 9 marshals 2014-02-13 14:17:17 UTC
this is still a problem in 4.2.0.4 (win7ult-32b)

should the version for this bug be changed to 4.2.0.4 release?
Comment 10 mal 2014-02-13 14:25:33 UTC
Are you following bug 52547 ?
Comment 11 marshals 2014-02-13 14:36:59 UTC
(In reply to comment #10)
> Are you following bug 52547 ?

no, i was only aware of bug 65410, which gave me a clue to a/the work-around.  

thanks for the heads-up!
Comment 12 Joel Madero 2015-05-02 15:44:37 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-05-02
Comment 13 simon 2015-05-02 19:28:16 UTC
tested on LO-4.4.2.2 on Win7HP64bit

note LO writer still does not display the final 2 images but no longer hogs cpu