Bug Hunting Session
Bug 65410 - LibO unresponsive with 100% CPU usages when pasting pictures from web browser
Summary: LibO unresponsive with 100% CPU usages when pasting pictures from web browser
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-05 10:37 UTC by Alf Tonny Bätz
Modified: 2015-08-02 09:51 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alf Tonny Bätz 2013-06-05 10:37:55 UTC
This is a bug that have been here for a wile.

to reproduce:

goto google, search for some pictures, for eksample "tree"

when you get up all the pictures, right click on mouse on one of the pictures and choose the copy pictures. (dont click so you only get one pictures up, you have to do it when you see all the pictures)

https://www.google.no/search?hl=en&site=imghp&tbm=isch&source=hp&biw=1612&bih=869&q=tree&oq=tree&gs_l=img.1.0.0l10.2252.2776.0.3426.4.4.0.0.0.0.116.375.2j2.4.0...0.0...1ac.1.15.img.9bNKrXdc8eM

and then paste it onto libreoffice writer. Resault = 100% cpu freeze, and no response on libreoffice.
Comment 1 Alf Tonny Bätz 2013-06-05 10:54:32 UTC
I forgot to say this happend on linux based system
Comment 2 Alf Tonny Bätz 2013-06-05 11:10:08 UTC
(In reply to comment #0)
> This is a bug that have been here for a wile.
> 
> to reproduce:
> 
> goto google, search for some pictures, for eksample "tree"
> 
> when you get up all the pictures, right click on mouse on one of the
> pictures and choose the copy pictures. (dont click so you only get one
> pictures up, you have to do it when you see all the pictures)
> 
> https://www.google.no/
> search?hl=en&site=imghp&tbm=isch&source=hp&biw=1612&bih=869&q=tree&oq=tree&gs
> _l=img.1.0.0l10.2252.2776.0.3426.4.4.0.0.0.0.116.375.2j2.4.0...0.0...1ac.1.
> 15.img.9bNKrXdc8eM
> 
> and then paste it onto libreoffice writer. Resault = 100% cpu freeze, and no
> response on libreoffice.

testet this with firefox, chromium with same resaults.

just a little from the strace

futex(0x149c06c, FUTEX_WAIT_PRIVATE, 1, NULL) = 0
futex(0x149c040, FUTEX_WAIT_PRIVATE, 2, NULL) = 0
futex(0x149c040, FUTEX_WAKE_PRIVATE, 1) = 0
futex(0x149bae4, FUTEX_WAIT_PRIVATE, 1, NULL) = 0
futex(0x149bb10, FUTEX_WAKE_PRIVATE, 1) = 0
close(6)                                = 0
futex(0x149bb84, FUTEX_WAIT_BITSET_PRIVATE|FUTEX_CLOCK_REALTIME, 1, {1370430435, 763725000}, ffffffff) = -1 ETIMEDOUT (Connection timed out)
futex(0x149bbb0, FUTEX_WAKE_PRIVATE, 1) = 0
poll([{fd=4, events=POLLIN|POLLOUT}], 1, 4294967295) = 1 ([{fd=4, revents=POLLOUT}])
writev(4, [{"8\2\4\0\2\0`\4\4\0\0\0\365\365\365\0C\0\5\0\1\0`\4\2\0`\4H\0\275\0"..., 72}, {NULL, 0}, {"", 0}], 3) = 72
recvfrom(4, 0x148ffa4, 4096, 0, 0, 0)   = -1 EAGAIN (Resource temporarily unavailable)
recvfrom(4, 0x148ffa4, 4096, 0, 0, 0)   = -1 EAGAIN (Resource temporarily unavailable)
read(5, "10%\n20%\n25%\n30%\n35%\n40%\n50%\n55%\n", 255) = 32
futex(0x149bb84, FUTEX_WAIT_BITSET_PRIVATE|FUTEX_CLOCK_REALTIME, 3, {1370430436, 14524000}, ffffffff) = -1 ETIMEDOUT (Connection timed out)
futex(0x149bbb0, FUTEX_WAKE_PRIVATE, 1) = 0
poll([{fd=4, events=POLLIN|POLLOUT}], 1, 4294967295) = 1 ([{fd=4, revents=POLLOUT}])
writev(4, [{"8\2\4\0\2\0`\4\4\0\0\0\365\365\365\0C\0\5\0\1\0`\4\2\0`\4H\0\275\0"..., 72}, {NULL, 0}, {"", 0}], 3) = 72
recvfrom(4, 0x148ffa4, 4096, 0, 0, 0)   = -1 EAGAIN (Resource temporarily unavailable)
recvfrom(4, 0x148ffa4, 4096, 0, 0, 0)   = -1 EAGAIN (Resource temporarily unavailable)
read(5, "60%\n75%\n80%\n100%\nend\n", 255) = 21
poll([{fd=4, events=POLLIN|POLLOUT}], 1, 4294967295) = 1 ([{fd=4, revents=POLLOUT}])
writev(4, [{"<\2\2\0\2\0`\4<\0\2\0\0\0`\4+\0\1\0", 20}, {NULL, 0}, {"", 0}], 3) = 20
poll([{fd=4, events=POLLIN}], 1, 4294967295) = 1 ([{fd=4, revents=POLLIN}])
recvfrom(4, "\1\2/\0\0\0\0\0\\\0\200\4\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0", 4096, 0, NULL, NULL) = 32
recvfrom(4, 0x148ffa4, 4096, 0, 0, 0)   = -1 EAGAIN (Resource temporarily unavailable)
recvfrom(4, 0x148ffa4, 4096, 0, 0, 0)   = -1 EAGAIN (Resource temporarily unavailable)
shutdown(4, 2 /* send and receive */)   = 0
close(4)                                = 0
futex(0x149bb84, FUTEX_WAIT_BITSET_PRIVATE|FUTEX_CLOCK_REALTIME, 5, {1370431460, 265768000}, ffffffff^C <unfinished ...>

Nothing more came after i pasted the pictures, libreoffice just freezed up, i had to kill libreoffice to stop it.
Comment 3 Alf Tonny Bätz 2013-06-05 13:07:10 UTC
little more info to this i got from gdb

warning: no loadable sections found in added symbol-file system-supplied DSO at 0x7fff6d2b7000
0x00007f044d6ee55f in icu_48::OpenTypeLayoutEngine::adjustGlyphPositions(unsigned short const*, int, int, signed char, icu_48::LEGlyphStorage&, LEErrorCode&) () from /usr/lib/x86_64-linux-gnu/libicule.so.48
Comment 4 Alf Tonny Bätz 2013-06-06 06:51:33 UTC
done some more research here is a backtrace to libreoffice when its crashing after pasting pictures.

#0  0x00007ffff3477a08 in ?? () from /usr/lib/x86_64-linux-gnu/libicule.so.48
#1  0x00007ffff346e547 in ?? () from /usr/lib/x86_64-linux-gnu/libicule.so.48
#2  0x00007ffff347048a in ?? () from /usr/lib/x86_64-linux-gnu/libicule.so.48
#3  0x00007ffff34705d2 in ?? () from /usr/lib/x86_64-linux-gnu/libicule.so.48
#4  0x00007ffff3470659 in ?? () from /usr/lib/x86_64-linux-gnu/libicule.so.48
#5  0x00007ffff3475fef in ?? () from /usr/lib/x86_64-linux-gnu/libicule.so.48
#6  0x00007ffff3476786 in ?? () from /usr/lib/x86_64-linux-gnu/libicule.so.48
#7  0x00007ffff347173c in ?? () from /usr/lib/x86_64-linux-gnu/libicule.so.48
#8  0x00007ffff3467f87 in icu_48::OpenTypeLayoutEngine::glyphProcessing(unsigned short const*, int, int, int, signed char, icu_48::LEGlyphStorage&, LEErrorCode&) () from /usr/lib/x86_64-linux-gnu/libicule.so.48
#9  0x00007ffff34689f0 in icu_48::OpenTypeLayoutEngine::computeGlyphs(unsigned short const*, int, int, int, signed char, icu_48::LEGlyphStorage&, LEErrorCode&)
    () from /usr/lib/x86_64-linux-gnu/libicule.so.48
#10 0x00007ffff346a7e0 in icu_48::LayoutEngine::layoutChars(unsigned short const*, int, int, int, signed char, float, float, LEErrorCode&) ()
   from /usr/lib/x86_64-linux-gnu/libicule.so.48
#11 0x00007ffff6d89109 in ?? ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#12 0x00007ffff6be6e0f in ?? ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#13 0x00007ffff6be79b5 in OutputDevice::GetTextArray(String const&, int*, unsigned short, unsigned short) const ()
 from /usr/lib/libreoffice/program/libmergedlo.so
#14 0x00007ffff6b9df3a in ?? ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#15 0x00007fffc6bc3c52 in ?? ()
   from /usr/lib/libreoffice/program/../program/libswlo.so
#16 0x00007fffc6bc5b6b in ?? ()
   from /usr/lib/libreoffice/program/../program/libswlo.so
#17 0x00007fffc6bc6619 in ?? ()
   from /usr/lib/libreoffice/program/../program/libswlo.so
#18 0x00007fffc6d2553f in ?? ()
   from /usr/lib/libreoffice/program/../program/libswlo.so
#19 0x00007fffc6d25f2a in ?? ()
   from /usr/lib/libreoffice/program/../program/libswlo.so
#20 0x00007fffc6dbccae in ?? ()
   from /usr/lib/libreoffice/program/../program/libswlo.so
#21 0x00007fffc6db6a31 in ?? ()
   from /usr/lib/libreoffice/program/../program/libswlo.so
#22 0x00007fffc6d9c3c2 in ?? ()
   from /usr/lib/libreoffice/program/../program/libswlo.so
#23 0x00007fffc6d2553f in ?? ()
   from /usr/lib/libreoffice/program/../program/libswlo.so
#24 0x00007fffc6d2553f in ?? ()
   from /usr/lib/libreoffice/program/../program/libswlo.so
#25 0x00007fffc6d2742a in ?? ()
   from /usr/lib/libreoffice/program/../program/libswlo.so
#26 0x00007fffc6f97b8c in ViewShell::ImplEndAction(unsigned char) ()
   from /usr/lib/libreoffice/program/../program/libswlo.so
#27 0x00007fffc6b0937f in SwCrsrShell::EndAction(unsigned char) ()
   from /usr/lib/libreoffice/program/../program/libswlo.so
#28 0x00007fffc6c6511a in SwEditShell::EndAllAction() ()
   from /usr/lib/libreoffice/program/../program/libswlo.so
#29 0x00007fffc70dec44 in ?? ()
   from /usr/lib/libreoffice/program/../program/libswlo.so
#30 0x00007fffc70dff4f in ?? ()
   from /usr/lib/libreoffice/program/../program/libswlo.so
#31 0x00007fffc715afbf in ?? ()
   from /usr/lib/libreoffice/program/../program/libswlo.so
#32 0x00007ffff5ee76f0 in ?? ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#33 0x00007ffff5ee0f64 in ?? ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#34 0x00007ffff5ee29eb in SfxDispatcher::_Execute(SfxShell&, SfxSlot const&, SfxRequest&, unsigned short) () from /usr/lib/libreoffice/program/libmergedlo.so
#35 0x00007ffff5cc5444 in ?? ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#36 0x00007ffff5cf7321 in ?? ()
Comment 5 Alf Tonny Bätz 2013-06-06 06:54:52 UTC
I tryed libreoffice version 3 yesterday with same resaults.
Comment 6 Alf Tonny Bätz 2013-06-06 08:01:22 UTC
I have got some people to test on differents distro,

wheezy, magaia, arch, ubuntu 12.04, 12.10, 13.04, 

same resaults, so it is distro agnostic
Comment 7 Paijo 2013-06-07 16:49:21 UTC
Just some test in my laptop:

I try to paste the whole page from google image search to LO-Write gives these result:
1. Google Chrome: Crash
2. Firefox: Crash
3. Opera: Shows some text only

I try to paste (Ctrl+V) single image:
1. Google Chome: Crash
2. Firefox: Crash
3. Opera: Success

Paste Special a single image as bitmap success for firefox and chrome.

OS: Ubuntu 13.04
LO: 4.0.2
Comment 8 marshals 2013-06-07 17:02:44 UTC
see also bug 55735
Comment 9 tommy27 2014-01-05 12:55:15 UTC
please test again Linux versions 4.1.4.2 and 4.2.0.1rc
Comment 10 Alf Tonny Bätz 2014-02-05 11:25:45 UTC
sorry to say the bug is still there in version 4.1.4.2
Comment 11 retired 2014-02-05 19:50:20 UTC
Alf Tonny Bätz: what about 4.2.0.4?
Comment 12 marshals 2014-02-13 14:30:07 UTC
(In reply to comment #11)
> Alf Tonny Bätz: what about 4.2.0.4?

yes, i can reproduce the problem if i right-click/copy image of the commons.wikimedia.org tree image from the google search results page, and C-v into a blank document.  (as the original op suggested, do this from the google search page, don't left-click on the image first and then copy.)

once writer is responsive again, if i scroll so that the image is invisible, and then scroll back, cpu usage goes back to 100% for a some time again.

for me, the image is never shown in the document.

this is with 4.2.0.4 (win7ult-32b).
Comment 13 Alf Tonny Bätz 2014-04-04 07:02:13 UTC
> Alf Tonny Bätz: what about 4.2.0.4?

Sorry to say the bug i stil there in libreoffice version 4.2.2.1 (and i guess also in 4.2.0.4..;)


Best regards
Comment 14 QA Administrators 2015-06-08 14:42:04 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.3 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results;
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-06-08
Comment 15 Buovjaga 2015-08-02 09:51:06 UTC
(In reply to marshals from comment #12)
> (In reply to comment #11)
> > Alf Tonny Bätz: what about 4.2.0.4?
> 
> yes, i can reproduce the problem if i right-click/copy image of the
> commons.wikimedia.org tree image from the google search results page, and
> C-v into a blank document.  (as the original op suggested, do this from the
> google search page, don't left-click on the image first and then copy.)
> 
> once writer is responsive again, if i scroll so that the image is invisible,
> and then scroll back, cpu usage goes back to 100% for a some time again.
> 
> for me, the image is never shown in the document.
> 
> this is with 4.2.0.4 (win7ult-32b).

I don't get the problem. Did exactly as described.

Setting to WFM as there was no response to retest plea. If you guys still experience this with 5.0, set back to NEW.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 902255645328efde34ddf62227c8278e8dd61ff0
TinderBox: Win-x86@39, Branch:master, Time: 2015-07-30_03:52:07
Locale: en-US (fi_FI)