Download it now!
Bug 55967 - EDITING: Sorts columns instead of rows
Summary: EDITING: Sorts columns instead of rows
Status: RESOLVED DUPLICATE of bug 53482
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.0.beta1
Hardware: x86 (IA32) All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 54260 columnsort (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-10-14 08:06 UTC by xeniun
Modified: 2012-10-17 09:09 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description xeniun 2012-10-14 08:06:01 UTC
If you want to sort data element in a column, it does true.
If you want to sort data element in a row, it doesn't function anymore.
Comment 1 Rainer Bielefeld Retired 2012-10-15 05:00:36 UTC
Summary tells the opposite of report

More or less [Reproducible] with  attached sample document and "LibreOffice 3.6.3.1” German UI/ German Locale [Build-ID: f8fce0b] on German WIN7 Home Premium (64bit). There are sort problems under particular circumstances, but I cna't see all details yet. Sometimes it works, sometimes it does not work



Steps how to try with attached sampel document:
1. open new spreadsheet document using button in LibO Start Center File menu
2. Type "1" into A1 anf fill A1:J1 with 1 ... 10 using Auto fill
3. Click Row Header "1" to select row 1
4. Menu 'Data-> Sort -> Options - only "include formatting checked, 
   Direction from left to right 
   -> Tab "Cirteria" = Row 1 - Descending <ok>
   Expected: 10 ... 1
   Actual: Nothing
   But: I am pretty sure that that worked for my first attempt

New Attempt
11. open new spreadsheet document using button in LibO Start Center File menu
12. Type "1" into A1 anf fill A1:J1 with 1 ... 10 using Auto fill
    Select A1:J1
    use Autofill to fill rows down J16
13. Range A1:J16 keeps selected
14. Menu 'Data-> Sort -> Options:  only "include formatting" checked, 
    Direction from left to right 
    -> Tab "Cirteria" = Row 1 - Descending <ok>
    Expected: 10 ... 1 in Row 1, following rows follow sort
    Actual: COLUMNS will be sorted
    
I am pretty sure that I reproduced a similar problem with vertical sort of columns, but currently I do not find a way to reproduce it.

A Further test filling column A with alternating 1,2 shows that sort in step 14 will be for Column A

Already reproducible with 3.6.0.4 (also see Bug 55485)

Was still ok  with Server installation of Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: a502549]" (tinderbox: Win-x86@6-fast, pull time 2012-05-31 07:33:55)

Modifying summary to current knowledge concerning problem

I can not reproduce "includes column headings" dependency in <https://bugs.freedesktop.org/show_bug.cgi?id=55485#c1>

@Spreadsheet Team
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf (and remove others in team from CC).
Comment 2 Rainer Bielefeld Retired 2012-10-15 05:01:49 UTC
*** Bug 55485 has been marked as a duplicate of this bug. ***
Comment 3 Rainer Bielefeld Retired 2012-10-15 05:02:16 UTC
OS = ALL due to Bug 55485
Comment 4 Rainer Bielefeld Retired 2012-10-15 05:10:15 UTC
Already [Reproducible] with Server Installation of  "LibreOffice 3.6.0beta1  German UI/Locale [Build-ID: 1f1cdd8] on German WIN7 Home Premium (64bit)
Comment 5 Rainer Bielefeld Retired 2012-10-15 05:39:00 UTC
*** Bug 54260 has been marked as a duplicate of this bug. ***
Comment 6 Markus Mohrhard 2012-10-17 09:09:32 UTC

*** This bug has been marked as a duplicate of bug 53482 ***