Bug 54260 - UI: Sorting left to right does not work
Summary: UI: Sorting left to right does not work
Status: RESOLVED DUPLICATE of bug 55967
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-30 10:04 UTC by Harri Pitkänen
Modified: 2012-10-15 05:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harri Pitkänen 2012-08-30 10:04:00 UTC
Problem description: 
Sorting left to right (sorting columns) does not work correctly.

Steps to reproduce:
1. Open a new empty Calc document
2. Enter the following values to A1:C2

MyTitle   A    B
MyValue   2    1

3. Select the six cells in A1:C2
4. Click Data -> Sort
5. From options select "Left to right" and "Range contains row labels"
6. From sort criteria set Sort key 1 to MyValue, ascending
7. Click OK

Current behavior:
Nothing happens.

Expected behavior:
Content of columns B and C should be swapped since 1 < 2.

A slight variation of the problem occurs if I select the entire rows 1 and 2 for sorting with the same sort options as above. This leads to rows being incorrectly swapped.

This problem did not occur in 3.5.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.0; rv:15.0) Gecko/20100101 Firefox/15.0
Comment 1 pierre-yves samyn 2012-09-14 10:01:23 UTC
I reproduce with Version 3.6.2.1 (Build ID: ba822cc) & W7 64bits
Comment 2 Jean-Baptiste Faure 2012-09-15 08:37:55 UTC
*** Bug 54360 has been marked as a duplicate of this bug. ***
Comment 3 Rainer Bielefeld Retired 2012-10-15 05:39:00 UTC
DUP of "Bug 55967 - EDITING: Sorts columns instead of rows", but currently I am not sure whether I understood all details of Row heading dependency

*** This bug has been marked as a duplicate of bug 55967 ***