Download it now!
Bug 56039 - Can't add several sort lists in Calc
Summary: Can't add several sort lists in Calc
Status: VERIFIED DUPLICATE of bug 53870
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: x86 (IA32) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-10-16 17:16 UTC by merien
Modified: 2012-10-23 08:42 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
view of the sorting list (90.81 KB, image/tif)
2012-10-16 17:16 UTC, merien
Details
View of the sorting list (51.42 KB, image/png)
2012-10-17 10:32 UTC, Roman Eisele
Details

Note You need to log in before you can comment on or make changes to this bug.
Description merien 2012-10-16 17:16:03 UTC
Created attachment 68626 [details]
view of the sorting list

LibreOffice options
LibreOffice Calc
Sorting list
Can't add several sorting list (efficient in 3.5)
Comment 1 Roman Eisele 2012-10-17 10:32:08 UTC
Created attachment 68682 [details]
View of the sorting list

Replaced attached TIFF image by copy in PNG format (easier to view and handle with most web browsers)
Comment 2 Roman Eisele 2012-10-17 10:50:12 UTC
Thank you for your bug report!

I can partially REPRODUCE this problem with LibreOffice 3.6.3.1 on Mac OS X 10.6.8 (Intel).

Of couse, I *can* add new sort lists: open the options pane at “Preferences > LibreOffice Calc > Sorting lists” and click on “New”, then enter the comma-separated list in the right colum (“Entries”), then click “Add”, and then click “New” again to add one more sort list ...
But when I *close* the “Options” dialog window and open it again, my new list(s) are not listed anymore, they are gone.

So, I would state that the problem is “New Calc sort lists are lost after closing the Options window”.

Do you see the same?

Or does bug 53870 (see
  https://bugs.freedesktop.org/show_bug.cgi?id=53870
describe your problem correctly?

Please answer (by coming back to this page:
   https://bugs.freedesktop.org/show_bug.cgi?id=56039
and adding an additional comment), then we can proceed with this bug!

Thank you in advance!


(Internal QA hint: This is more or less a DUP of bug 53870, but there are some differences, therefore I want to clarify them first before marking this as a duplicate of bug 53870.)
Comment 3 Markus Mohrhard 2012-10-17 14:04:59 UTC

*** This bug has been marked as a duplicate of bug 53870 ***
Comment 4 merien 2012-10-17 21:07:47 UTC
I aggree with you but
I guess there are two problems:
The one you discribe, (first sorting list you add is destroyed when you add a new sorting list)
and 
LibreOffice sorting lists are not visible when you open option pane "Preferences > LibreOffice Calc > Sorting lists even they are present.
Comment 5 Roman Eisele 2012-10-18 07:00:12 UTC
@ Merien:

You are right, at least at the surface there are two problems. But I hope that Markus Mohrhard’s patch for bug 53870 has fixed them both (it is possible that both problems had the same reason in the code).

So I propose:
* let’s wait until there is a new daily build including Markus’ patch,
  which was committed 2012-10-17 13:53:26 (GMT)
  (at the moment, daily builds are not coming daily ;-);
* then we (I) can test if both problems mentioned by you are fixed now;
* if yes, this (your) bug report is rightly marked as a duplicate of
  bug 53870, and does not need any further treatment;
* if no, we can always open your bug report again,
  or, even better (Markus will probably prefer this!),
  file a new bug report exactly for the remaining problem.
Comment 6 Roman Eisele 2012-10-23 08:42:41 UTC
I have checked this issue again with a new master build:
  LOdev 3.7.0.0.alpha0+ (Build ID: 370m0(Build:0);
  pull time: 2012-10-21 10:01:47),
and as far as I can tell the problem is fixed. This result confirms that the present issue was really the same bug as bug 53870, so no more action is necessary.