Bug 56121 - FILESAVE as .pptx: Drawing Shapes and pixel pictures without rotation
Summary: FILESAVE as .pptx: Drawing Shapes and pixel pictures without rotation
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-18 04:56 UTC by Rainer Bielefeld Retired
Modified: 2019-10-09 15:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample Document (18.52 KB, application/vnd.oasis.opendocument.presentation)
2012-10-18 04:56 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-10-18 04:56:10 UTC
Created attachment 68747 [details]
Sample Document

Found during my research for "Bug 34897 - FILESAVE as .pptx mis-rotates text"  with  "LibreOffice 3.6.3.1” German UI/ German Locale [Build-ID: f8fce0b] on German WIN7 Home Premium (64bit):

Rotated Shapes ans pictures wil be saved without rotation.

Steps to reproduce:

1. Open attache sample21.odp
2. Save as sample21.pptx (does not matter whether MSO2007 or OOXML)
3. Close document
4. Open .pptx with MS Powerpoint Viewer
   Bug: Smileys and home buttons are shown without rotation.
Comment 1 Rainer Bielefeld Retired 2012-10-18 04:59:43 UTC
Already with 3.3.0
Comment 2 Lennard Wasserthal 2012-11-11 10:33:21 UTC

*** This bug has been marked as a duplicate of bug 45495 ***
Comment 3 Regina Henschel 2019-10-09 15:49:42 UTC
This is indeed fixed with
Lennard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a9fc1456719da3cecda6a97454bad0642e493035

fdo#45495 pptx Export saves rotation of pictures,shapes,text

from bug 45495. But it is not duplicate to 45495.