Bug 56279 - FILESAVE: Merged Cells attribute loss when Comment in one of the cells
Summary: FILESAVE: Merged Cells attribute loss when Comment in one of the cells
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.2.1 rc
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: bibisected, regression
: 61024 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-10-22 11:48 UTC by Peter Weber
Modified: 2015-12-17 07:00 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Spreadsheet with cell comments and merge cell macro (15.01 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-10-22 11:48 UTC, Peter Weber
Details
Simple Sample (7.93 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-10-22 18:23 UTC, Rainer Bielefeld Retired
Details
bibisect output (2.77 KB, text/plain)
2012-12-13 10:17 UTC, Werner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Weber 2012-10-22 11:48:00 UTC
Created attachment 68912 [details]
Spreadsheet with cell comments and merge cell macro

Problem description:
Cells loose formatting (merged cell attribute) after save and reopen
if some cells have comments attached.

This worked fine in version 3.5.4.7.

Steps to reproduce:
1. Open cell_merge_test2.ods
2. Run basic macro Format_Staggered -> enter sheet name T1, when asked
3. Save file
4. Reopen file: cells are not merged anymore on the left of cells 
                containing comments/annotations

Current behavior:
Cells are merged in a staggered way by running the macro.
This works as expected.
Some of the cells are not merged anymore after file save and reopen.

Expected behavior:
Cells should stay merged even if they contain comments.


Platform (if different from the browser): 
SuSE Linux 12.1, x86_64
              
Browser: Mozilla/5.0 (X11; Linux x86_64; rv:16.0) Gecko/20100101 Firefox/16.0
Comment 1 Rainer Bielefeld Retired 2012-10-22 17:24:41 UTC
I see the effect with "LibreOffice 3.6.3.1” German UI/ German Locale [Build-ID: f8fce0b] on German WIN7 Home Premium (64bit), but that's - ehm - not the most simple sample document I can imagine. I will try to reduce that sample.
Comment 2 Rainer Bielefeld Retired 2012-10-22 17:55:52 UTC
Reproducible] with "LibreOffice 3.6.3.1” German UI/ German Locale [Build-ID: f8fce0b] on German WIN7 Home Premium (64bit) :

1. Open attached "sample201.ods" with comments in B5, E5, I5
   activate Navigator if necessary
2. Merge Cells with same numbers A5:B5, E5:F5, J5:K5 Using the
   'Merge and Center' Icon
   First surprise: Comment 11 lost (That might be a different bug)
3. Menu 'File -> Save as - "sample201_M.ods"
4. Close, then reopen
   Expected: Looks like after step 3
   Actual: All Comments lost (see Navigator )
           A5:B5 no longer merged, E5:F5 no longer merged

What means: all merged cells lost merging if one of the merged cells contain a Comment.

I failed to reproduce the problem with only a single merged cell pair with comment

Already [Reproducible] with Server Installation of "LibreOffice 3.6.2.1 rc  German UI/ German Locale [Build-ID:  ba822cc] on German WIN7 Home Premium (64bit) 

Was still ok with
-  Server Installation of  "LibreOffice 3.6.0beta1  German UI/Locale [Build-ID: 1f1cdd8] on German WIN7 Home Premium (64bit)
Comment 3 Rainer Bielefeld Retired 2012-10-22 18:23:57 UTC
Created attachment 68921 [details]
Simple Sample

See Comment 2 how to use!
Comment 4 Rainer Bielefeld Retired 2012-10-22 20:38:28 UTC
Still [Reproducible] with parallel installation of Master "LOdev  3.7.0.0.alpha0+   -  ENGLISH UI / German Locale  [Build ID: 370m0(Build:0)]"  {tinderbox: @6, pull time 2012-10-20 14:21:35} on German WIN7 Home Premium (64bit) with separate User Profile for Master Branch

Definitive not a FILEOPEN problem.
Comment 5 Werner 2012-12-13 10:17:00 UTC
Created attachment 71436 [details]
bibisect output

Results from Bibisect 4.0
Comment 6 Michael Stahl (CIB) 2012-12-21 13:10:39 UTC
Calc devs needed to look at bibisect output
Comment 7 Robinson Tryon (qubit) 2013-10-23 16:45:11 UTC
Removing comma from whiteboard (please use a space to delimit values in this field)
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Whiteboard#Getting_Started
Comment 8 Xisco Faulí 2014-07-30 09:58:36 UTC
Replace bibisected40 by bibisected and add regression to keywords
Comment 9 Matthew Francis 2015-01-13 06:41:57 UTC
Not reproduced with 4.3.4.1, 4.4 beta or 4.5 master

The issue that not all comments are preserved when cells are merged has been raised as bug 88355


Setting RESOLVED - WORKSFORME
Comment 10 Matthew Francis 2015-01-13 06:58:09 UTC
*** Bug 61024 has been marked as a duplicate of this bug. ***
Comment 11 Robinson Tryon (qubit) 2015-12-17 07:00:54 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]