Bug 56393 - first page has different width (by default)
Summary: first page has different width (by default)
Status: RESOLVED DUPLICATE of bug 59270
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: Other Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-10-25 13:36 UTC by Lior Kaplan
Modified: 2013-02-08 15:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screen shot with the problem (69.48 KB, image/png)
2012-10-25 13:36 UTC, Lior Kaplan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lior Kaplan 2012-10-25 13:36:17 UTC
Created attachment 69070 [details]
screen shot with the problem

While testing LibO 3.7/master (build from commit 5ad86ef on Debian testing 64bit), I've noticed that the first page have different width. This is mainly visible in lists or tables, but also appear in just regular text.

See attached screen shot.

Going to format -> page and applying whatever you have there makes all pages to have the same width. Another option is to page a large text (more than one page) which makes all pages be the same size.

Steps to reproduce:
1. Create new writer document
2. Enter text lines repetitively so it would expand to another page (don't paste a large text to shortcut). The easiest option is to Hit return till the next page.

After saving the file and reopening it, the "problem" doesn't appear.
Comment 1 Rainer Bielefeld Retired 2012-11-18 11:29:24 UTC
@Lior
I think it might be interesting to check 'Format -> Page' for both pages in your document. Can you see any differences?
Can you attach the default Writer Template here?
Comment 2 Rainer Bielefeld Retired 2012-11-18 12:03:32 UTC
I should have mentioned: NOT Steps how to reproduce reproducible with parallel installation of Master "LOdev  4.0.0.0.alpha0+   -  ENGLISH UI / German Locale  [Build ID: a2b3ee)]"  {tinderbox: @6, pull time 2012-11-13 06:07:28} on German WIN7 Home Premium (64bit) with separate /4 User Profile for Master Branch
Comment 3 Rainer Bielefeld Retired 2012-11-18 12:13:20 UTC
grrrr, danmned copy / past - please strike "Steps how to" in comment above
Comment 4 Lior Kaplan 2012-11-20 19:10:33 UTC
I can't attach anything as saving and reopening a file doesn't have the problem, only new documents before saved.
Comment 5 Lior Kaplan 2012-11-20 19:11:29 UTC
And there's no difference if the page format between the first and second pages, or even comparing to the document after being saved and reopened.
Comment 6 Rainer Bielefeld Retired 2012-11-20 21:23:17 UTC
@Lior Kaplan
Please attach your default template what is used for new "Untitled" documents.
Comment 7 Lior Kaplan 2013-01-22 20:50:55 UTC
Still have the same problem with 4.0.0 RC1, can't reproduce on 3.6.5 RC2.

@Rainer - where is the default template? instructions would be great.
Comment 8 Caolán McNamara 2013-02-08 15:36:31 UTC
I can't reproduce this either. Tried setting locale to en_US, and different zoom levels. My only thought it that it might be someway related to the new first page stuff. 

caolanm->mstahl/vmiklos. Either of you able to reproduce this or recognize the effect ?

caolanm->lior: Is this reproducible for you using the 4-0 bibisect builds ?
https://wiki.documentfoundation.org/QA/HowToBibisect
if it is, then knowing the commit range where it appears might help us figure this out.
Comment 9 Michael Stahl (allotropia) 2013-02-08 15:53:56 UTC
sounds familiar; there were a few problems with the first-page-style feature.

and if you had set "regression" keyword we might have fixed it sooner :)

*** This bug has been marked as a duplicate of bug 59270 ***