Bug Hunting Session
Bug 59270 - TEMPLATE related: Page margin changes unexpectedly on page two
Summary: TEMPLATE related: Page margin changes unexpectedly on page two
Status: RESOLVED DUPLICATE of bug 59779
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.1 rc
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
: 56393 (view as bug list)
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2013-01-12 06:58 UTC by webofht-libreofficebugs002
Modified: 2013-02-08 15:53 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing different page margins (71.81 KB, application/vnd.oasis.opendocument.graphics)
2013-01-12 06:58 UTC, webofht-libreofficebugs002
Details
Saved the sample document (8.57 KB, application/vnd.oasis.opendocument.text)
2013-01-12 11:42 UTC, webofht-libreofficebugs002
Details
LODev 4.0 Screenshot (85.85 KB, image/png)
2013-01-28 21:25 UTC, NoOp
Details
LO 3.6 screenshot (76.32 KB, image/png)
2013-01-28 21:26 UTC, NoOp
Details
LODev 4.0 Windows Screenshot (77.08 KB, image/png)
2013-01-29 06:42 UTC, NoOp
Details
WinLO4 with language settings at UK vs US (78.84 KB, image/png)
2013-01-30 01:49 UTC, NoOp
Details
Same WinLO4 with language reset to English(US) (77.56 KB, image/png)
2013-01-30 01:51 UTC, NoOp
Details
Same WinLO4 with language reset to English(US) (77.56 KB, image/png)
2013-01-30 01:54 UTC, NoOp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description webofht-libreofficebugs002 2013-01-12 06:58:12 UTC
Created attachment 72889 [details]
Screenshot showing different page margins

Problem description: The page margin changes unexpectedly on page two in LibreOffice 4.0.0.1. This is not an issue in LibreOffice 3.6.4.3. This is a software regression.

Steps to reproduce:
1. The operating system used is Linux debian 2.6.32-5-686 #1 SMP Sun Sep 23 09:49:36 UTC 2012 i686 GNU/Linux.
2. The LibreOffice versions involved are:
- LibreOffice Version 3.6.4.3 (Build ID: 2ef5aff) (LO3.6.4)
- LibreOffice Version 4.0.0.1 (Build ID: 527dba6f6e0cfbbc71bd6e7b88a52699bb48799) (LO4.0.0.1)
3. File -> New -> Text Document
4. Press and hold down Enter or type some text and repeatedly hit Enter until page two appears.
5. Compare:
- In LO4.0.0.1, the page margin becomes narrow on page two.
- In LO3.6.4, the page margin stays the same on page two.

6. This issue also exists on Windows 7.

Current behavior: The page margin becomes narrow on page two.

Expected behavior: The page margin should stay the same on page two as the one on page one.

I am submitting the screenshot showing different page margins.

Regards,
C. H. D.
Operating System: All
Version: 4.0.0.1 rc
Last worked in: 3.6.4.3 release
Comment 1 Rainer Bielefeld Retired 2013-01-12 09:08:58 UTC
@webofht-libreofficebugs002
Please attach the sample document from what you did the screenshots
Comment 2 webofht-libreofficebugs002 2013-01-12 11:42:21 UTC
Created attachment 72898 [details]
Saved the sample document

The saved document shows the same narrow page margin when it is opened in LibreOffice 4.0.0.1.

When the document is not saved (untitled), the screen shows that the page margin is wide on page one and the page margin becomes narrow on page two.

Saving and reopening the untitled document shows the narrow page margin on page one and page two. The wide page margin is not there.

The page margins are not consistent in an untitled document.

Regards, 
C. H. D.
Comment 3 Rainer Bielefeld Retired 2013-01-22 07:20:40 UTC
NOT reproducible with reporter's sample 2013-01-12 11:42 UTC and  parallel installation of  "LibO  4.0.0.1 rc   -  GERMAN UI / German Locale  [Build ID: 527dba6f6e0cfbbc71bd6e7b88a52699bb48799)]"  {tinderbox: @6, pull time 2013-01-10(?)} on German WIN7 Home Premium (64bit) with separate /40 User Profile for Master Branch

Newly created documents and reporter's sample have 20mm margin all around.

@reporter:
What Page Styles do you see for the pages in your document ('<f11> -> Page styles')?
Comment 4 webofht-libreofficebugs002 2013-01-22 15:40:40 UTC
(In reply to comment #3)

> @reporter:
> What Page Styles do you see for the pages in your document ('<f11> -> Page
> styles')?

The "default" one.

_Before_ saving a new document, the first page is different from the other pages.

_After_ saving the new document, no difference is displayed.
Comment 5 Rainer Bielefeld Retired 2013-01-22 15:55:40 UTC
So I now am helpless, have no more ideas how to get that reproducible.
Comment 6 Joel Madero 2013-01-23 14:56:06 UTC
Unable to reproduce. 

Version 4.1.0.0.alpha0+ (Build ID: 593e6ed34f89c8abba41a771d5de05aebd600fb)
Comment 7 Joel Madero 2013-01-23 18:01:58 UTC
We have 4 QA staff that has looked at this and no one can reproduce. Marking as WFM. 

@webofht - if this is still an issue for you with RC2 that is being released in the coming days please reopen as UNCONFIRMED and add as much detail about your environment as possible. Also please reset your profile before testing
Comment 8 Rainer Bielefeld Retired 2013-01-23 18:24:28 UTC
@webofht-libreofficebugs002@yahoo.com.hk
So we continue in a closed Bug ...

I still think that it's a templates problem, probably related to your PC.

The most easy test would be to rename the user profile<https://wiki.documentfoundation.org/UserProfile#User_profile_location>
and test again.

If that fails you can do some additional experiments with page templates. Unfortunately I have some difficulties to understand the new Template Manager design. You can get assistance on
<http://ask.libreoffice.org/questions/>
or on the public users mailing list <users@libreoffice.org>, a mailing list from <http://www.documentfoundation.org/contribution/#lists> or
<http://wiki.documentfoundation.org/Local_Mailing_Lists> 

I currently have no more ideas what we could test (except above, of course).

Please feel free to reopen this Bug if discussion with other users leaded to an assessment that we have a LibO bug  with a current LibO Version and a clear and comprehensible description of the problem due to  <http://wiki.documentfoundation.org/BugReport>.
Comment 9 webofht-libreofficebugs002 2013-01-26 12:56:47 UTC
I think a video may show the bug:

Using LibreOffice Version 4.0.0.2 (Build ID: 408fe71bd18616c467b3dcd7ab6756528ffcae2), the video is made:

http://youtu.be/IRA0ZIEDb7k
Comment 10 Rainer Bielefeld Retired 2013-01-26 18:54:11 UTC
@webofht-libreofficebugs002:
Thank you for the video, but I'm afraid that's some misunderstanding. The problem is not that we would not believe you, but that we did not find a way how to reproduce that. And that's the precondition for a fix. We know how to type some <Enter> for a new page ;-)

Can you please follow my instructions in Comment 8 and do a first test with a blank new user profile?
Comment 11 Joel Madero 2013-01-28 16:01:45 UTC
Closing again as NEEDINFO until reporter tests with a fresh profile.

@webofht: if you test with a fresh profile and it's still an issue, please reopn the bug as UNCONFIRMED and we'll do another round of triage work.

Welcome to the wonderful world of guess and check :-D Thanks for your patience and help on this, if we're able to at least find one independent confirmation, we can try to track down what in your environment is causing this.
Comment 12 NoOp 2013-01-28 21:24:29 UTC
Confirmed on:

Version 4.0.1.0+ (Build ID: 28530d7c254ec154ed1f82b32bea4d59665632e)
TinderBox: Linux-x86_64_11-Release-Configuration, Branch:libreoffice-4-0, Time: 2013-01-25_00:47:35

$ cat /opt/lodev4.0/program/versionrc
[Version]
AllLanguages=en-US
BuildVersion=
buildid=28530d7c254ec154ed1f82b32bea4d59665632e
ExtensionUpdateURL=http://updateexte.libreoffice.org/ExtensionUpdateService/check.Update
ProductBuildid=0
ProductMajor=400
ProductMinor=0
ProductSource=OOO400
ReferenceOOoMajorMinor=3.4
UpdateID=LOdev_4_en-US
UpdateURL=http://update.libreoffice.org/check.php?pkgfmt=deb
UpdateUserAgent=<PRODUCT> (${buildid}; ${_OS}; ${_ARCH}; BundledLanguages=${AllLanguages})
Vendor=The Document Foundation

 (see the attached screenshots).
Comment 13 NoOp 2013-01-28 21:25:47 UTC
Created attachment 73797 [details]
LODev 4.0 Screenshot
Comment 14 NoOp 2013-01-28 21:26:28 UTC
Created attachment 73798 [details]
LO 3.6 screenshot
Comment 15 webofht-libreofficebugs002 2013-01-29 01:07:22 UTC
(In reply to comment #11)
> Closing again as NEEDINFO until reporter tests with a fresh profile.
> 
> @webofht: if you test with a fresh profile and it's still an issue, please
> reopn the bug as UNCONFIRMED and we'll do another round of triage work.
> 
> Welcome to the wonderful world of guess and check :-D Thanks for your
> patience and help on this, if we're able to at least find one independent
> confirmation, we can try to track down what in your environment is causing
> this.

After removing the user profile and restarting, the issue is still there on Debian Linux:

$ cat /opt/libreoffice4.0/program/versionrc 
[Version]
AllLanguages=en-US
BuildVersion=
buildid=408fe71bd18616c467b3dcd7ab6756528ffcae2
ExtensionUpdateURL=http://updateexte.libreoffice.org/ExtensionUpdateService/check.Update
ProductBuildid=102
ProductMajor=400
ProductMinor=0
ProductSource=OOO400
ReferenceOOoMajorMinor=3.4
UpdateID=LibreOffice_4_en-US
UpdateURL=http://update.libreoffice.org/check.php?pkgfmt=deb
UpdateUserAgent=<PRODUCT> (${buildid}; ${_OS}; ${_ARCH}; BundledLanguages=${AllLanguages})
Vendor=The Document Foundation



After removing the user profile and restarting, the issue is still there on Windows 7 Professional (64-bit Operating System):

C:\Program Files (x86)\LibreOffice 4.0\program\version

[Version]
AllLanguages=en-US af am ar as ast be bg bn bn-IN bo br brx bs ca ca-XV cs cy da de dgo dz el en-GB en-ZA eo es et eu fa fi fr ga gd gl gu he hi hr hu id is it ja ka kk km kn ko kok ks ku lb lo lt lv mai mk ml mn mni mr my nb ne nl nn nr nso oc om or pa-IN pl pt pt-BR ro ru rw sa-IN sat sd sh si sid sk sl sq sr ss st sv sw-TZ ta te tg th tn tr ts tt ug uk uz ve vi xh zh-CN zh-TW zu
BuildVersion=
buildid=5991f37846fc3763493029c4958b57282c2597e
ExtensionUpdateURL=http://updateexte.libreoffice.org/ExtensionUpdateService/check.Update
MsiProductVersion=4.0.0.2
ProductBuildid=102
ProductCode={57343304-C3E5-4214-9FE6-948507AB850A}
ProductMajor=400
ProductMinor=0
ProductSource=OOO400
ReferenceOOoMajorMinor=3.4
UpdateID=LibreOffice_4_en-US_af_am_ar_as_ast_be_bg_bn_bn-IN_bo_br_brx_bs_ca_ca-XV_cs_cy_da_de_dgo_dz_el_en-GB_en-ZA_eo_es_et_eu_fa_fi_fr_ga_gd_gl_gu_he_hi_hr_hu_id_is_it_ja_ka_kk_km_kn_ko_kok_ks_ku_lb_lo_lt_lv_mai_mk_ml_mn_mni_mr_my_nb_ne_nl_nn_nr_nso_oc_om_or_pa-IN_pl_pt_pt-BR_ro_ru_rw_sa-IN_sat_sd_sh_si_sid_sk_sl_sq_sr_ss_st_sv_sw-TZ_ta_te_tg_th_tn_tr_ts_tt_ug_uk_uz_ve_vi_xh_zh-CN_zh-TW_zu
UpdateURL=http://update.libreoffice.org/check.php
UpgradeCode={4B17E523-5D91-4E69-BD96-7FD81CFA81BB}
UpdateUserAgent=<PRODUCT> (${buildid}; ${_OS}; ${_ARCH}; BundledLanguages=${AllLanguages})
Vendor=The Document Foundation
Comment 16 Rainer Bielefeld Retired 2013-01-29 05:48:18 UTC
@NoOp:
a) What of the pages shows correct margins, page 1 or page 2? I think amore interesting fact that the margin changes would be what page is shown with wrong margins.
b) Any Idea how to make this one reproducible for everybody?
Comment 17 NoOp 2013-01-29 06:20:05 UTC
@Rainer: Page one (top page) is the correct margin. Reproducing is easy, as mentioned in the original description:

1. Open a new LO 4.0 Writer document. 
2. Press a alpha key and continue to hold down until it spills over to page two.
3. Repeat with LO 3.4 & compare.

Note: it is important to 'open a new' Writer document.
Comment 18 Rainer Bielefeld Retired 2013-01-29 06:39:59 UTC
@NoOp
As I already told in comment 3, the problem can't be simply reproduced, and be sure, I did not ask for an explication how to pres an alphanumeric key.
What are the margins you see on page 1?
What are the margins you see on page 2
What are your ideas why the margins changed?
Comment 19 NoOp 2013-01-29 06:42:32 UTC
Created attachment 73807 [details]
LODev 4.0 Windows Screenshot


Replicated on Windows:

LODev 4.0 Windows Screenshot
Version 4.0.0.1 (Build ID: 527dba6f6e0cfbbc71bd6e7b88a52699bb48799)
Comment 20 NoOp 2013-01-29 07:07:36 UTC
@Rainer: 

The problem *can* "simply be reproduced". I've easily reproduced the issue on linux and Windows. The OP reproduced on linux and Windows. 

You asked: "Any Idea how to make this one reproducible for everybody?"
I told you how. Why don't you actually try with the instructions provided? 

Note: your comment #3 indicates that you attempted to use the OP's attached document: "NOT reproducible with reporter's sample". So did you attempt using the OP's sample, or did you create a new document to test?

Re Margins: It is the standard default template & margins (tested with new installs and then again with new profiles. You can see for yourself from the rulers on the screenshots margins are set to (measurement is in inches.

In Comment #11 Joel stated: "Welcome to the wonderful world of guess and check :-D Thanks for your patience and help on this, if we're able to at least find one independent confirmation, we can try to track down what in your environment is causing this."

I'm an independent user, I confirmed. Rainer, if you expect users to contribute to bug reports, I'd suggest that you tone down your comments, and appreciate when and independent users take the time to test and assist.
Comment 21 headsup 2013-01-29 22:27:14 UTC
I am not able to reproduce this on x86 W8 Pro 32bit, English-UK, LibreOffice Version 4.0.0.2 .0.2 (Build ID: 5991f37846fc3763493029c4958b57282c2597e). My page settings are A4. I tested with a new document (unsaved) and default settings after a new install.
Comment 22 NoOp 2013-01-30 01:49:30 UTC
Created attachment 73896 [details]
WinLO4 with language settings at UK vs US

@headsup: Thanks, that is very helpful. From my comments & the OP's recent test you can see that we are using English US settings. So, following your post I reset the Windows version (from my Comment/attachment #19) to English(UK), restarted (standard A4 default) and tested again. The result is that I *then* could not replicate (see attached screen-shot). 

So I reset back to English(US) and could then easily replicate. This is probably the reason why Rainer & others couldn't replicate.
Comment 23 NoOp 2013-01-30 01:51:00 UTC
Created attachment 73897 [details]
Same WinLO4 with language reset to English(US)
Comment 24 NoOp 2013-01-30 01:54:16 UTC
Created attachment 73898 [details]
Same WinLO4 with language reset to English(US)

Set to png this time.
Comment 25 webofht-libreofficebugs002 2013-01-30 02:03:18 UTC
The following steps solve this issue (on Debian Linux):

Make a new template by using LibreOffice 3 or LibreOffice 4:

./.config/libreoffice/4/user/template/_savedTemplate_

File → New → Templates → My Templates 
→ click (previously saved template) → Set as default → Close Window
→ Restart LibreOffice → File → New → Text Document

The page margins are the same on page one and page two. Then, this issue is fixed.

There is something wrong in the default template.

I think a possible quick fix is to save _another_ template to replace the existing default template:

File → New → Text Document 
→ File → Save As Template

Look for the folder where the default template is located. (I do not know the location.)
Copy the saved template and paste it into that folder.

For more research, please compare the default template with the saved template. (Since I do not know the location, I cannot compare the templates on my own.)
Comment 26 NoOp 2013-01-30 02:17:19 UTC
Re Comment #25 - that may provide a 'workaround', but doesn't 'solve' the issue.
Comment 27 webofht-libreofficebugs002 2013-01-30 02:23:08 UTC
(In reply to comment #26)
> Re Comment #25 - that may provide a 'workaround', but doesn't 'solve' the
> issue.

I agree to this idea.

(In reply to comment #25)
> The following steps solve this issue (on Debian Linux):
> 
> Make a new template by using LibreOffice 3 or LibreOffice 4:
> 
> ...
(Set a new default template.)

Such steps also provide a workaround on Windows 7 Professional (64-bit Operating System).
Comment 28 Rainer Bielefeld Retired 2013-01-30 10:16:08 UTC
webofht-libreofficebugs002's results also might explain language dependencies discussed in some comments. 
Comment 25 should be enough for a NEW
Comment 29 Jorendc 2013-01-30 11:01:39 UTC
This might be related in a certain way to Bug 59779?
Comment 30 Michael Stahl (CIB) 2013-01-30 20:11:43 UTC
Comment on attachment 73897 [details]
Same WinLO4 with language reset to English(US)

same as next attachment, setting obsolete
Comment 31 Michael Stahl (CIB) 2013-01-30 20:29:49 UTC
alright can reproduce this on Linux via LC_ALL=en_US
it is fixed already in 4.0.0.3 and was fixed by
2f8abaad2830530ad299221d72964894d5ddb402

*** This bug has been marked as a duplicate of bug 59779 ***
Comment 32 NoOp 2013-01-31 00:16:13 UTC
Thanks for that. 

Version 4.0.1.0+ (Build ID: 3353687fb4af77de2a5a901d58b940367162f74)
TinderBox: Linux-x86_64_11-Release-Configuration, Branch:libreoffice-4-0, Time: 2013-01-30_08:12:00

Works for me.
Comment 33 Michael Stahl (CIB) 2013-02-08 15:53:56 UTC
*** Bug 56393 has been marked as a duplicate of this bug. ***