Bug Hunting Session
Bug 56709 - UI: Cell formatting dialog shows characters as squares for some languages
Summary: UI: Cell formatting dialog shows characters as squares for some languages
Status: VERIFIED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2012-11-03 07:01 UTC by Korrawit Pruegsanusak
Modified: 2013-09-21 08:57 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot showing what is expected vs actually rendered (105.31 KB, image/png)
2012-11-03 07:01 UTC, Korrawit Pruegsanusak
Details
Screenshot showing 4.0.0.0.alpha0+ (pull time: 2012-11-15) on Mac OS X 10.6.8 (190.06 KB, image/png)
2012-11-21 15:53 UTC, Roman Eisele
Details
Screenshot Windows 7 x64 (83.70 KB, image/png)
2013-01-11 23:32 UTC, Jorendc
Details
Screenshot on Windows 7, SUSE RC build (12.14 KB, image/png)
2013-04-19 10:01 UTC, W.H.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Korrawit Pruegsanusak 2012-11-03 07:01:43 UTC
Created attachment 69475 [details]
screenshot showing what is expected vs actually rendered

Problem:
Format Cells dialog shows Thai characters as squares.

Platform:
Reproducible on Windows 7 x64, but not on Windows XP

Steps:
1. Open new Spreadsheet
2. Right click at cell A1 > Format Cells...
3. Select Language to "Thai"

Actual: some format rendered as squares
Expected: they should be Thai characters

REPRODUCIBLE with
* Build from W2008R2@16-minimal_build, pull time 2012-10-16 08:02:45, core: 20e7a9bda9ae9eae2af47402903e17f95ae3510a
* Build from W2008R2@16-minimal_build, pull time 2012-11-01 23:27:25, core: 1219bcb0c4f1dd1753c8bb63baf957f878971b70

NOT REPRODUCIBLE with
* Build from W2008R2@16-minimal_build, pull time 2012-09-28 00:02:27, core: 77a0acae58828d2186bce241b562c363da93343b

So regression on master

Note that builds between Sep 28 and Oct 12 can't be used to test this bug, as it will crash after step 2 according to bug 55560.
Comment 1 Korrawit Pruegsanusak 2012-11-03 08:15:01 UTC
Apart from Thai, this bug also reproduce with following languages:

For Category "Number" (as in screenshot):
* Burmese
* Dzongkha
* Khmer
* Nepali (Nepal)

For Category "Date":
* Bengali (Bangladesh)
* Bengali (India)
* Burmese
* ... etc (sorry, I'm too lazy to check :-)
Comment 2 Eike Rathke 2012-11-09 15:47:49 UTC
A square means that the font used does not contain the glyph. No idea what the UI font would be on Windows.
Comment 3 Lior Kaplan 2012-11-17 16:56:11 UTC
The font settings for these languages haven't changed recently. See http://cgit.freedesktop.org/libreoffice/core/log/officecfg/registry/data/org/openoffice/VCL.xcu

I don't have any Khmer fonts on my system (Debian) which means I do see squares in numbers format with Khmer selected. After installing Khmer fonts I see regular Khmer (well, at least it isn't squares).

Could you try and switch to older version of liberation fonts ? Just to rule out 
http://cgit.freedesktop.org/libreoffice/core/commit/?id=bd6b41bce491ac5a5f562652b7e32045cc22c35c
Comment 4 Korrawit Pruegsanusak 2012-11-17 17:16:48 UTC
(In reply to comment #3)
> I don't have any Khmer fonts on my system (Debian) which means I do see
> squares in numbers format with Khmer selected. After installing Khmer fonts
> I see regular Khmer (well, at least it isn't squares).

Thanks for testing and info. Anyway, I think I already have the font for, at least, Thai.

This is because, in same computer (Win7 x64), I can reproduce the problem with some builds, but can't with another build (please see comment 0 for builds identification). I just tried again currently and still got same result.

Also, I just tried and this doesn't reproduce with 3.6 beta 1.

> Could you try and switch to older version of liberation fonts ? Just to rule
> out ...

Thanks for the suggestion! will try now ...
Comment 5 Korrawit Pruegsanusak 2012-11-17 17:49:05 UTC
While waiting for my local builds, I've just found one thing:

After opening scalc.exe, if you do right-click > Format Cells... (or Ctrl+1) *without* typing anything before, you'll be reproducible.

And if you've gone through this; typing any Thai characters will also result in squares in formula bar. But it shown correctly in table cell.

Otherwise, if you type anything in any table cell (any characters; can be in English; notice that Thai characters are shown correctly in formula bar, as opposed to the former), and then right-click any cell > Format Cells... > TADA! No squares! (means not reproducible).
Comment 6 Korrawit Pruegsanusak 2012-11-17 17:58:38 UTC
(In reply to comment #3)
> Could you try and switch to older version of liberation fonts ? Just to rule
> out 
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=bd6b41bce491ac5a5f562652b7e32045cc22c35c

OK, I tried this, and the result didn't change, so we could rule out this commit. Thanks again for suggestion :-)
Comment 7 Roman Eisele 2012-11-21 15:53:57 UTC
Created attachment 70379 [details]
Screenshot showing 4.0.0.0.alpha0+ (pull time: 2012-11-15) on Mac OS X 10.6.8


Just a hint:

NOT reproducible on Mac OS X 10.6.8 (Intel) with
LOdev 4.0.0.0.alpha0+ (Build ID: ed8067; pull time: 2012-11-15 03:54:19)

See attached screenshot. The Thai glyphs are rendered correctly, just like in LibreOffice 3.6.4.1.
Comment 8 Joel Madero 2012-12-11 16:45:36 UTC
This seems just like the language isn't installed correctly in Windows. Are you able to use the language/fonts in other software?
Comment 9 Korrawit Pruegsanusak 2012-12-11 17:25:17 UTC
Thanks everyone. In conclusion:

1. This bug is currently Windows 7 only, and not even on Windows XP. (comment 0)

2. I think my font is installed correctly; because in same computer, I can use older builds without bug, but not for newer builds. (comment 0 and comment 4)

3. To reproduce, after opening scalc.exe, you must *not* type anything into any cell. Instead, just right click the cell > Format cells ... > language Thai > category Date, and you'll see the squares. (comment 5 and attachment 69475 [details])

4. No offense here, of course :) but since this bug has been introduced between Sep 28 and Oct 16, I would like to copy Roman Eisele's comment from bug 56882 comment 4 here:

> But was has happened in this timeframe? The new Widged Layout feature landed
> in master, ...

> Of course, I may be wrong; I don’t want to blame anybody (and I really love
> the new Widget Layout feature!); I just want to help ...
Comment 10 Jorendc 2013-01-11 23:30:45 UTC
I can confirm this behavior with Windows 7 x64, LibreOffice Version 4.0.0.1 (Build id: 527dba6f6e0cfbbc71bd6e7b88a52699bb48799); Dutch UI;
Comment 11 Jorendc 2013-01-11 23:32:16 UTC
Created attachment 72877 [details]
Screenshot Windows 7 x64

When I set language to 'Thai';
Comment 12 Eike Rathke 2013-01-14 13:41:43 UTC
Seeing Windows 7 being mentioned, there was a Windows 7 update somewhen in Q4 of last year that rendered a portion of fonts unusable, maybe Korrawit and Joren are victims of that. Search the net for "Windows update KB2753842".
Comment 13 Jorendc 2013-01-14 16:49:47 UTC
(In reply to comment #12)
> Seeing Windows 7 being mentioned, there was a Windows 7 update somewhen in
> Q4 of last year that rendered a portion of fonts unusable, maybe Korrawit
> and Joren are victims of that. Search the net for "Windows update KB2753842".

I'll look at it when I'm back on my Windows OS (=dualboot with Mac OSX) ... but the problem with my versions is maybe related to the fact I haven't installed 'Thai' as a sytem language/font ... I don't use it :-) (I'm Belgian, ... so the only languages are installed is English and Dutch (as far I certainly know)...
Comment 14 Korrawit Pruegsanusak 2013-01-14 20:00:59 UTC
Eike, thanks for the info. I'll check when I'm back at my laptop.

Joren, thanks for confirming. Anyway, could you please check some other languages mentioned in comment 1 ?

Also, could you please check this (from comment 5) :
> Otherwise, if you type anything in any table cell (any characters; can be in
> English; notice that Thai characters are shown correctly in formula bar, as
> opposed to the former), and then right-click any cell > Format Cells... >
> TADA! No squares! (means not reproducible).

In other words, please follow steps in comment 0, but add one step in between step 1 and 2, as follows:
> 1. Open new Spreadsheet

ADD: type anything in any cell, then press <Enter>

> 2. Right click at cell A1 > Format Cells...
> 3. Select Language to "Thai"

IMHO if this display Thai characters correctly, it isn't a font problem.

Thanks! :)
Comment 15 Jorendc 2013-01-14 21:08:26 UTC
(In reply to comment #14)
> In other words, please follow steps in comment 0, but add one step in
> between step 1 and 2, as follows:
> > 1. Open new Spreadsheet
> 
> ADD: type anything in any cell, then press <Enter>
> 
> > 2. Right click at cell A1 > Format Cells...
> > 3. Select Language to "Thai"
> 
> IMHO if this display Thai characters correctly, it isn't a font problem.
> 
> Thanks! :)

Indeed, when I format it as a data cell with some Thai formatting ... I see nice Thai characters. So ... reproducible :-)
Comment 16 Korrawit Pruegsanusak 2013-01-14 21:44:26 UTC
Thanks :) To confirm again that it isn't font problem, Joren, could you please:

1. close libo
2. follow steps in comment 0, but select other languages listed in comment 1
-> This should show squares (bug)

3. close libo
4. follow steps in comment 14, that is, type anything before Format Cell, and select languages listed in comment 1
-> This should *not* show squares, but show characters correctly
Comment 17 Jorendc 2013-03-19 21:50:10 UTC
@Korrawit: isn't this fixed by bug 59240 ?

Kind regards,
Joren
Comment 18 Korrawit Pruegsanusak 2013-03-21 04:02:59 UTC
@Joren, unfortunately, that is different bug.
Comment 19 Rainer Bielefeld Retired 2013-04-16 15:30:05 UTC
Something went wrong here, this one has nothing to do with Bug 63585
Comment 20 W.H. 2013-04-19 09:59:55 UTC
I can not reproduce this bug on windows7 by the latest build. See attachment.
Comment 21 W.H. 2013-04-19 10:01:21 UTC
Created attachment 78226 [details]
Screenshot on Windows 7, SUSE RC build
Comment 22 Michael Meeks 2013-06-11 17:05:54 UTC
I too had a go at reproducing this; I have a clean Windows 7 SP1 x86 install inside a virtual machine, I installed LibreOffice 4.0.3 and without installing any fonts, or configuring anything it worked out of the box and displayed the Thai glyphs just fine. At least - I can't read them - but they're certainly not boxes :-)

Korrawit - thanks for filing this, I'm personally frustrated that we can't reproduce it; is there something in your profile that does this, some UI font setting ? Eike suggested a Windows bug - that may disappear on update - what is your windows 7 ? [ are you at SP1 ].

Since we have 3x guys with this working, and no way to reproduce - I'll mark it "worksforme" though - clearly it'd be great to re-open if we can do better :-)

Thanks !
Comment 23 Korrawit Pruegsanusak 2013-09-21 08:57:29 UTC
Sorry for very late reply. :(

Anyway, for a record, I've just VERIFIED that this bug is WORKSFORME on the same computer with same Windows 7 that I found and report this bug. I checked with the version that I found buggy, but now the bug vanished! I also checked with 4.1.0.4 and there was no bug, either.

In conclusion, IMHO this is some environment problem that coincidentally come and gone, not really LibreOffice problem.