Bug Hunting Session
Bug 57092 - UI: Visual glitches with the new Widget Layout: cursor does not blink in "Name" field of "Insert Table" dialog
Summary: UI: Visual glitches with the new Widget Layout: cursor does not blink in "Nam...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium minor
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.0.0
Keywords:
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2012-11-13 19:38 UTC by Roman Eisele
Modified: 2012-11-22 15:57 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Visual glitches in Insert Table dialog, LOdev 2012-11-13 on Mac OS X 10.6.8 - the cursor does not blink (52.70 KB, image/png)
2012-11-13 19:42 UTC, Roman Eisele
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Eisele 2012-11-13 19:38:45 UTC
The new Widget Layout is wonderful, but some dialog windows converted to the new .ui format show minor visual glitches, at least on Mac OS X 10.6.8 (Intel). Resetting the LibreOffice/LOdev user profile does not change this situation.

2) If I open the “Insert Table” dialog window, available in Writer via “Table > Insert > Table...”, the cursor is already in the “Name” edit field. But the cursor does not blink (as usual on Mac OS X), not even if I move the cursor via the keyboard arrow keys, edit the text inside of that edit field or click somewhere into the text inside of that edit field. If I click into the “Rows” or “Columns” edit field, the cursor does blink correctly. But as soon as I return to edit the “Name” field, the cursor does not blink anymore.

Only when I resize the dialog window manually, even if I only increase it by ca. 1 px in width or height, the cursor begins to blink inside of the “Name” edit field, as expected, and continues to work correctly (to blink) even when I switch to another edit field inside of the dialog window and then return to the “Name” edit field.

See the attached screenshot.

Tested with LOdev 4.0.0.0.alpha0+ (Build ID: 32315e; pull time: 2012-11-13 00:32:26) on Mac OS X 10.6.8 (Intel).
Comment 1 Roman Eisele 2012-11-13 19:42:48 UTC
Created attachment 70025 [details]
Visual glitches in Insert Table dialog, LOdev 2012-11-13 on Mac OS X 10.6.8 - the cursor does not blink



Well, it is hard to show a blinking or not blinking cursor on a screenshot ;-), but at least the screenshot shows (without any ambiguity) which edit field is the one with the problem.
Comment 2 Jean-Baptiste Faure 2012-11-13 21:41:09 UTC
I do not reproduce on Ubuntu 12.04 x86_64 with version 4.0.0.0.alpha0+ (Build ID: 12fa9e).

Best regards. JBF
Comment 3 Roman Eisele 2012-11-14 08:20:54 UTC
@ Jean-Baptiste Faure:
Thank you for testing! So this seems to be a MacOS-only issue ... It would be great, if someone else could test Windows.
Comment 4 Caolán McNamara 2012-11-14 13:32:02 UTC
I'm hoping this is effectively the same problem as bug 57090 and the fix there will solve this too
Comment 5 Caolán McNamara 2012-11-14 14:57:04 UTC
Yeah, that seems to work locally fine now on MacOSX. Definitely reopen if tomorrows daily still doesn't work
Comment 6 Roman Eisele 2012-11-15 10:42:56 UTC
VERIFIED as FIXED
with LOdev 4.0.0.0.alpha0+ (Build ID: ed8067; pull time: 2012-11-15 03:54:19)
on Mac OS X 10.6.8 (Intel).

The “Insert Table” dialog looks fine now by default, and the cursor blinks ;-)

@ Caolán:
Thank you very much again! I will check if similar problems in other dialog windows are fixed now, too ...