Bug 57142 - Recovery does not work after particular crash
Summary: Recovery does not work after particular crash
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: Other All
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-11-15 05:49 UTC by Rainer Bielefeld Retired
Modified: 2014-04-09 12:07 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-11-15 05:49:29 UTC
I found that during my research for "Bug 56549 - CRASH in menu 'Format → Autocorrect → Apply and Edit Changes'".

Steps how to reproduce [Reproducible] with parallel installation of Master "LOdev  3.7.0.0.alpha0+   -  ENGLISH UI / German Locale  [Build ID: 70ec82)]"  {tinderbox: @16, pull time 2012-11-09 00:53:19} on German WIN7 Home Premium (64bit) with separate User Profile for Master Branch:

1. Proceed as per Bug 56549 Comment 16
   > Crash after step 8, recovery dialog appears
2. <ok> to start recuvery
3. In New dialog '<Start Recovery>
   Expected: recovery will be done and finished successfully
   Actual: Message "The file '$(ARG1)' is corrupt and therefore cannot be opened.
           LOdev can try to repair the file. The corruption could be the result 
           of document manipulation or of structural document damage due to 
           data transmission. We recommend that you do not trust the content 
           of the repaired document. Execution of macros is disabled for this 
           document. Should LOdev repair the file?
4. <Yes> for 'repair document'
   Expected: repair
   Actual: Message "The file '$(ARG1)' could not be repaired and therefore 
           cannot be opened."
Comment 1 Rainer Bielefeld Retired 2012-11-15 06:31:59 UTC
Was ok with Server installation of  Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 475d0c5-829fc92-39746e8-206648e-fefd87]" (2012-02-14), so REGRESSION
Comment 2 Joel Madero 2012-12-06 22:00:08 UTC
Rainer: now that Bug 56549 is fixed, is this still reproducible?
Comment 3 Rainer Bielefeld Retired 2012-12-07 05:20:40 UTC
I checked with crash on "Bug 57780 - CRASH when FILEOPEN particular .doc" with parallel installation of  "LOdev  4.0.0.0.alpha1+   -  ENGLISH UI / German Locale  [Build ID:d6579884752c298a18b7cdfcc7d1614b55c9c7c)]"  {tinderbox: Win-x86@6, pull time 2012-12-06 02:46:58} on German WIN7 Home Premium (64bit) with own separate User Profile - no longer reproducible

@joel:
My problem had nothing to do with Bug 56549, that was only a posibility to get a crash
Comment 4 Rainer Bielefeld Retired 2012-12-11 14:54:53 UTC
I can reporduce thi bug with crash from "Bug 58142 - EDITING: CRASH when copy paste multiple pictures from file explorer"
Comment 5 Rainer Bielefeld Retired 2012-12-27 07:03:59 UTC
Confirmed by "Bug 58760 - EDITING: CRASH when "Insert > Indexes and Tables > Indexes and Tables...""

But not  reproducible with server  installation of  "4.1.0.0.alpha0+ (Build ID: e90807267808eb062b93d762c50c02113ca40db) TinderBox: Win-x86@6, Branch:master, Time: 2012-12-26_22:00:49   -  ENGLISH UI / German Locale  on German WIN7 Home Premium (64bit) with own separate User Profile 
and
a.m. Bug
Comment 6 Joel Madero 2013-01-14 21:57:31 UTC
Marking as NEW

Critical - crash
Highest - default for critical

thanks Rainer for the follow up
Comment 7 Michael Stahl (CIB) 2013-07-05 20:32:32 UTC
cannot reproduce this on Linux with 4.0.4 or Windows with current master or 4.0.1.

can anybody reproduce it?  in case it hasn't been fixed there should be duplicates by now...
Comment 8 Joel Madero 2013-07-08 17:38:08 UTC
Also not reproducible on 4.1 RC with Bodhi Linux. Marking as WFM.