Download it now!
Bug 58760 - EDITING: CRASH when "Insert > Indexes and Tables > Indexes and Tables..."
Summary: EDITING: CRASH when "Insert > Indexes and Tables > Indexes and Tables..."
Status: RESOLVED DUPLICATE of bug 58749
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-12-25 20:03 UTC by manj_k
Modified: 2013-01-17 14:07 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file with error messages: 'untitled_0.odt' (81.44 KB, application/vnd.oasis.opendocument.text)
2012-12-25 20:18 UTC, manj_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description manj_k 2012-12-25 20:03:22 UTC
LibO-Dev_4.1.0.0.alpha0+
Win-x86@6 MASTER
pull time 2012-12-21 12:45:13
core:9c6006b961f690728f4035c10f8b9fe9fdb6f332
(on WinXP 32b)

Installed as server image (msiexec /a) with a default user profile.

- Open Writer via StartCenter
- Type:
  ¶
  Heading 1¶
  Heading 2¶
  Heading 3¶
- Apply the corresponding styles via Formatting toolbar > 'Apply Style'
- Set the cursor in the first line (for creating a TOC)
- Menu "Insert > Indexes and Tables > Indexes and Tables..."
- Crash

Recovery process
→ Start Recovery

Message 1:
"The file '$(ARG1)' is corrupt and therefore cannot be opened. LOdev can try to repair the file.
The corruption could be the result of document manipulation or of structural document damage due to data transmission.
We recommend that you do not trust the content of the repaired document.
Execution of macros is disabled for this document.
Should LOdev repair the file?"

→ Yes

Message 2:
"The file '$(ARG1)' could not be repaired and therefore cannot be opened."

→ OK

Recovery process:
"Recovery failed"

Recovery process:
"The automatic recovery process was interrupted.
The documents listed below will be saved in the folder noted below if you click 'Save'. Click 'Cancel' to close the wizard without saving the documents."


Reproducible with:
LibO-Dev_4.1.0.0.alpha0+
Win-x86@6 MASTER
pull time 2012-12-21 23:39:29
core:d6bbdaf02d614babebeebb2fcdc00035760c2f69

LibO-Dev_4.1.0.0.alpha0+
Win-x86@6 MASTER
pull time 2012-12-25 12:12:27
core:5c0ca47ea05ac169c3aa6af5e95321b5de3e439d



Still works well with:
LibO-Dev_4.1.0.0.alpha0+
Win-x86@6 MASTER
pull time 2012-12-20 07:28:46
core:ea47c12cc8ce6f8b05905d11f1a3fd3f634f585a
Comment 1 manj_k 2012-12-25 20:18:35 UTC
Created attachment 72116 [details]
Sample file with error messages: 'untitled_0.odt'
Comment 2 m.a.riosv 2012-12-26 01:14:37 UTC
Hi manj_k,
I can not reproduce with:
Win7x64 Ultimate
Version 4.0.0.0.beta2 (Build ID: 4104d660979c57e1160b5135634f732918460a0)
with your file or from scratch.
Comment 3 manj_k 2012-12-26 01:43:08 UTC
(In reply to comment #2)
> I can not reproduce with:
> Win7x64 Ultimate
> Version 4.0.0.0.beta2 (Build ID: 4104d660979c57e1160b5135634f732918460a0)
> with your file or from scratch.

Yes, only 'LibO-Dev 4.1.0.0.alpha0+' (Master) is affected (since 2012-12-21).

That works well with
LibO-Dev 4.0.0.0.beta2,
LibO-Dev 4.0.0.0.beta2+.
Comment 4 Julien Nabet 2012-12-26 14:58:32 UTC
On pc Debian x86-64 with master sources updated today (commit ed338bc212725f422f0def21aafc82f05e350646) and brand new LO profile, I don't reproduce this crash.

Did you try with a brand new LO profile?
What's your last commit retrieved?
Would it be possible you retrieve a bt? (see https://wiki.documentfoundation.org/BugReport#How_to_get_a_backtrace_.28on_Windows.29)
Comment 5 manj_k 2012-12-26 18:41:00 UTC
(In reply to comment #4)
> Did you try with a brand new LO profile?

I have tried with about 15 brand new LO user profiles
(changed bootstrap.ini 'UserInstallation=$SYSUSERCONFIG/LibO-dev02/4', and renamed 'user_1' etc.).

> What's your last commit retrieved?

(See my description)
The very latest test has been with the current
LibO-Dev_4.1.0.0.alpha0+
Win-x86@6 MASTER
pull time 2012-12-25 12:12:27
core:5c0ca47ea05ac169c3aa6af5e95321b5de3e439d.

The problem occurred for the first time with
LibO-Dev_4.1.0.0.alpha0+
Win-x86@6 MASTER
pull time 2012-12-21 12:45:13
core:9c6006b961f690728f4035c10f8b9fe9fdb6f332.

The problem did *not* occur (for the last time)
LibO-Dev_4.1.0.0.alpha0+
Win-x86@6 MASTER
pull time 2012-12-20 07:28:46
core:ea47c12cc8ce6f8b05905d11f1a3fd3f634f585a.

> Would it be possible you retrieve a bt? (see
> https://wiki.documentfoundation.org/BugReport#How_to_get_a_backtrace_.
> 28on_Windows.29)

Sorry, I can't do it.

Maybe, there's a second tester on Windows ... ;)
Comment 6 Julien Nabet 2012-12-26 21:57:05 UTC
manj: perhaps I'm wrong but it seems you compile yourself the sources. Did you try a "make clean && make"?
I tried to add Tables and index on your file, I hadn't got a crash.

Rainer: would you have some time to give it a try?
Comment 7 Rainer Bielefeld Retired 2012-12-27 07:11:30 UTC
[Reproducible] with reporter's sample document and  server  installation of  "4.1.0.0.alpha0+ (Build ID: e90807267808eb062b93d762c50c02113ca40db) TinderBox: Win-x86@6, Branch:master, Time: 2012-12-26_22:00:49   -  ENGLISH UI / German Locale  on German WIN7 Home Premium (64bit) with own separate User Profile 

Strange, I do not see the "Bug 57142 - Recovery does not work after particular crash" "The automatic recovery process was interrupted...." problem.

With this Version I also get the crash with a blank new document when I 'Insert > Indexes and Tables > Indexes and Tables...', so this one might be related to or DUP of "Bug 58752 - EDITING: Crash when "Insert > Frame""
Comment 8 Julien Nabet 2012-12-27 07:54:50 UTC
Still no crash with master sources but if it can help, here are some logs console just after having inserted an index on a brand new file (and so empty document):

warn:legacy.osl:8797:1:/home/julien/compile-libreoffice/libo/svtools/source/graphic/grfmgr2.cxx:1447: Missing implementation: Mtf-Transparency
warn:legacy.osl:8797:1:/home/julien/compile-libreoffice/libo/svtools/source/graphic/grfmgr2.cxx:1447: Missing implementation: Mtf-Transparency
warn:legacy.osl:8797:1:/home/julien/compile-libreoffice/libo/sw/source/core/attr/calbck.cxx:231: Client added to active ClientIter
warn:legacy.osl:8797:1:/home/julien/compile-libreoffice/libo/sw/source/core/attr/calbck.cxx:231: Client added to active ClientIter
warn:legacy.osl:8797:1:/home/julien/compile-libreoffice/libo/sw/source/core/attr/calbck.cxx:231: Client added to active ClientIter
warn:legacy.osl:8797:1:/home/julien/compile-libreoffice/libo/sw/source/core/attr/calbck.cxx:231: Client added to active ClientIter
warn:legacy.osl:8797:1:/home/julien/compile-libreoffice/libo/sw/source/core/attr/calbck.cxx:231: Client added to active ClientIter
warn:legacy.osl:8797:1:/home/julien/compile-libreoffice/libo/sw/source/core/attr/calbck.cxx:231: Client added to active ClientIter
warn:legacy.osl:8797:1:/home/julien/compile-libreoffice/libo/sw/source/core/attr/calbck.cxx:231: Client added to active ClientIter
warn:legacy.osl:8797:1:/home/julien/compile-libreoffice/libo/sw/source/core/attr/calbck.cxx:231: Client added to active ClientIter
warn:legacy.osl:8797:1:/home/julien/compile-libreoffice/libo/sw/source/core/attr/calbck.cxx:231: Client added to active ClientIter
warn:legacy.osl:8797:1:/home/julien/compile-libreoffice/libo/sw/source/core/attr/format.cxx:220: SwFmt::~SwFmt: Def dependents!
warn:legacy.osl:8797:1:/home/julien/compile-libreoffice/libo/sw/source/core/attr/format.cxx:229: ~SwFmt: parent format missing from: Textformatvorlage
warn:legacy.osl:8797:1:/home/julien/compile-libreoffice/libo/framework/source/fwi/threadhelp/transactionmanager.cxx:315: ASSERT:
	TransactionManager...
	"Owner instance stand in close method. Call was rejected!"

Cédric/Michael: one for you?
Comment 9 manj_k 2012-12-27 11:36:22 UTC
@Julien Nabet
(In reply to comment #6)

All my tested builds are the "official" tinderbox builds on
→ http://dev-builds.libreoffice.org/daily/master/Win-x86@6/ .
Comment 10 manj_k 2012-12-27 11:50:59 UTC
@Rainer Bielefeld
(In reply to comment #7):

Thanks for confirming.

'Bug 57142 - Recovery does not work after particular crash' doesn't occur consistently with this command, and the same document. Sometimes it has been recovered with success, and sometimes the recovery failed.
Comment 11 Caolán McNamara 2013-01-17 14:07:28 UTC

*** This bug has been marked as a duplicate of bug 58749 ***