Download it now!
Bug 58749 - CRASH when "Format > Page"
Summary: CRASH when "Format > Page"
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.1.0
Keywords: regression
: 58750 58751 58752 58760 59252 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-25 15:35 UTC by manj_k
Modified: 2013-05-27 10:05 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample: 'user_profile.zip' (233.02 KB, application/zip)
2012-12-26 11:19 UTC, manj_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description manj_k 2012-12-25 15:35:43 UTC
LibO-Dev_4.1.0.0.alpha0+
Win-x86@6 MASTER
pull time 2012-12-21 12:45:13
core:9c6006b961f690728f4035c10f8b9fe9fdb6f332
(on WinXP 32b)

Installed as server image (msiexec /a) with a default user profile.

(1)
- Open Writer via StartCenter
- Menu "Format > Page"
- Crash

(2)
- Open Writer via StartCenter
- Menu "Format > Styles and Formatting > Page Styles > Default Style > Modify"
- Crash


Reproducible with:
LibO-Dev_4.1.0.0.alpha0+
Win-x86@6 MASTER
pull time 2012-12-21 23:39:29
core:d6bbdaf02d614babebeebb2fcdc00035760c2f69

LibO-Dev_4.1.0.0.alpha0+
Win-x86@6 MASTER
pull time 2012-12-23 06:01:25
core:9c655c4c55e3be85a6cef0bd04f95e4d47e211f1


Still works well with:
LibO-Dev_4.1.0.0.alpha0+
Win-x86@6 MASTER
pull time 2012-12-20 07:28:46
core:ea47c12cc8ce6f8b05905d11f1a3fd3f634f585a
Comment 1 Jorendc 2012-12-26 10:42:51 UTC
Thanks for reporting.

Can't reproduce under Mac OSX 10.8.2

LibreOffice 4.1.0.0.alpha0+ (Build ID: de9475756effa8102cc4090db8d03393a02fdc6)
TinderBox: MacOSX-Intel@1-built_no-moz_on_10.6.8, Branch:master, Time: 2012-12-25_01:01:53

OR this is Windows only, or there is something wrong with your installation. You tried a user profile reset? https://wiki.documentfoundation.org/UserProfile#Resetting_the_user_profile
Comment 2 manj_k 2012-12-26 11:18:26 UTC
Thanks for testing on Mac.

It is always a new *default* user profile (without customization).
(see also the attachment 'user_profile.zip').
Comment 3 manj_k 2012-12-26 11:19:40 UTC
Created attachment 72136 [details]
Sample: 'user_profile.zip'
Comment 4 Rainer Bielefeld Retired 2012-12-28 09:39:23 UTC
[Reproducible] with server  installation of  "4.1.0.0.alpha0+ (Build ID: e90807267808eb062b93d762c50c02113ca40db) TinderBox: Win-x86@6, Branch:master, Time: 2012-12-26_22:00:49 - ENGLISH UI / German Locale  on German WIN7 Home Premium (64bit) with own separate User Profile
Comment 5 Jorendc 2013-01-11 17:02:48 UTC
*** Bug 59252 has been marked as a duplicate of this bug. ***
Comment 6 Caolán McNamara 2013-01-17 14:04:58 UTC
*** Bug 58750 has been marked as a duplicate of this bug. ***
Comment 7 Caolán McNamara 2013-01-17 14:05:28 UTC
*** Bug 58751 has been marked as a duplicate of this bug. ***
Comment 8 Caolán McNamara 2013-01-17 14:05:58 UTC
*** Bug 58752 has been marked as a duplicate of this bug. ***
Comment 9 Caolán McNamara 2013-01-17 14:07:28 UTC
*** Bug 58760 has been marked as a duplicate of this bug. ***
Comment 10 Caolán McNamara 2013-01-17 14:11:13 UTC
These are probably all the same underlying problem, and probably something I did. Pity its windows only, that'll slow me down finding and fixing it a bit
Comment 11 manj_k 2013-01-17 20:17:25 UTC
The bug occured for the first time

after
Master
pull time 2012-12-20 07:28:46
core:ea47c12cc8ce6f8b05905d11f1a3fd3f634f585a
(still OK)

with
Master
pull time 2012-12-21 12:45:13
core:9c6006b961f690728f4035c10f8b9fe9fdb6f332.
Comment 12 Caolán McNamara 2013-01-21 09:45:39 UTC
All these dialogs share the same "columns" page and there's a little typo in the preview widget name.
Comment 13 Not Assigned 2013-01-21 09:48:29 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8cb7d461fb1466477a18500bf25d42fad14e83ca

Resolves: fdo#58749 wrong custom widget libname in columns page



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Jesper Laugesen 2013-05-26 17:04:18 UTC
Same problem in just downloaded:

Version: 4.1.0.0.beta1
Build ID: 5271b34bec742e190e2fe5a7dadb7334a705b54

Platform: Windows 8

Tested on several documents
Comment 15 Caolán McNamara 2013-05-27 10:05:37 UTC
please don't reopen fixed bugs that have similar effects to a new problem. That risks the bug getting assigned to someone that hasn't a clue what the new problem is.

I suspect that this one is fixed by http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-4-1&id=d601bab683779c2db47c13a965405cc1be7f9147