Bug 57230 - LibreOffice does not print all pages
Summary: LibreOffice does not print all pages
Status: RESOLVED DUPLICATE of bug 35771
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: x86-64 (AMD64) macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-17 17:25 UTC by Bernd Kloss
Modified: 2013-05-06 12:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screen-shots of the printer-dialogue (417.76 KB, application/vnd.oasis.opendocument.text)
2012-11-17 17:25 UTC, Bernd Kloss
Details
Print bug, simple doc without anything (11.38 KB, application/vnd.oasis.opendocument.text)
2013-05-06 10:16 UTC, Bernd Kloss
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bernd Kloss 2012-11-17 17:25:17 UTC
Created attachment 70193 [details]
screen-shots of the printer-dialogue

Mac-Book Pro 
OS X 10.8.2
Kyocera FS C5150
LO Version 3.6.3.2 (Build ID: 58f22d5)

Trying to print all n pages of a Writer-document only n-1 pages will be printed
You have to add an extra page to get n pages printed

Trying to print last page is not possible. Adding extra page is oligatory.

Attachment:
screen-shots of the printer-dialogue protokoll-testdruck.odt
Comment 1 Roman Eisele 2012-11-18 15:46:15 UTC
@ Bernd Kloss:

Thank you for your bug report!


@ Alex Thurgood:

As you are our QA expert for printing problems on Mac OS X, could you please take a look at this new bug report and try to reproduce it? (I still can’t print from my machine, therefore I can’t help here :-(

Thank you very much!
Comment 2 Bernd Kloss 2013-05-05 07:28:59 UTC
Meanwhile I am working with 4.0.3.1, but the problem is still existing.
If you are printing parts of a document in writer with more than one page, you get errors like
'no page selected'
For example:
document with 5 pages and you try to print all then only page 1 is being printed and a second dialogue opens that alows you to print pages 1 - 4
There has to be an extra page added to print pages 1-5

The last page of a n-page document is not prinable. n+1 has to be added to get page n

This problem does not occur using MS Office 2011

Regards
Bernd
Comment 3 Alex Thurgood 2013-05-06 08:59:21 UTC
Confirming. Very awkward indeed.


How to reproduce :
1) Open test document.
2) Press the Command+P keys
3) In the print dialog, select a page range choosing from 5 to 5 (i.e. from page 5 to page 5)
4) Error message is displayed "No document selected"
5) The preview display then changes in the print preview of the print dialog and removes the last page. It is now impossible to select page 5 of the document.


Alex
Comment 4 Alex Thurgood 2013-05-06 09:00:38 UTC
(In reply to comment #3)
> Confirming. Very awkward indeed.

I reproduced the buggy behaviour with LO 4.0.2.2.


Alex
Comment 5 Alex Thurgood 2013-05-06 09:14:26 UTC
Testing with another document that had no embedded images shows that the problem lies in the document itself or the way it is being parsed or fed to the printer subsystem.

The problem is document specific, the question now is to find out what exactly triggers the problem.

I tried removing the manual page breaks - no difference.
I tried deleting some  of the images, starting from the end of the document - no difference.


@Bernd : we need a minimal document that reproduces the problem - there are currently too many possibilities to be able to single out where the problem is coming from in the document you have posted.

Alex
Comment 6 Alex Thurgood 2013-05-06 09:23:11 UTC
Removing header and footer made no difference.

Perhaps it is the way the image are anchored (to paragraph) ?


Alex
Comment 7 Alex Thurgood 2013-05-06 09:32:08 UTC
Hmm, seems to be linked to image management within the document. Changing anchors makes no difference either.

Alex
Comment 8 Bernd Kloss 2013-05-06 10:16:47 UTC
Created attachment 78914 [details]
Print bug, simple doc without anything

requested sample-document

Regards
Bernd
Comment 9 Alex Thurgood 2013-05-06 12:08:58 UTC
Thanks Bernd,

I have found a workaround, and what might be the cause of the problem.

Reset the margins to say, 1cm top and bottom, and the I can print out page 4 on its own just fine (in fact any page I choose). You can then reset the margins again to the value you want and the printing will continue to work.

This would indicate that the problem lies in the initial margin settings.


Alex
Comment 10 Alex Thurgood 2013-05-06 12:17:50 UTC
Setting this as duplicate of 35771, which in turn seems to be linked to bug 36799

*** This bug has been marked as a duplicate of bug 35771 ***