Bug 36799 - If you insert an envelope into a document only the envelope is printed (Mac OS X)
Summary: If you insert an envelope into a document only the envelope is printed (Mac O...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: MacOS-Wishlist Envelope
  Show dependency treegraph
 
Reported: 2011-05-03 05:56 UTC by Fred
Modified: 2019-05-22 02:53 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fred 2011-05-03 05:56:03 UTC
Hello,

If I choose Insert > Envelope > Insert, the envelope is added as the first page in the document.

When I print, only the envelope is printed, even though I have selected "all pages" or page "1-2" in the print dialogue.

Fred
Comment 1 vitriol 2011-05-03 06:29:27 UTC
Not reproducible for me with LibO 3.4 Beta 3
Comment 2 Fred 2011-05-03 07:48:06 UTC
I tested with LibO 3.4 beta 3 and it was the same: Only the envelope is printed.
Comment 3 vitriol 2011-05-03 07:52:25 UTC
Which OS do you use? I tested under Win7 64 bit.
Comment 4 Fred 2011-05-03 08:04:50 UTC
(In reply to comment #3)
> Which OS do you use? I tested under Win7 64 bit.

I use OS X 10.6.7
Comment 5 vitriol 2011-05-03 08:09:14 UTC
Maybe a platform dependent bug.
Comment 6 Alex Thurgood 2011-05-03 08:31:51 UTC
Hi all,

I can reproduce this behaviour, but I can also work around it.

If you insert an envelope, say A4 size into an existing document, it creates a page break which resets the page size of the following pages. This caused printing of the subsequent pages to fail on my system, Mac OSX 10.6.7.

LibO does not inform you of the page problem unless you activate the option in the preferences to require that the page of your document conform to the page default of your printer (although I haven't actually tried this to see if it works as designed). Thus the print operation fails silently. The only reason I could see it is because my HP Laserjet shows an orange error light when there is a page mismatch.

If you reset the page size of the pages following your envelope insert to A4, or rather, to your printer default page size, then all of the pages will print out, at least that is how I managed to do it.


However, I consider it a bug that inserting an envelope resets the page size for the subsequent pages. That should not happen IMHO, but it is not the only bug related to the use of envelopes in LibO at the moment.

Alex
Comment 7 Alex Thurgood 2011-05-03 08:45:40 UTC
Hmmm, more info :

My assumptions weren't quite right. I just tried to print a 3 page document.

First page : inserted envelope B4 size
Second page : test text plus manually inserted page break
Third page : more test text

Results :

The first page prints out twice, the second page once, and the third page not all.
No error messages anywhere. I had configured the default page size to be A4 before inserting the envelope.

Even though I chose B4 size envelope, if I click on the page where the envelope was inserted, it says that my page size is Custom...which appears to be incorrect since it should logically be B4.


So there is obviously a problem, but what the root cause of that problem is still remains unclear.

Alex
Comment 8 Fred 2011-05-03 11:21:56 UTC
I don't know if it's platform dependant.

I tested with Ubuntu Live CD 11.04, which ships with LibreOffice 3.3.2, and found a new behaviour. When I tested, page one was the envelope and page two was text. When I printed and selected "all", the envelope was printed all right but the next page was blank.
Comment 9 Muthu 2011-05-05 01:53:31 UTC
One for cedric?
Comment 10 Alex Thurgood 2011-05-06 05:26:02 UTC
Linking to 35711 because the same problem occurs there, albeit with multi-page documents, but the end result with regard to the user is the same, i.e. the user can only print the first page, or else 2 successive print operations are launched, and the first page is printed twice. In addition, it appears that the page count is incorrect.

Alex
Comment 11 Björn Michaelsen 2011-12-23 13:24:48 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 12 A (Andy) 2013-05-05 20:34:47 UTC
That reported specific issue is for me not reproducible with LO 4.0.2.2 (Win7 Home, 64bit).

Steps Done:
1. Open a new document in WRITER
2. Write "Test Page 2" in the first line
3. Insert a page break after the typed text (go to the menu INSERT -> MANUAL BREAK -> select PAGE BREAK and press OK)
4. Write "Test Page 3" in the first line of this new second page
5. Place the cursor before the word "Test" on page 1
6. Go to the menu INSERT -> ENVELOPE and go to the tab FORMAT
7. In the section SIZE select as format "B4 (ISO)" and press INSERT
8. Go to the menu FILE -> PRINT and select the printer and assure that "All pages" is selected

Result: The envelope is inserted correctly and all three pages are printed.  No page is missing and no page is printed twice or anything else like that.
But I experienced a strange other issue.  Page 1 (the envelope) and page 2 are ok.  But if I check page 3 then the text "Test Page 3" does not appear in the first line but several lines below on this page.

@Mac OS users: Did this issue still persist for you with the latest release of LO?
Can anybody confirm my experienced issue with the latest release of LO?
Comment 13 Alex Thurgood 2013-05-06 12:28:56 UTC
Still not resolved on OSX LO 4.0.2.2.

This is now getting to be a very old bug.


Alex
Comment 14 Alex Thurgood 2013-05-06 12:31:21 UTC
Notice that the print dialog gets called twice, the first time the user is led to think that the whole document has been sent to the printer, and while that process is occurring, the print dialog is displayed a second time, but with one page less than the actual total number of pages.

Alex
Comment 15 Jorendc 2013-05-06 12:59:31 UTC
@Alex: Due the fact this is a bug < version 3.6 we have to place it on the mab3.6 list.
Comment 16 Jorendc 2013-05-06 13:19:35 UTC
Lets reset Assignee due no activity in about 2 year, and we work now with a 'pull' principle for developers (not assign them right away :-) ).

Kind regards,
Joren
Comment 17 tommy27 2013-08-08 10:46:29 UTC
hi. do you still reproduce the bug with recent 4.0.4 and 4.1.0 final release?

moreover it would be useful to attach a sample document which reproduces the bug.
Comment 18 tommy27 2013-09-04 20:50:45 UTC
(In reply to comment #13)
> Still not resolved on OSX LO 4.0.2.2.
>This is now getting to be a very old bug.
> 
> Alex

according to this comment I move this Mac specific bug to the 4.0 MAB list.
still waiting for confirmation in later 4.0.x and 4.1.x releases
Comment 19 Alex Thurgood 2013-09-06 06:28:31 UTC
(In reply to comment #18)
> (In reply to comment #13)
> > Still not resolved on OSX LO 4.0.2.2.
> >This is now getting to be a very old bug.
> > 
> > Alex
> 
> according to this comment I move this Mac specific bug to the 4.0 MAB list.
> still waiting for confirmation in later 4.0.x and 4.1.x releases

Tommy, 

You have confirmation for 4.0.x in comment 13. If, as I suspect, this issue has the same root cause as bug 35771, then it is still present in 4.1.1.2

Alex
Comment 20 Alex Thurgood 2013-09-06 06:32:51 UTC
Adding Cedric, Caolan, Tor to CC.

Guys, it seems that this bug, and those linked to it, has never really had your attention drawn to it, but it is (1) problematic for office usage on the Mac, (2) quite old now.

Anyone care to take a look ?

Alex
Comment 21 Björn Michaelsen 2014-01-17 09:58:37 UTC Comment hidden (obsolete)
Comment 22 stragu 2014-02-14 14:53:26 UTC
Could someone please test this with 4.1 or 4.2? I would like to know if we have to move it to mab4.1. Cheers.
Comment 23 Alex Thurgood 2014-02-28 10:42:22 UTC
Tested on 4.2.0.4 OSX 10.9

Not only is the problem still there, it has got worse...

Whereas previously only the first page would print out, i.e. the envelope page, when I now try to print via either a Samsung CLX 375 FN or Kyocera CS5150DN (both are networked laser printers), I systematically get a jam of the first page within the printer resulting in hours of endless fun trying to retrieve the sheet/envelope/support on which the address has been printed. Of the second page, on which I had typed the word "test" and pressed the return key, there is no sign. The second page does not even display in the Print as PDF Preview provided by the underlying OS.

Alex
Comment 24 tommy27 2014-02-28 10:46:50 UTC
thanks Alex. moving to the mab4.1 list.
Comment 25 Robinson Tryon (qubit) 2014-02-28 16:40:35 UTC
CC'ing Thorsten (listed as the Mac expert).
Comment 26 tommy27 2014-05-03 13:52:11 UTC
moving this old bug to mab4.2 list since 4.1.x is END OF LIFE
Comment 27 Alex Thurgood 2014-10-06 16:24:27 UTC
*** Bug 75803 has been marked as a duplicate of this bug. ***
Comment 28 tommy27 2014-10-06 16:54:57 UTC
for the record, bug has been reproduced also with LibO 4.3.0.4
see: https://bugs.freedesktop.org/show_bug.cgi?id=75803#c5
Comment 29 tommy27 2014-11-21 06:32:26 UTC
please Mac users, retest with 4.3.4.1 or 4.4.0.0 beta1
if bug is still present please move this from mab4.2 list to mab4.3 list since 4.2.x reached the end of life
Comment 30 Alex Thurgood 2014-12-08 13:51:09 UTC
LO 4341 OSX 10.10.1

Envelope page gets printed, then printer attempts to print the envelope page again and jams - bug still present
Comment 31 tommy27 2015-06-24 15:17:46 UTC
just an head up about 4.4.x 
is the bug still here?
Comment 32 Alex Thurgood 2015-06-25 08:22:07 UTC
(In reply to tommy27 from comment #31)
> just an head up about 4.4.x 
> is the bug still here?

Yes.

Samsung CLX3170FN printer systematically jams halfway through printing of envelope page. The reason for the jam appears to be that the printer receives an incorrect page size instruction from LO via CUPS for the subsequent page.

Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Locale : fr_

It is desperate that this bug still hasn't been fixed. Even testing for this bug is PITA. A single print job attempt, which fails, as described above, is kept in the memory of the printer, meaning the print job attempts to repeat itself endlessly until the printe is switched off and back on again. The cancel button is useless in that regard. Granted, this could be a design error in the printer, where the Cancel button should always be allowed to interrupt the print process, but having to pull out three jams before switching off the machine is :
- time consuming;
- very irritating;
- a huge waste of paper.

This doesn't motivate any tester to keep retesting this bug just to see whether, on the off-chance, it might have been fixed.
Comment 33 Bookman900 2016-01-08 18:23:52 UTC
Hi all. 

It still represents even in LO 5.0.4.0

I think that the best way to cope with this "bug" Is just to print an envelope as a separate print-task.
Comment 34 Alex Thurgood 2016-01-11 11:34:50 UTC
Why does this bug status say assigned ? Who has taken it to try and fix it ?
Comment 35 Alex Thurgood 2016-01-11 11:36:00 UTC
@Bookman900 : apparently you have assigned yourself this bug ? Are you attempting to fix it ? If not, then please unassign yourself and set back to NEW.
Comment 36 QA Administrators 2019-05-22 02:53:38 UTC
Dear Fred,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug