Download it now!
Bug 70501 - JPG is displaced or lost when .docx file is saved and reopened
Summary: JPG is displaced or lost when .docx file is saved and reopened
Status: RESOLVED DUPLICATE of bug 52226
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-15 16:32 UTC by hunter.croil
Modified: 2013-12-31 11:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Dropped JPG (26.98 KB, image/jpeg)
2013-10-15 16:32 UTC, hunter.croil
Details
Moved JPG (28.92 KB, image/jpeg)
2013-10-15 16:35 UTC, hunter.croil
Details
Example (10.85 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-10-22 14:39 UTC, hunter.croil
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hunter.croil 2013-10-15 16:32:37 UTC
Created attachment 87675 [details]
Dropped JPG

Exactly as described in Bug ID 61342, duplicating the same process of opening and closing the file.

I added a screenshot showing where the jpg (a masthead logo in this case) is missing entirely (see dropped pic.jpg). In other cases when reopening the file the jpg has been moved to another place on the page (see moved pic.jpg).

(I can only add one attachment at a time so I'll send the second one as a follow up to this post. Seems it could be helpful to be able to add multiple attachments to a single report.)
Comment 1 hunter.croil 2013-10-15 16:35:05 UTC
Created attachment 87676 [details]
Moved JPG

This is the second attachment.
Comment 2 tommy27 2013-10-19 08:05:40 UTC
please attach the .odt file you show in screenshots.
Comment 3 hunter.croil 2013-10-22 14:39:06 UTC
Created attachment 87987 [details]
Example
Comment 4 tommy27 2013-11-04 21:32:24 UTC
example .odt has missing picture in the upper left corner in any LibO releases I've tried from 3.3.3 to 4.1.2. same issue with AOO 4.0.0
Comment 5 retired 2013-11-23 19:42:46 UTC
Is this bug still valid / reproducible with the latest LO release?  Currently 4.1.3.2: http://www.libreoffice.org/download/

Not sure how to reproduce if the file is already damaged. What we'd need is a working file. But in this case the example file opens with missing image in both Word and LO.

So basically I'd say NOTABUG.

Should this be still reproducible for you with the latest LO release please re-open this bug and we’ll go from there. In that case please include a working docx file that does open correctly in some software.

Setting to NEEDINFO until more detail is provided.

After providing the requested info, please reset this bug to UNCONFIRMED. Thanks :)
Comment 6 hunter.croil 2013-11-23 20:15:32 UTC
How do you suggest I add a working docx file?? I create the file in LO and when I save and close it the jpg disappears. I don't use other word processors, but maybe I should. Is that what you mean?
Comment 7 Nikhil Walvekar 2013-12-31 05:08:58 UTC
Can you please add original file? I guess the attached file is the file which was saved using LO.
Comment 8 tommy27 2013-12-31 10:29:24 UTC
@hunter
try this: create an .odt file with that .jpg then save it.
the open it again and save it as .docx and tell us what happens...
Comment 9 tommy27 2013-12-31 10:32:06 UTC
@Nikhil Walvekar
according comment 6 he created that .docx from scratch using LibO.
so basically the one he attached it's the original file.
Comment 10 tommy27 2013-12-31 11:59:21 UTC
according to comment 6 it seems this is an issue about .docx saving
so I think this is a dubplicate of Bug 52226

I modified summary notes.
please revert changes if you thinks it's a different issue.

*** This bug has been marked as a duplicate of bug 52226 ***