Bug 57259 - UI: Master pages styles change view to "Default" instead of being applied
Summary: UI: Master pages styles change view to "Default" instead of being applied
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: (target:4.0.0.0.beta1)
Keywords: regression
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2012-11-18 19:58 UTC by luksiw
Modified: 2012-12-07 22:16 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing the bug (172.47 KB, image/jpeg)
2012-11-18 19:58 UTC, luksiw
Details

Note You need to log in before you can comment on or make changes to this bug.
Description luksiw 2012-11-18 19:58:58 UTC
Created attachment 70235 [details]
Screenshot showing the bug

Steps to reproduce:
1. Open Impress
2. Select master pages
3. Click on a style

Expected behavior: slide style is changed to selected style
Observed behavior: style turns to blank/all white after clicking.

Note that DNA and Inspiration styles aren't affected.

Attached screenshot of the bug.
Comment 1 Rainer Bielefeld Retired 2012-11-19 05:58:13 UTC
[Reproducible] with parallel installation of Master "LOdev  4.0.0.0.alpha0+   -  ENGLISH UI / German Locale  [Build ID: a2b3ee)]"  {tinderbox: @6, pull time 2012-11-13 06:07:28} on German WIN7 Home Premium (64bit) with separate /4 User Profile for Master Branch: All Styles clicked in 'Tasks-Pane -> Available for use' change view in Tasks pane to "Default", but will not be applied for current slide.

Wrong view in 'Tasks-Pane -> Available for use' will remain until LibO will have been closed and relaunched
Comment 2 Rainer Bielefeld Retired 2012-11-19 06:01:17 UTC
Comment on attachment 70235 [details]
Screenshot showing the bug

Was still ok with Server-installation of Master "3.7.0.alpha0+  – ENGLISH UI [Build ID: f2e622]" {tinderbox: Win-x86@16, pull time 2012-10-06 09:31:39} on German WIN7 Home Premium (64bit) UserInstallation=$SYSUSERCONFIG/LOdev/3
Comment 3 Rainer Bielefeld Retired 2012-11-19 06:05:27 UTC
@Thorsten:
what do you think concerning ProposedEasyHack
Comment 4 Thorsten Behrens (CIB) 2012-11-19 14:21:39 UTC
(In reply to comment #3)
> @Thorsten:
> what do you think concerning ProposedEasyHack
>
I'd first try to bibisect it.
Comment 5 Rainer Bielefeld Retired 2012-11-19 15:03:59 UTC
@tbehrens / Björn:
do we have Bibisect data for that version range? <http://wiki.documentfoundation.org/Bibisect> does not mention 4.0 Master, may be that page needs some update (WIN bibisecting also is not mentioned)
Comment 6 Petr Mladek 2012-11-23 17:11:34 UTC
Do you see the problem also with DNA.otp and Inspiration.otp from the default set?

It might be related to svg import. It seems that it is broken in master. Most of the presentation templates are using svg pictures. See also the the bug 56402.
Comment 7 Rob Snelders 2012-12-07 19:43:48 UTC
I can't reproduce the problem anymore with 4.1.0.0-master. Can you recheck with a recent master?
Comment 8 Rainer Bielefeld Retired 2012-12-07 22:16:07 UTC
There still are some preview problems (for what I will submit a different bug), but indeed, thhe reported problem seems to be solved for parallel installation of  "LOdev  4.0.0.0.alpha1+   -  ENGLISH UI / German Locale  [Build ID:d6579884752c298a18b7cdfcc7d1614b55c9c7c)]"  {tinderbox: Win-x86@6, pull time 2012-12-06 02:46:58} on German WIN7 Home Premium (64bit) with own separate User Profile 

@luksiw
I hope you can confirm this progress?