Bug Hunting Session
Bug 56402 - No "LibreOffice" logo image anymore in about box of current master builds
Summary: No "LibreOffice" logo image anymore in about box of current master builds
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Muthu
URL:
Whiteboard: target:4.1.0 target:4.0.0.0.beta0
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-10-25 16:27 UTC by Roman Eisele
Modified: 2012-12-19 13:24 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
About box of daily build with pull time 2012-10-12 22.05.41 (102.17 KB, image/png)
2012-10-25 16:30 UTC, Roman Eisele
Details
About box of daily build with pull time 2012-10-25 06.12.34 (50.11 KB, image/png)
2012-10-25 16:31 UTC, Roman Eisele
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Eisele 2012-10-25 16:27:20 UTC
At least on Mac OS X, in the latest master builds from
http://dev-builds.libreoffice.org/daily/MacOSX-Intel@27-OSX_10.7.0-gcc_4.2.1_llvm/master/
the about box does not show anymore the “LibreOffice” logo image (document symbol and text, both white, on green background). Instead, there is only the plain text “LOdev” in black.

This is a regression:
while the master build from that directory with pull time 2012-10-12 22.05.41 still includes the logo image in the about box,
the build with pull time 2012-10-19 23.57.57 just says “LOdev” at the same place, and that is still true in the newest build with pull time 2012-10-25_06.12.34.

This is not an important bug for the user, but it makes the about box look worse.
And maybe this is just the symptom of some more serious building problem?
I don’t know.

Probably related to bug 56400 - “No useful build ID in about box of current master builds”, which has appeared at the same time.
Comment 1 Roman Eisele 2012-10-25 16:30:49 UTC
Created attachment 69079 [details]
About box of daily build with pull time 2012-10-12 22.05.41
Comment 2 Roman Eisele 2012-10-25 16:31:25 UTC
Created attachment 69080 [details]
About box of daily build with pull time 2012-10-25 06.12.34



A screenshot shows best what the problem is.
Comment 3 Roman Eisele 2012-10-25 16:37:29 UTC
@ Rainer Bielefeld / bfoman:
Could you please check: Is this also true on Windows and/or Linux,
or is this problem limited to master builds for Mac OS X?
Comment 4 Rainer Bielefeld Retired 2012-10-25 17:28:08 UTC
We already had something similar some time ago in "https://bugs.freedesktop.org/show_bug.cgi?id=52095", but that was ok after a while.

[Reproducible] with parallel installation of Master "LOdev  3.7.0.0.alpha0+   -  ENGLISH UI / German Locale  [Build ID: 370m0(Build:0)]"  {tinderbox: @6, pull time 2012-10-20 14:21:35} on German WIN7 Home Premium (64bit) with separate User Profile for Master Branch.

Related to "Bug 56247 - Help-About shows "370m0(Build:0)" instead of Unique Build Identifier"?
Comment 5 Roman Eisele 2012-10-30 17:40:34 UTC
Still reproducible with today’s master build for Mac OS X (Intel) --
LOdev 3.7.0.0.alpha0+ (Build ID: ce2690; pull time: 2012-10-30 00:06:37) --
which has fixed bug 56247 - “Help-About shows ‘370m0(Build:0)’ instead of Unique Build Identifier”; this means that the two bugs don’t have the same root.
Comment 6 Roman Eisele 2012-10-30 17:46:09 UTC
@ Petr Mladek:

Hi Petr, you have fixed/reported the fix for bug 56247 -- “Help-About shows ‘370m0(Build:0)’ instead of Unique Build Identifier”. Now *this* bug seems similar/related to bug 56247, and was introduced around the same time as the latter, so it may have similar roots ...

Can you please take a look at this bug and see, if it is possible to fix it?
(Or is this not a bug at all, but intended behaviour?)

Thank you very much!
Comment 7 Petr Mladek 2012-11-05 10:18:43 UTC
I am afraid that the two bugs are not related. The wrong buildid was related to moving the optional git repositories tp submodules, so we needed to update the git command. I can't imagine how it could affect the logo. Anything is possibly, though :-)

If time permits, I will look at it by the end of this week. Any volunteer is welcome.
Comment 8 Petr Mladek 2012-11-16 11:51:51 UTC
Heh, the SVGloading stuff is temporary disabled because of rebasing on top of AOOo code. There are few #ifdef FIXME_REMOVE_WHEN_RE_BASE_COMPLETE in the sources.

So, it will get fixed once the rebase is finished and all modules are back in consistent state. Michael says that it is going well.
Comment 9 Roman Eisele 2012-11-16 12:24:31 UTC
Ah, thank you! It is nice to know what the reason of this problem is,
and that it will go away soon (hopefully).
Comment 10 Muthu 2012-12-13 07:18:48 UTC
Picking this up.
Comment 12 Not Assigned 2012-12-13 07:22:33 UTC
Muthu Subramanian committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=634ee953f1d090871834f6bc53faafaa7b96b874

fdo#56402: SVG in About Dialog.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Roman Eisele 2012-12-13 08:05:24 UTC
@ Muthu:

Thank you very much for fixing this issue!

Could you please backport this fix to 4.0.0? (Else our shiny new version would ship without logo ... ;-)
Comment 14 Not Assigned 2012-12-13 08:35:20 UTC
Muthu Subramanian committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b739389dba055f300d2e738474f468a1c672dcfb&g=libreoffice-4-0

fdo#56402: SVG in About Dialog.


It will be available in LibreOffice 4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Roman Eisele 2012-12-19 13:24:31 UTC
VERIFIED as FIXED:

In the current master build for Mac OS X (LOdev 4.1.0.0.alpha0+, Build ID: 413d1a932eb4c47510dd05905c1ff467cb186d0, TinderBox: MacOSX-Intel@1-built_no-moz_on_10.6.8, Branch:master, Time: 2012-12-19_04:13:37), the logo image is present again. Tested on Mac OS X 10.6.8 (Intel).

Thank you again, Muthu, for fixing this issue!