Bug Hunting Session
Bug 56247 - Help-About shows "370m0(Build:0)" instead of Unique Build Identifier
Summary: Help-About shows "370m0(Build:0)" instead of Unique Build Identifier
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Lior Kaplan
URL: http://dev-builds.libreoffice.org/daily/
Whiteboard:
Keywords:
: 56400 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-10-21 09:21 UTC by Rainer Bielefeld Retired
Modified: 2012-11-02 12:49 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-10-21 09:21:31 UTC
With parallel installation of Master "LOdev  3.7.0.0.alpha0+   -  ENGLISH UI / German Locale  [Build ID: 370m0(Build:0)]"  {tinderbox: @6, pull time 2012-10-20 14:21:35} on German WIN7 Home Premium (64bit) with separate User Profile for Master Branch
and also
with parallel installation of Master "LOdev  3.7.0.0.alpha0+   -  ENGLISH UI / German Locale  [Build ID: 370m0(Build:0)]"  {tinderbox: @16, pull time 2012-10-19 07:45:39} on German WIN7 Home Premium (64bit) with separate User Profile for Master Branch

I see the same build identifier. 

@Petr:
Bug or new feature I missed?
Comment 1 Rainer Bielefeld Retired 2012-10-25 17:03:54 UTC
Confirmed by Attachment 69080 [details] of "Bug 56402 - No "LibreOffice" logo image anymore in about box of current master builds", I still don't know whether unique identifier has been dropped.
Comment 2 Rainer Bielefeld Retired 2012-10-25 20:16:06 UTC
*** Bug 56400 has been marked as a duplicate of this bug. ***
Comment 3 Petr Mladek 2012-10-29 14:04:55 UTC
This should get fixed by http://cgit.freedesktop.org/libreoffice/core/commit/?id=9a4f81c333f23462f4fa462d8fba539b0b10a9a8

The problem was caused by the switch to git submodules, see http://wiki.documentfoundation.org/Development/Submodules

Note that the single commit id from the core repo is enough to describe the master build now. All the 5 IDs are still needed in the 3.5 and 3.6 builds.

Many thanks to Lior for the fix.
Comment 4 Roman Eisele 2012-10-30 17:33:00 UTC
VERIFIED as FIXED with the newest Master build for Mac OS X (Intel):

The about box of today’s master build (pull time: 2012-10-30 00:06:37)
says again
   LOdev 3.7.0.0.alpha0+ (Build ID: ce2690)
so we have got back an unique build identifier.

Thank you very much for fixing this!
Comment 5 Rainer Bielefeld Retired 2012-11-02 12:49:18 UTC
Yes, ok with parallel installation of Master "LOdev  3.7.0.0.alpha0+   -  ENGLISH UI / German Locale  [Build ID: af8098)]"  {tinderbox: @16, pull time 2012-10-31 23:08:18}