Bug 56400 - No useful build ID in about box of current master builds
Summary: No useful build ID in about box of current master builds
Status: RESOLVED DUPLICATE of bug 56247
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-10-25 16:16 UTC by Roman Eisele
Modified: 2012-10-25 20:16 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Eisele 2012-10-25 16:16:20 UTC
At least on Mac OS X, the latest master builds from
http://dev-builds.libreoffice.org/daily/MacOSX-Intel@27-OSX_10.7.0-gcc_4.2.1_llvm/master/
don’t show a useful build ID anymore in the about box.

This is a regression: while the master build from that directory with pull time 2012-10-12 22.05.41 still says
   Version 3.7.0.0.alpha0+ (Build ID: c252694)
in the about box, the build with pull time 2012-10-19 23.57.57 just says
   Version 3.7.0.0.alpha0+ (Build ID: 370m0(Build:0))
, and that is still true in the newest build with pull time 2012-10-25_06.12.34.

This is not an important bug for the user, but it makes the whole build ID worthless, because the same pseudo-ID is used for all builds from the same branch.

And maybe this is the symptom of some more serious building problem? I don’t know.
Comment 1 Roman Eisele 2012-10-25 16:19:17 UTC
@ Alex Thurgood:
Can you please confirm this?

@ Rainer Bielefeld / bfoman:
Could you please check: Is this also true on Windows and/or Linux,
or is this problem limited to master builds for Mac OS X?
Comment 2 Roman Eisele 2012-10-25 16:35:53 UTC
Screenshots added, to avoid any uncertainty:
1) About box from older  daily build (2012-10-12 22.05.41) *with* build ID:
   see attachment 69079 [details]
2) About box from newest daily build (2012-10-25_06.12.34) without useful ID:
   see attachment 69080 [details]

These screenshots are shared with bug 56402 -- “No ‘LibreOffice’ logo image anymore in about box of current master builds” --, which may be related.
Comment 3 Rainer Bielefeld Retired 2012-10-25 20:16:06 UTC
Yes, we can ;-)

*** This bug has been marked as a duplicate of bug 56247 ***