Download it now!
Bug 57330 - Links to external data not preserved for XLS
Summary: Links to external data not preserved for XLS
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-20 16:40 UTC by manover
Modified: 2014-08-29 20:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description manover 2012-11-20 16:40:12 UTC
Problem description:
 
no way to link external data to .xls file in Calc and keep it updated.
Neither (1)linking .txt,.csv file format via the Insert -> Sheet from file -> Link,(2)nor with "Paste as link" with .xls external file format, (3) nor with .html external file format via "Link to external data" in Insert menu.
 

Case (1)

Steps to reproduce:


1.       Create a list of simple comma separated  numbers in a .txt, .csv file, for ex. E1.txt.

2.       Open a new spreadsheet in Calc, .xls format (for ex. NEW.xls), and try to link data from external source to this file using Insert -> Sheet from file -> Link from external sheet to the new sheet.

3.       Now save and close the files.

4.       Open the "new" sheet.

 

Expected behavior:

NEW.xls open and linked data are shown correctly.


Current behavior:

No data update in NEW.xls is done.


Case (2)

Steps to reproduce:

1.       Create a list of simple comma separated  numbers in a .xls file, for ex. E1.xls.

2.       Open a new spreadsheet in Calc, .xls format (for ex. NEW.xls), and try to link data from external source to this file using "Paste special" and "Link" from external sheet to the new sheet.

3.       Now save and close the files.

4.       Open the "new" sheet.

 

Expected behavior:

 NEW.xls open and linked data are shown correctly.

 
Current behavior:

At file opening an error message will pop up: "

---- reported error window ----


The following external file could not be loaded. Data linked from this

file did not get updated.


file:///home/xxx/E1.txt

 
----   end error window    ----

 
Looking into the linked cell it paste twice the file path: i.e. file:///home/xxx/home/xxx/E1.txt


Case (3)
Steps to reproduce:

1.       Create a .html file with a table of simple numbers. Called for or ex. E1.html.

2.       Open a new spreadsheet in Calc, .xls format (for ex. NEW.xls), and try to link data from external source to this file using "Insert" -> "Link to external data".

3.       Now save and close the files.

4.       Open the "new" sheet.

 

Expected behavior:

 NEW.xls open and linked data are shown correctly.

 
Current behavior:

 
At file opening all linked values are gone and replaced by "The link cannot be updated"

Looking into the reference link file path is pasted twice.

 

 


Platform (if different from the browser): 
              
Browser: Firefox 16.0.2
Ubuntu; Linux 12.04.1 LTS (kernel:  3.2.0-33-generic #52-Ubuntu SMP Thu Oct 18 16:19:45 UTC 2012 i686 i686 i386 GNU/Linux)
Calc 3.5.4.2 Numero di build: 350m1(Build:2)
Comment 1 Julien Nabet 2012-12-15 07:58:49 UTC
On pc Debian x86-64 with 3.6 sources updated 3 days ago, I gave a try to case 1 (since I don't know how case 2 may work).

With xls format, after having linked the source, closed the file and opened, the data are present.
However, if I change txt file and open xls file again, it doesn't propose to update and keeps the old data.

On the contrary, with ods format, when I reopen the file, a popup displays to propose to update the data. If you accept, it works.

I've got the same behaviour with master sources updated yesterday.

Muthu: one for you? (perhaps it lacks something during export in xls to indicate that the sheet source must be linked, so xls file must be updated)
Comment 2 Goran Rakic 2013-06-13 02:29:06 UTC
Case (2) is a dupliacte of Bug 48463
Comment 3 Owen Genat (retired) 2013-07-04 10:14:53 UTC
I think my comment here is relevant to this bug: https://bugs.freedesktop.org/show_bug.cgi?id=54533#c2

Cases (1) and (3) in particular would seem to be a duplicate of bug #54533, which in turn is currently suffering from problems (for testing purposes) specified in bug #63407. I will leave it to the QA team to work out which is a duplicate of which and to what extent.
Comment 4 Owen Genat (retired) 2013-12-13 12:28:17 UTC
Julien I think this can be resolved as a duplicate of one of the bugs I list. The main problem with this report is it contains multiple issues and is not as clear as the other bugs. As Eike Rathke has reported in: 

https://bugs.freedesktop.org/show_bug.cgi?id=54533#c5

> Insert -> Link to external data is not meant to work with CSV files or files of 
> types other than spreadsheet or HTML files.

In this sense case (1) is invalid or at least a duplicate of enhancement bug 35040. In terms of case (2) this is not clear:

> Create a list of simple comma separated numbers in a .xls file, for ex. E1.xls.

If the file is in XLS format it is not "comma separated" and vice versa. It may be a reference (as indicated in comment #2) to LO not exporting the link correctly to the XLS format, in which case it is a duplicate of bug 48463.

In terms of case (3) the data can be inserted / linked OK and initially re-opening the XLS the data is displayed as expected, but answering "Yes" to the "This file contains links to other files. Should they be updated?" query results in the message "The link could not be updated." I tested this using this basic example:

http://www.w3schools.com/html/tryit.asp?filename=tryhtml_tables

... under Ubuntu 10.04 x86_64 running:

- v3.3.0.4 OOO330m19 Build: 6
- v4.1.3.2 Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a

As I previously suggested, this would appear to be bug 63407.
Comment 5 Owen Genat (retired) 2013-12-13 21:21:20 UTC
Summary edited for clarity.
Comment 6 Alex 2014-03-11 23:27:50 UTC
I am having a similar/related issue that I have documented here: https://bugs.freedesktop.org/show_bug.cgi?id=76047
Comment 7 Owen Genat (retired) 2014-08-23 08:26:53 UTC
(In reply to comment #4)
> http://www.w3schools.com/html/tryit.asp?filename=tryhtml_tables

The above example was bad as it does not include any tabular elements. Apologies. Under GNU/Linux using:

- v4.1.6.2 Build ID: 40ff705089295be5be0aae9b15123f687c05b0a
- v4.2.6.2 Build ID: 185f2ce4dcc34af9bd97dec29e6d42c39557298f
- v4.4.0.0.alpha0+ Build ID: e379401618268ed7f7f5885a36b90e1f4f6cd4af TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-08-18_05:51:03

A link to a working example, such as one of these:

http://portfolios.morningstar.com/fund/summary?t=VTI
http://coinmarketcap.com/currencies/views/all/

... works as expected for XLS file format. v4.3.0.4 Build ID: 62ad5818884a2fc2e5780dd45466868d41009ec0 currently has problems with link insertion (refer bug 49043).

I think this report can be RESOLVED as WORKSFORME (unless a related fix can be located). Summary amended for clarity.
Comment 8 Julien Nabet 2014-08-29 20:26:17 UTC
Following Owen's comments and no additional feedback from reporter, let's put this to WFM.

Don't hesitate to reopen this tracker if you still reproduce this.