Download it now!
Bug 57345 - FILEOPEN: cell borders width of double line is no longer clear as with old version
Summary: FILEOPEN: cell borders width of double line is no longer clear as with old ve...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: x86 (IA32) All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
: 65164 (view as bug list)
Depends on:
Blocks: Cell-Border
  Show dependency treegraph
 
Reported: 2012-11-20 21:55 UTC by S.Andreason
Modified: 2016-12-27 16:46 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
various border styles (17.53 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-11-20 21:55 UTC, S.Andreason
Details
screenshot #1 of 3.4.5 showing various border styles (75.89 KB, image/png)
2012-11-20 21:57 UTC, S.Andreason
Details
screenshot #2 of 3.6.3 showing various border styles (88.05 KB, image/png)
2012-11-20 21:58 UTC, S.Andreason
Details
screenshot #3 of 3.6.3 showing various border styles including new 0.05pt (91.88 KB, image/png)
2012-11-20 22:00 UTC, S.Andreason
Details
screenshot #4 of 3.4.5 loading the modified ods showing various border styles (77.37 KB, image/png)
2012-11-20 22:01 UTC, S.Andreason
Details
pdf of how it looks in Ubuntu x64 with LibreOffice 5.3beta2 (38.80 KB, application/pdf)
2016-12-27 16:46 UTC, Justin L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description S.Andreason 2012-11-20 21:55:06 UTC
Created attachment 70332 [details]
various border styles

I have an older sheet with double-line borders to mark special cells. Now they look like one thick line at 100% zoom. This is shown in the 4 png below, in cell A1. If I zoom in to max, then the double line is still visible, but only for cells in .ods file created in older versions.

If I load 3.6.3, new spreadsheet, add border, 0.05pt double line (2nd from the bottom in the new listbox lineup) at 100% zoom this line is 4 pixels tall, a solid line. 
If I zoom in to max, it is still a solid line. 

The double-line border (1 pixel solid-1 pixel transparent-1 pixel solid) has effectively been lost. I can not find a setting to get it back.


I am attaching an ods made in 3.4.5, showing all border types available in that version. The first png shows that result. 
Then I loaded that ods in 3.6.3, png#2
and added the new 0.05 pt examples, png#3
and then last loaded the modified ods back in 3.4.5. png#4

Some cells have lost the border completely. I'll file a new bug report for that separate issue.
Comment 1 S.Andreason 2012-11-20 21:57:31 UTC
Created attachment 70333 [details]
screenshot #1 of 3.4.5 showing various border styles
Comment 2 S.Andreason 2012-11-20 21:58:48 UTC
Created attachment 70335 [details]
screenshot #2 of 3.6.3 showing various border styles
Comment 3 S.Andreason 2012-11-20 22:00:17 UTC
Created attachment 70336 [details]
screenshot #3 of 3.6.3 showing various border styles including new 0.05pt
Comment 4 S.Andreason 2012-11-20 22:01:56 UTC
Created attachment 70337 [details]
screenshot #4 of 3.4.5 loading the modified ods showing various border styles
Comment 5 S.Andreason 2012-11-20 22:04:51 UTC
Comment on attachment 70337 [details]
screenshot #4 of 3.4.5 loading the modified ods showing various border styles

4 cells created in 3.6.3 with smaller point size, do not show at all in 3.4.5
Additionally 10 more cells were modified by 3.6.3 without user intervention, and are no longer showing as created.
Comment 6 m.a.riosv 2012-11-27 00:47:46 UTC
Have you tried disabling anti-aliasing?
Menu/Tools/Options/LibreOffice/View/Use Anti-Aliasing.
Comment 7 S.Andreason 2012-11-27 15:15:22 UTC
Yes I have tried that, but anti-aliasing was turned on for graphics in 3.4.5, looked good, and did not do this blurring of Straight and Crisp lines. It used to blur only the angles, which is as it should be.

Now it is blurring the straight lines that should be 1 pixel wide, into a 3 pixel wide mess. This is not the expected behavior of anti-alias.

Turning off anti-alias in 3.6 does remove the blurring, but also leaves the angled lines jagged.
Comment 8 m.a.riosv 2012-11-27 16:21:19 UTC
I think this was discussed last week at the minutes ESC.
http://nabble.documentfoundation.org/Libreoffice-qa-minutes-of-ESC-call-tc4020292.html
Comment 9 Joel Madero 2013-05-29 18:46:08 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version: 4.2.0.0.alpha0+Build ID: b0a1666f756aa5f5315366eca9d7d02ddd55d2b
Date:   Tue May 28 08:51:01 2013 +0300 
Platform: Bodhi Linux 2.2 x64

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
As I've been able to confirm this problem I am marking as:

New (confirmed)
Normal - can prevent high quality work
High - borders are quite popular and expected to be consistent. The older style IMO looked cleaner

Whiteboard Status - bibisectrequest - might be possible in this case

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage and join us on freenode at #libreoffice-qa

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 10 ign_christian 2013-07-13 03:08:01 UTC
*** Bug 65164 has been marked as a duplicate of this bug. ***
Comment 11 Joel Madero 2013-10-18 22:06:55 UTC
322dea02e8867272a756e7430e689699d2216aad is the first bad commit
commit 322dea02e8867272a756e7430e689699d2216aad
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Sun Dec 9 11:37:59 2012 +0000

    source-hash-18e6e7d929c2be209407ed2e56b8ec4d5e6c4900
    
    commit 18e6e7d929c2be209407ed2e56b8ec4d5e6c4900
    Author:     Julien Nabet <serval2412@yahoo.fr>
    AuthorDate: Mon May 14 18:59:35 2012 +0200
    Commit:     Julien Nabet <serval2412@yahoo.fr>
    CommitDate: Mon May 14 19:01:02 2012 +0200
    
        WaE : XKeycodeToKeysym deprecated
    
        Replaced by XkbKeycodeToKeysym
        (cf http://nabble.documentfoundation.org/PATCH-Proposed-patch-for-XKeycodeToKeysym-deprecated-td3978158.html)
    
        Change-Id: Ide8331705369d0c38e72bfe693102625e62a87e1

:100644 100644 13e11be9938c5079b96e4eb4cd2b4acf2f9a3b05 5aa1dfc68ecb9ac57316a995424b2d3683cb4774 M	autogen.log
:100644 100644 20a85200f0d859066fecafde8cdef513d59724ec 72da0ea5e9ec1223cb456558a2e0254561faa98c M	ccache.log
:100644 100644 00d946c601c37d4463365a27a04dac440b0e86a4 5ef3324ce1c257155c9e095fdeb7d912b2681ae1 M	commitmsg
:100644 100644 ff02681e8cefd9f0b1a9b8f19c25a3e77944e88a 8b14489bddefe04fcfaecb0be901837505c64b67 M	dev-install.log
:100644 100644 151ff28cf8b64f65d7b206588dd3c4e18553adce 68ac6a90c73f1f7c8776a70772a40ae1ce41e13d M	make.log
:040000 040000 6bde6ac28b39c6b41b55491b1a6a9900d26e65c1 8b906c6863615fd1253b393b35b18a883201b310 M	opt


# bad: [5b4b36d87517a6ea96ff8c84c46b12f462fc9a1a] source-hash-8450a99c744e9005f19173e4df35d65640bcf5c4
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# bad: [16b0b88cbd4ef0f51816e97277e40c5cf78f7bf9] source-hash-099198a4224778fe6e43f5dc13b5b9b1b4dc828c
git bisect bad 16b0b88cbd4ef0f51816e97277e40c5cf78f7bf9
# good: [598083cdb5699e7f45183da8b750815f62ff5485] source-hash-ecb1599ad00e71dfe05f3ae9a71bdce5f7540a40
git bisect good 598083cdb5699e7f45183da8b750815f62ff5485
# good: [cc1fc072dd691da3da43742dfc3fdd126157257b] source-hash-18c661f715a0b6850d30b374e5556dc14a377d2b
git bisect good cc1fc072dd691da3da43742dfc3fdd126157257b
# good: [fb0ce84a03588593a081ac3a26b2ada2d960b76c] source-hash-1aa91a2d8e7db5cebff5b47f3005f1acff64d25e
git bisect good fb0ce84a03588593a081ac3a26b2ada2d960b76c
# good: [d9be4b56c2e61bb94c677582dc92419f8468a927] source-hash-ef7a460fa51140782b7ad4d87aa782ca007c56ca
git bisect good d9be4b56c2e61bb94c677582dc92419f8468a927
# bad: [6d6e5252d2c81fa930cb89f3eaf0efadf09cb87f] source-hash-e3633f60b349022994e291aa3d1a0c90c3403b2e
git bisect bad 6d6e5252d2c81fa930cb89f3eaf0efadf09cb87f
# good: [b3713b7e6bccaa3c07695a358f2667f877d007d9] source-hash-9ca02a663c3eee2698eb360dd5dc7afb1951e743
git bisect good b3713b7e6bccaa3c07695a358f2667f877d007d9
# bad: [322dea02e8867272a756e7430e689699d2216aad] source-hash-18e6e7d929c2be209407ed2e56b8ec4d5e6c4900
git bisect bad 322dea02e8867272a756e7430e689699d2216aad
Comment 12 Xisco Faulí 2014-07-31 13:45:15 UTC
- Add 'regression' to keywords
- Add 'FILEOPEN' to summary
- Change platform to x86(IA32) All as it can be reproduced in Windows as well

This issue is still reproducible with Version: 4.3.1.0.0+
Build ID: 0d5d8c22f7be41d408d8ee4012ef1a6f4368423e
TinderBox: Win-x86@51-TDF, Branch:libreoffice-4-3, Time: 2014-07-23_05:34:04
Comment 13 Robinson Tryon (qubit) 2015-12-13 11:09:31 UTC Comment hidden (obsolete)
Comment 14 Justin L 2016-12-27 16:45:27 UTC
A lot has changed regarding borders and most complaints seem to be from the 3.6/4.0 time frame.  In 5.3beta2, in general things look pretty nice - not ugly. And specifically cell A1 is showing as a double line instead of a single-thick line.

I suggest (by marking it as worksforme) that this bug be closed since it doesn't seem to be a current issue.
Comment 15 Justin L 2016-12-27 16:46:38 UTC
Created attachment 129964 [details]
pdf of how it looks in Ubuntu x64 with LibreOffice 5.3beta2