Bug Hunting Session
Bug 57417 - LDAP address book support disappeared
Summary: LDAP address book support disappeared
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: All Linux (All)
: medium major
Assignee: DavidO
URL:
Whiteboard: target:4.1.0 target:4.0.1
Keywords: regression
: 105366 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-11-22 15:57 UTC by Lionel Elie Mamane
Modified: 2017-04-14 12:24 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
LDAP Address book support available (165.47 KB, image/png)
2012-12-22 11:55 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lionel Elie Mamane 2012-11-22 15:57:53 UTC
Version 4.0.0.0.alpha1 (Build ID: dec8fe) downloaded from http://dev-builds.libreoffice.org/pre-releases/deb/x86_64/

File / Wizards / Address Data Source

No "LDAP address data" choice. Was there in 3.6 and earlier (when compiled with mozilla, so not on Debian & Ubuntu, but was in our official builds).

We disabled mozab driver on Unix-like OSs, thinking we replaced it by mork driver. But mork only implements access to *mozilla* address books, not other address books that we were using mozilla code to access.

In an immediate way: reinstate mozab driver, but disable its handling of thunderbird/seamonkey address books on Unix-like OSs, leaving that role to mork driver.

Later: replace also these parts (see bug 57322)
Comment 1 DavidO 2012-11-22 21:57:35 UTC
Please don't ... as pointed out in this comment 

https://bugs.freedesktop.org/show_bug.cgi?id=57322#c5 

it was an accident that it got removed from non windows platform ... but a good one ;-)

I tend to reject this issue with won't fix.
Comment 2 Michael Meeks 2012-12-18 15:08:36 UTC
What was the resolution of this ?
Comment 3 DavidO 2012-12-19 07:15:13 UTC
The resolution is: LDAP support was discontinued starting with LO 4.0. This issue is going to be rejected with won't fix.
Comment 4 Jean-Baptiste Faure 2012-12-22 11:55:16 UTC
Created attachment 71969 [details]
LDAP Address book support available

(In reply to comment #3)
> The resolution is: LDAP support was discontinued starting with LO 4.0. This
> issue is going to be rejected with won't fix.

Really? It seems I have LDAP choice in Version 4.0.0.0.beta2+ (Build ID: d3b7a2bfe2a95153134f340c5a13a467de95a0d) under Ubuntu 12.04 x86_64. If I understand well the attached screenshot.

Best regards. JBF
Comment 5 Kohei Yoshida 2013-01-11 03:04:06 UTC
Let me just "confirm" this so that the QA people won't have to think hard about what to do with this bug...
Comment 6 Alex Thurgood 2013-01-11 08:00:55 UTC
Not only is it nice to have, but if you had it _already_ in a corporate setup, even with its current limitations and then it disappears, you will not endear corporations to your cause.

So, I don't see this being announced as one of the "features" for LO4 release ? In terms of communication, it should be announced though.


Alex
Comment 7 Alex Thurgood 2013-01-11 08:10:46 UTC
(In reply to comment #4)

> Really? It seems I have LDAP choice in Version 4.0.0.0.beta2+ (Build ID:
> d3b7a2bfe2a95153134f340c5a13a467de95a0d) under Ubuntu 12.04 x86_64. If I
> understand well the attached screenshot.
> 
> Best regards. JBF

Hi Jean-Baptiste,
Yes, the choice is there in the list of Address Book datasources via the Address Book wizard, but not in datasources in general, i.e. not in the Database Creation wizard.

If you choose LDAP as an address book datasource, you are taken to a dialog asking for a URL and an ID field. Leaving them blank and confirming leads to a failed driver load error.

Clicking on the Help button in that LDAP configuration dialog opens the Writer help !!

Searching for LDAP help content brings up help pages that bear no relation whatsoever to the dialog that is offered in the LDAP Address Book configuration wizard.


Alex
Comment 8 Lionel Elie Mamane 2013-01-14 10:10:26 UTC
(In reply to comment #7)
> (In reply to comment #4)

> Yes, the choice is there in the list of Address Book datasources via the
> Address Book wizard, but not in datasources in general, i.e. not in the
> Database Creation wizard.

> If you choose LDAP as an address book datasource, you are taken to a dialog
> asking for a URL and an ID field. Leaving them blank and confirming leads to
> a failed driver load error.

Ah, I see. The choice should definitely be removed/hidden from the wizard then.
Comment 9 DavidO 2013-01-14 10:25:44 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > (In reply to comment #4)
> 
> > Yes, the choice is there in the list of Address Book datasources via the
> > Address Book wizard, but not in datasources in general, i.e. not in the
> > Database Creation wizard.
> 
> > If you choose LDAP as an address book datasource, you are taken to a dialog
> > asking for a URL and an ID field. Leaving them blank and confirming leads to
> > a failed driver load error.
> 
> Ah, I see. The choice should definitely be removed/hidden from the wizard
> then.

Caolan told once that in gnome there is another LDAP connector implementation available and ReadHat supports it. I don't know, if the dialog above is also used in this case.
Comment 10 Caolán McNamara 2013-01-24 15:48:07 UTC
re "there is another LDAP connector implementation available and ReadHat supports it"

On Linux for address book, if evolution is enabled then you get access to LDAP with whatever is configured within evolution for LDAP as another option there. That was what I was referring to.
Comment 11 DavidO 2013-01-25 15:19:51 UTC
[12:05:39] <_david_> caolan: your comment #10 for fdo#57417 am i understand it right, that LO LDAP dialog is not needed for evolution <-> LDAP integration?
[12:07:16] <caolan> _david_: I *think* that might be the case, needs double checking what the non-evolution "ldap" radiobutton depends on, and what that dialog might also be used for
[12:07:27] <schoinobates> _david_: there are *two* LDAP choices in the address book assistant. "LDAP" (which is Moz) and "Evolution LDAP" (which is through Evolution)
[12:08:24] <caolan> my presumption at the moment is that we should remove the bare "LDAP" radiobutton from the address book assistant as pointing to nothing now, but leave the evo one
[12:08:43] <caolan> i.e. just remove that radiobutton option
[12:09:37] <caolan> do we still build the moz ldap stuff for windows these days, or is it gone there as well ?
[12:10:12] <_david_> caolan: we do. it is untouched
[12:10:40] <caolan> so an ifdef in the addressbook ui to hide it under non-windows (or whatever the logic for its existence is)
Comment 12 Alex Thurgood 2013-02-01 14:06:02 UTC
(In reply to comment #11)

> [12:09:37] <caolan> do we still build the moz ldap stuff for windows these
> days, or is it gone there as well ?
> [12:10:12] <_david_> caolan: we do. it is untouched
> [12:10:40] <caolan> so an ifdef in the addressbook ui to hide it under
> non-windows (or whatever the logic for its existence is)

So if I understand correctly, the situation will be the following ?
- Windows : LDAP support

- Linux : no LDAP support by default, unless the build happens to have added the evolution-ldap switch - how many distros do this ? or is it provided as a distro specific add-on?

- Mac : no LDAP support

That's a pretty sorry mess all in all.


Alex
Comment 13 DavidO 2013-02-04 18:53:18 UTC
Just uploaded a fix to gerrit to remove LDAP choice from Address Book Wizard dialog: https://gerrit.libreoffice.org/#/c/1983/
Comment 14 Not Assigned 2013-02-06 10:41:48 UTC
David Ostrovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=30957764a9ef77c53054866869adb50d049484e2

fdo#57417: remove LDAP choice from non windows platform



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 DavidO 2013-02-06 11:25:09 UTC
After Address Book Wizard Dialog has been cleaned to reflect the fact that Mozilla based LDAP provider was discontinued on non windows platforms, i am going to close this bug with Won't fix resolution. Any objections?
Comment 17 Not Assigned 2013-02-07 09:00:43 UTC
David Ostrovsky committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d68310c185886c6755849640d568c4597456282e&h=libreoffice-4-0

fdo#57417: remove LDAP choice from non windows platform


It will be available in LibreOffice 4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 18 Alex Thurgood 2013-02-07 09:54:38 UTC
Well, I was looking forward to being able to use LDAP on my OSX server, but hey, guess that's just gone out the window :-/
Comment 19 Lionel Elie Mamane 2013-02-07 10:25:01 UTC
(In reply to comment #18)
> Well, I was looking forward to being able to use LDAP on my OSX server, but
> hey, guess that's just gone out the window :-/

Were you able to use LDAP with LibreOffice 3.6 or earlier? This bug was marked WONTFIX under the assumption that the existing LDAP support was so limited (tied to a Mozilla-specific schema) to not be very useful anyway.

If you have contrary information, please speak up *now*.

GNU/Linux is still able to use LDAP via Evolution. Maybe "mac address book" also gives such an indirect access to LDAP?
Comment 20 Xisco Faulí 2017-01-16 20:05:25 UTC
*** Bug 105366 has been marked as a duplicate of this bug. ***
Comment 21 Bruno MONDIN 2017-01-17 07:18:16 UTC
I posted ticket Bug 105366.

If I understand correctly, it is no longer possible to connect an LDAP address book on non-Windows platforms.
But I have a platform in Windows 7 with version 5.1.6.2 and I have no choice of an LDAP connection.
It was however possible in version 5.0.6. We had set up on this version of mailing that used an LDAP address book. And with version 5.1, or 5.2, we can not anymore.

Why LDAP support is no longer available?

Under C: \ Program Files (x86) \ LibreOffice 5 \ share \ registry I have 2 files oo-ad-ldap.xcd.sample and oo-ldap.xcd.sample. What are they for ?

Thank you for your explanations.
Comment 22 DavidO 2017-01-17 07:29:34 UTC
(In reply to Bruno MONDIN from comment #21)
> I posted ticket Bug 105366.
> 
> If I understand correctly, it is no longer possible to connect an LDAP
> address book on non-Windows platforms.
> But I have a platform in Windows 7 with version 5.1.6.2 and I have no choice
> of an LDAP connection.
> It was however possible in version 5.0.6. We had set up on this version of
> mailing that used an LDAP address book. And with version 5.1, or 5.2, we can
> not anymore.
> 
> Why LDAP support is no longer available?

LDAP support was provided by ancient mozilla driver. Since 64 bit port LibreOffice was made available, mozilla driver was discontinued also in Windows. So, ther is no LDAP Any more on Windows platform.

> Under C: \ Program Files (x86) \ LibreOffice 5 \ share \ registry I have 2
> files oo-ad-ldap.xcd.sample and oo-ldap.xcd.sample. What are they for ?

Probably left over files.
Comment 23 Bruno MONDIN 2017-01-17 08:03:42 UTC
Thanks,

Is it planned to re-integrate the LDAP drivers into future versions?

regards