Bug 57422 - presenter console RTL support needs completion
Summary: presenter console RTL support needs completion
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.1.0
Keywords:
Depends on: 42070
Blocks: Presenter-Console RTL-UI
  Show dependency treegraph
 
Reported: 2012-11-22 16:46 UTC by Lior Kaplan
Modified: 2022-01-09 03:41 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test .odp. (323.98 KB, application/vnd.oasis.opendocument.presentation)
2018-09-17 17:16 UTC, Shlomi Fish
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lior Kaplan 2012-11-22 16:46:33 UTC
This is a follow up for bug 42070 which added RTL support for presenter console.

The missing parts are (taken from http://cgit.freedesktop.org/libreoffice/core/commit/?id=5e5c11c664f67ff9fd1120905b09a32bea3b2f6c):
1. Help layout.
2. Slide sorter view (slides alignment).
3. Note view buttons.
4. Scroll bars.
Comment 1 Not Assigned 2012-12-12 10:54:35 UTC
Faisal M. Al-Otaibi committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a77fa7ee84424a5844d836e83978ab0197716bef

fdo#57422 - presenter console RTL support needs completion



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 2 Not Assigned 2012-12-12 11:00:29 UTC
Faisal M. Al-Otaibi committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cfa0588e04ee3d132081212ac38fda7c83c45024

fdo#57422 - presenter console RTL support needs completion



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Not Assigned 2013-01-10 13:08:59 UTC
Abdulelah Alarifi committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=eb0d07d3f2937315700dabf72d366f5ef4d4200d

fdo#57422 - presenter console RTL support needs completion



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Not Assigned 2013-01-29 07:42:50 UTC
Ahmad Harthi committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e252ac072276a6e9459a5573c862e8066b78c29d

More fixes to fdo#57422



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2013-03-11 09:39:40 UTC
Abdulaziz A Alayed committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b977c27383b36f511bcedc8cd48c160a1c0be514

fdo#57422 fixing scroll bar and slides position



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2013-03-11 10:21:06 UTC
Abdulaziz A Alayed committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=32e593dc2da4266567cf80ee6bea7917e56572c7

fdo#57422 fixing scroll bar and slides position



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2016-10-23 12:46:29 UTC
Hello,
Is this bug already fixed?
If so, could you please close it as RESOLVED FIXED?
Comment 8 Omer Zak 2017-11-02 18:06:15 UTC
How to reproduce the bug in a buggy version (in order to verify that it has been fixed)?
Comment 9 Shlomi Fish 2018-09-17 17:14:21 UTC
How do I invoke the presenter console? On kde plasma 5 on mageia 7 x64 "F5" displays the slides and "alt+f5" does nothing. I'll attach a sample doc.
Comment 10 Shlomi Fish 2018-09-17 17:16:24 UTC
Created attachment 144953 [details]
Test .odp.
Comment 11 QA Administrators 2022-01-09 03:41:46 UTC
Dear Lior Kaplan,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://web.libera.chat/?settings=#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug