Bug Hunting Session
Bug 57469 - key handling broken in dialog Tools > Customize .. > Add
Summary: key handling broken in dialog Tools > Customize .. > Add
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: Other All
: medium major
Assignee: Caolán McNamara
URL:
Whiteboard: usabillity target:4.1.0 target:4.0.0....
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-11-23 22:49 UTC by Cor Nouws
Modified: 2012-12-12 14:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2012-11-23 22:49:17 UTC
- LibreOffice
- Tools > Customize
- Alt-A (for Add)
 > Add commands dialog opens fine

- Now try to move to an item in the list Category, e.g. Options
  e.g. arrow, TAB, and again...

 > Impossible to reach the Category list (focus moves to buttons)
- go there with the mouse, travel to the desired item
- Now try to move to the Command list
  e.g. arrow, TAB, and again...
 > Impossible to reach the Command list, (focus moves to buttons)
Comment 1 Cor Nouws 2012-11-23 22:51:20 UTC
also see bug 51556

@caolan: since you did work for the new ui files, you may know where / how / who ;-)
Comment 2 Cor Nouws 2012-11-25 11:51:45 UTC
( similar problem:
Writer Isert . Special character... try to get to the table with charaters with arrow / TAB ... does not work. )
Comment 3 Not Assigned 2012-12-12 13:30:34 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=166d8257979aac6775319a9e1f305bc94df97e29

Resolves: fdo#57469 allow tab to traverse into custom widgets



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Not Assigned 2012-12-12 13:36:37 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7d34a702136765cab15edb47aecae9181edd2802&g=libreoffice-4-0

Resolves: fdo#57469 allow tab to traverse into custom widgets


It will be available in LibreOffice 4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Cor Nouws 2012-12-12 14:14:35 UTC
thanks :-)
This makes it no more needed for me - I expect - to list other dialogs with the same problem.