Bug Hunting Session
Bug 51556 - FORMATTING [accessibility] Tab/keyboard behaviour in dialog Conditional formatting strange
Summary: FORMATTING [accessibility] Tab/keyboard behaviour in dialog Conditional forma...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.0.beta2
Hardware: Other Linux (All)
: medium major
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.1.0 target:4.0.4
Keywords:
: 56908 (view as bug list)
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2012-06-29 05:07 UTC by Cor Nouws
Modified: 2013-04-29 10:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2012-06-29 05:07:07 UTC
Open dialog Formatting > Conditional Formatting
Focus is on ADD
So hit space
 > OK works
Try to go to the list control for the Condition with Tab or so
 > does not work = not OK
Use the mouse to go to the list control 
Make a selection
Tab to go to the field for a value/formula or so
 > focus goes to ADD = not OK
Comment 1 Markus Mohrhard 2012-06-29 16:23:27 UTC
Is expected because I did not yet specify any tab parameters and/or tab order. Will do that for RC1.
Comment 2 Markus Mohrhard 2012-08-06 17:14:06 UTC
This did not make it into RC1 will include it in 3.6.1
Comment 3 Markus Mohrhard 2012-08-06 17:23:14 UTC
Hmm seems that it is not easily possible. The problem is that the entry is a special control which gives all the control to its parent. I need tot hink more about it.
Comment 4 Cor Nouws 2012-11-09 21:04:25 UTC
*** Bug 56908 has been marked as a duplicate of this bug. ***
Comment 5 Cor Nouws 2012-11-09 21:05:44 UTC
keyword 'regression' .. new functionality.. ah well, the old dialog worked with key-board navigation :-)
Comment 6 Cor Nouws 2012-11-23 22:51:42 UTC
(also see bug 57469)
Comment 7 Caolán McNamara 2013-04-29 09:08:41 UTC
The trick here (with the classic .src format) is using DialogControl to specify that the tab traversal goes "into" controls that are containers for other controls.
Comment 8 Caolán McNamara 2013-04-29 09:13:06 UTC
proposed to 4-0 as https://gerrit.libreoffice.org/3656
Comment 9 Commit Notification 2013-04-29 09:14:21 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f0596516b943f90632ff4bbca83f4ce825e3b433

Resolves: fdo#51556 allow tab traversing into the conditional formatting list



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2013-04-29 10:46:40 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=24eb9d6f32397dabf5e52671090fd7607bcc1cf2&h=libreoffice-4-0

Resolves: fdo#51556 allow tab traversing into the conditional formatting list


It will be available in LibreOffice 4.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.