Bug Hunting Session
Bug 57472 - Tabbed dialogs not erasing backgrounds
Summary: Tabbed dialogs not erasing backgrounds
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: Other Windows (All)
: medium major
Assignee: Ivan Timofeev (retired)
URL:
Whiteboard: target:4.0.0
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-24 03:31 UTC by Urmas
Modified: 2012-11-25 03:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Urmas 2012-11-24 03:31:58 UTC
The tabbed dialogs in recent build do not eraase background when switching tabs.
This is regression introduced since November 20.
Comment 2 Ivan Timofeev (retired) 2012-11-24 13:29:45 UTC
Yes, I am to blame, indeed... Thanks for the report.
Comment 3 Not Assigned 2012-11-24 14:09:24 UTC
Ivan Timofeev committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=59e59a16c1e9189458aafc9875eab989484f5191

fdo#57472: VclContainer: make it paint-transparent



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Urmas 2012-11-25 03:32:30 UTC
*** Bug 57499 has been marked as a duplicate of this bug. ***