Bug Hunting Session
Bug 57499 - Word Count: ugly and unreadable numbers when writing while the window is open
Summary: Word Count: ugly and unreadable numbers when writing while the window is open
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha1
Hardware: All All
: medium normal
Assignee: Ivan Timofeev (retired)
URL:
Whiteboard: target:4.0.0
Keywords:
Depends on:
Blocks: Word-Count
  Show dependency treegraph
 
Reported: 2012-11-25 00:16 UTC by Stefan Knorr (astron)
Modified: 2016-10-24 21:20 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (13.13 KB, image/png)
2012-11-25 00:16 UTC, Stefan Knorr (astron)
Details
Screenshot (13.13 KB, image/png)
2012-11-25 00:18 UTC, Stefan Knorr (astron)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Knorr (astron) 2012-11-25 00:16:09 UTC
Created attachment 70530 [details]
Screenshot

Since the conversion of word count to .ui, there is this bug:

#1 Open Writer
#2 Go to Tools > Word Count
#3 Now select your document window and type something (don't close Word Count)

Result: numbers are overlaid over each other and become unreadable.
Comment 1 Stefan Knorr (astron) 2012-11-25 00:18:05 UTC
Created attachment 70531 [details]
Screenshot

Correct MIME type for screenshot
Comment 2 Urmas 2012-11-25 03:32:30 UTC

*** This bug has been marked as a duplicate of bug 57472 ***
Comment 3 Stefan Knorr (astron) 2012-11-25 11:28:37 UTC
Reopening, as it is not fixed (I rebuilt just now and it still looks the same).

Adding Ivan to CC, maybe he knows what to do here...
Comment 4 Not Assigned 2012-11-25 14:36:32 UTC
Ivan Timofeev committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=87c923be603d0b3706c481281549a79c8b8bcd41

fdo#57499: VclContainer: enable child transparent mode



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Ivan Timofeev (retired) 2012-11-25 14:44:01 UTC
It was my silliness again, sorry.