Bug 57502 - FILESAVE as .xlsx (OOXML) corrupts document with hidden grouped areas
Summary: FILESAVE as .xlsx (OOXML) corrupts document with hidden grouped areas
Status: RESOLVED DUPLICATE of bug 100347
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-25 08:17 UTC by Rainer Bielefeld Retired
Modified: 2016-07-03 21:13 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-11-25 08:17:51 UTC
Steps how to reproduce with parallel installation of  "LOdev  4.0.0.0.alpha1   -  ENGLISH UI / German Locale  [Build ID: dec8fe)]"  {tinderbox: @6, pull time 2012-11-13 06:07:28} on German WIN7 Home Premium (64bit) with separate /4 User Profile for Master Branch:

1. download and open  Attachment 70526 [details] of Bug 51524 
2. Save document as "simplesample11.xlsx" (OOXML)
3. save and close
4. reopen 
   Expected: Small '+' icon above Column D heading as in .odt
   Actual: '+' is missing

That's not a simple UI problem, Excel 2010 will complain a corrupted document (and after repair also the Small '+' icon above Column D heading is missing)
Comment 1 billhook 2012-11-25 22:38:42 UTC
Confirmed on LO 3.6.4.1 Windows Vista 32bit

@Rainer Your example mentions LO 4.0. Have you also seen this on LO 3.3?
Comment 2 Rainer Bielefeld Retired 2012-11-26 05:25:00 UTC
Sorry, I forgot to mention! Yes, I really did a test with 3.3.0 where the problem already was visible.
Comment 3 Winfried Donkers (retired) 2014-12-04 11:17:53 UTC
Still present in 4.3.4.1 (Windows7) and in 4.5.0.0.alpha0+ (openSUSE13.1).
Comment 4 QA Administrators 2015-12-20 16:16:47 UTC Comment hidden (obsolete)
Comment 5 Bartosz 2016-07-03 21:13:30 UTC
I checked that issue and it is resolved together with:
https://bugs.documentfoundation.org/show_bug.cgi?id=100347

After saving to simplesample11.xlsx everything is working as expected.

*** This bug has been marked as a duplicate of bug 100347 ***