Bug 57626 - Macro assigned to print event does not execute
Summary: Macro assigned to print event does not execute
Status: RESOLVED DUPLICATE of bug 58269
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-27 20:17 UTC by 0241586279
Modified: 2013-01-02 09:42 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test document execute macro on print event (10.52 KB, application/vnd.oasis.opendocument.text)
2012-11-30 13:59 UTC, stfhell
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 0241586279 2012-11-27 20:17:37 UTC
Problem description: 
Macros déclenchées par événement Imprimer le document 
Steps to reproduce:
1. ....
2. ....
3. ....

Current behavior:
événement non détecté, macro non exécutée
Expected behavior:
détection événement
              
Operating System: All
Last worked in: 3.6.3.2 release
Comment 1 stfhell 2012-11-30 13:59:11 UTC
Created attachment 70834 [details]
test document execute macro on print event

I can confirm that a macro associated with event "print document" does not execute on print. Tested with LO 3.5.4.2 and a 3.7 build; also with AOO 3.4.1 where this also does not work (see ApacheBug 118893). So I don't think it is a regression.
Comment 2 stfhell 2012-11-30 14:02:20 UTC
Removed "regression" from keywords, added link to Apache bug.
Comment 3 Julien Nabet 2012-12-22 19:27:35 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce this.
However, security options must obviously be tuned to enable macros (which is not the by default case).

With 3.6 sources updated yesterday, even by putting security macros at lowest, it doesn't work and so I can reproduce the problem with 3.6

Rainer: any idea about what should be the status of this tracker?
Comment 4 Julien Nabet 2012-12-22 19:28:44 UTC
stfhell: on which env did you test?
Comment 5 stfhell 2012-12-23 12:59:20 UTC
(In reply to comment #4)
> stfhell: on which env did you test?

Test system was also Linux (Ubuntu 12.04/AMD64), LO 3.5 from Ubuntu repository, the 3.7 build compiled from sources some 3-4 weeks ago (I don't have the system available at the moment). Macro security was set to medium (confirm execution for each document).
Comment 6 0241586279 2012-12-24 16:00:09 UTC
Le 23/12/2012 13:59, bugzilla-daemon@freedesktop.org a écrit :
>
> *Comment # 5 <https://bugs.freedesktop.org/show_bug.cgi?id=57626#c5> 
> on bug 57626 <https://bugs.freedesktop.org/show_bug.cgi?id=57626> from 
> stfhell <mailto:stfhell@googlemail.com> *
> (In reply tocomment #4  <show_bug.cgi?id=57626#c4>)
> > stfhell: on which env did you test?
>
> Test system was also Linux (Ubuntu 12.04/AMD64), LO 3.5 from Ubuntu repository,
> the 3.7 build compiled from sources some 3-4 weeks ago (I don't have the system
> available at the moment). Macro security was set to medium (confirm execution
> for each document).
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
os : XP, ubuntu 12.10, ubuntu, ubuntu 13.04
Securite : faible
Comment 7 LeMoyne Castle 2013-01-02 09:42:27 UTC
Dup of Bug 58269 which has patch merged to master that  reinstates  Print event registration code.

*** This bug has been marked as a duplicate of bug 58269 ***