Bug 58269 - Macros: OnPrint Event
Summary: Macros: OnPrint Event
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other All
: medium normal
Assignee: Noel Power
URL:
Whiteboard: BSA target:4.0.0.1 target:3.6.5
Keywords: regression
: 57626 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-13 21:44 UTC by 0241586279
Modified: 2013-01-04 09:42 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description 0241586279 2012-12-13 21:44:19 UTC
Problem description: 

Steps to reproduce:
1. ....
2. ....
3. ....

Current behavior:
La macro démarre et stoppe à la première instruction. 
Expected behavior:
Exécution des instructions.
              
Operating System: All
Last worked in: 3.6.4.3 release
Comment 1 Noel Power 2012-12-19 11:19:27 UTC
if you want someone to look at your problem then you need to actually provide
an example of something that fails. There is no information here that would
allow someone to reproduce your bug :-/
It would be really helpful for you to provide the smallest macro example ( perhaps
in a module in a document ) that shows your problem
Comment 2 Noel Power 2012-12-19 12:32:42 UTC
hmm, ok OnPrint in the title should be enough for me to understand where the
problem is

>3.6.4.3

I doubt that, I see even in the 3.5 branch that there seems to be *no* instance
where this event is posted anymore. It seems that the printing code has got
changed/reworked and the it looks like this event got dropped.

anyway I'll take it
Comment 3 Not Assigned 2012-12-20 19:31:42 UTC
Noel Power committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=86a6acaa60b514a07948ecc8063f5e674dda8f34&g=libreoffice-4-0

post OnPrint event ( application & document ) when printing starts fdo#58269


It will be available in LibreOffice 4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 LeMoyne Castle 2013-01-02 09:42:27 UTC
*** Bug 57626 has been marked as a duplicate of this bug. ***
Comment 5 Noel Power 2013-01-03 15:48:16 UTC
marking as fixed, it's in 4.0 branch and a backport is out for review for 3.6
Comment 6 Not Assigned 2013-01-04 09:42:12 UTC
Noel Power committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0dbb66fb59205507824534b7130fab1cf2db3eae&h=libreoffice-3-6

post OnPrint event ( application & document ) when printing starts fdo#58269


It will be available in LibreOffice 3.6.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.