Download it now!
Bug 57815 - Wrong closing » instead of « opening quotation mark behind apostrophe in French language text
Summary: Wrong closing » instead of « opening quotation mark behind apostrophe in Fren...
Status: RESOLVED DUPLICATE of bug 38394
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-02 19:06 UTC by Échec et Matt
Modified: 2014-05-03 20:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample Document (8.48 KB, application/vnd.oasis.opendocument.text)
2013-02-18 06:35 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Échec et Matt 2012-12-02 19:06:02 UTC
In French, we use this type of quotation mark : « and ». i want to report a bug I found today : when, after an apostrophe (http://en.wikipedia.org/wiki/Apostrophe), you want to quote a citation and you type ", it show » and not «.

Example : Je suis l'»homme » le plus idiot du monde.

It should be : Je suis l'« homme » le plus idiot du monde.

Thanks for what you do, I use LibreOffice every day.

And sorry for my English, I'm just a fifteen years old student ;-)


Operating System: Ubuntu
Comment 1 Rainer Bielefeld Retired 2013-02-18 06:30:30 UTC
The effect is reproducible with  "LibreOffice 3.6.5.2 " German UI/ French Locale [Build-ID: 5b93205] {pull date 2013-01-18} on German WIN7 Home Premium (64bit):

0. Launch LibO, modify locale settings as mentioned above.
1. Open new writer Document from LibO Start center
2. Menu 'Tools -> Language -> All Document -> French'
3. type 
     Il est un "homme" mal                             becomes
     Il est un « homme » mal
   what might be ok, please see the automatically inserted blanks
4. type   
     Il est l' "homme"  mal                           becomes
     Il est l' »homme » mal
   please see the automatically inserted blanks and the wrong "»"

There are some special punctuation rules in French language what differ from those in English and German Language, for example unbreakable spaces
<http://fr.wikipedia.org/wiki/Ponctuation#Les_espaces_autour_des_signes_de_ponctuation_.28r.C3.A8gles_actuelles.29> (French language text).

How to use apostrophe and opening uqotation mark correctly, you can see (for example) on <http://fr.wikipedia.org/wiki/Apostrophe_%28typographie%29#Aspect_de_l.E2.80.99apostrophe> in the first line of that paragraph: 
"  définition d’« une virgule que l’on met un peu au dessus du mot » dès la première édition "

Currently the only workaround seems to be to type a blank after the apostrophe and to delete that after having typed the opening quotation mark, see "Bug 38394 - EDITING: Can't insert a French opening quote after an apostrophe using AutoCorrection"

I see the same in LibO 3.3.3, AOOo 3.4 ans Symphony, so this problem seems inherited from OOo.

@Jean Baptiste:
Any idea how this can be fixed?
Comment 2 Rainer Bielefeld Retired 2013-02-18 06:35:00 UTC
Created attachment 75029 [details]
Sample Document

See comment above!
Comment 3 Jean-Baptiste Faure 2013-02-27 05:49:40 UTC
I guess that ' and " are treated in the same way when the code has to decide if such key is an opening or a closing one. The problem is that I do not know where to look in the source code. Will ask Cédric.

Best regards. JBF
Comment 4 Jean-Baptiste Faure 2013-07-13 16:22:12 UTC
Hi Cédric, 

Do you have any idea how to fix this problem?

Best regards. JBF
Comment 5 Cédric Bosdonnat 2014-01-20 09:00:26 UTC
Restricted my LibreOffice hacking area
Comment 6 Julien Nabet 2014-05-03 20:39:21 UTC
Indeed a dup not just related.

*** This bug has been marked as a duplicate of bug 38394 ***